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I tweak the light settings for weeks, but it still doesn’t match the light in your eyes.

I scan and layer a hundred photos, but it still doesn’t capture the
details of your soft skin.

I apply every controller and animation technique, but it still can’t portray the
intricacies of your tiny smile.

I load hundreds of sound files, but it still isn’t equal to the synchronization
of your little laugh.

I render thousands of times, and still I'm amazed at the work of the Master Animator.

To Max, 2003






Preface

Whenever [ withdrew to the computer room, my wife would say that [ was off to my “fun and
games.” | would flatly deny this accusation, saying that it was serious work that I was involved in.
But later, when I emerged with a twinkle in my eye and excitedly asked her to take a look at my lat-
est rendering, | knew that she was right. Working with 3D graphics is pure “fun and games.”

My goal in writing this book was to take all my fun years of playing in 3D and boil them down into
something that’s worthwhile for you — the reader. This goal was compounded by the fact that all
you Max-heads out there are at different levels. Luckily, this book is thick enough to include a little
something for everyone.

The audience level for the book ranges from beginning to intermediate, with a smattering of
advanced topics for the seasoned user. If you're new to Max, then you’ll want to start at the begin-
ning and move methodically through the book. If you're relatively comfortable making your way
around Max, then review the table of contents for sections that can enhance your fundamental
base. If you're a seasoned pro, then you’ll want to watch for coverage of the features new to
Release 6.

If you're so excited to be working with Max that you can’t decide where to start, then head straight
for the Quick Start. The Quick Start is a single chapter-long tutorial that takes you through the cre-
ation of an entire scene and animation. This Quick Start was included in response to some feedback
from readers of the first edition who complained that they didn’t know where to start. For those of
you who were too anxious to wade through a mountain of material before you could create some-
thing, this Quick Start is for you.

Another goal of this book is to make it a complete reference for Max. To achieve this goal, I've gone
into painstaking detail to cover almost every feature in Max, including coverage of every primitive,
material and map type, modifier, and controller.

As this book has come together, I've tried to write the type of book that I'd like to read. I've tried to
include a variety of scenes that are infused with creativity. It is my hope that these examples will
not only teach you how to use the software, but also provide a creative springboard for you in your
own projects. After all, that’s what turns 3D graphics from work into “fun and games.”

Who Is Max?

Max is coming of age. Now with the number 6 attached to its name, it is starting to show some
maturity. I'd say that version numbers are akin to dog years, which would place Max in its early 40s.

Before we go any further, I should explain my naming convention. The official name of the product in
this release is 3ds max 6 with a lowercase m, but [ simply refer to it as Max with a capital M. This ref-
erence is a nickname given to a piece of software that has become more familiar to me than the family
pets (whose names are Fuzzy, Curious, and Parakeetsta, by the way). Note: I have not been successful
in training Max to come when I call or to sit on command, but it will on occasion play dead.

One way we humans develop our personalities is to incorporate desirable personality traits from
those around us. Max’s personality is developing as well — every new release has incorporated a
plethora of desirable new features. Many of these features come from the many additional plug-ins
being developed to enhance Max. With Release 6, many features that were available as plug-ins for
previous releases have been adopted by Max. Several new features have been magically assimilated
into the core product, such as mental ray. These additions make Max’s personality much more lik-
able, like a human developing a sense of humor.
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Other personality traits are gained by stretching in new directions. Max and its developers have
accomplished this feat as well. Many of the new features are completely new, not only to Max, but
to the industry, such as the Particle Flow interface. As Max grows up, it will continue to mature by
adopting new features and inventing others. I just hope Max doesn’t experience a mid-life crisis in
the next version.

About This Book

Let me paint a picture of the writing process. It starts with years of experience, which is followed
by months of painstaking research. There were system crashes and personal catastrophes and the
always-present, ever-looming deadlines. | wrote into the early hours of the morning and during the
late hours of the night — burning the candle at both ends and in the middle all at the same time. It
was grueling and difficult, and spending all this time staring at the Max interface made me feel like .
.. well...like an animator.

Sound familiar? This process actually isn’t much different from what 3D artists, modelers, and ani-
mators do on a daily basis, and, like you, I find satisfaction in the finished product.

Tutorials aplenty

I've always been a very visual learner — the easiest way for me to gain knowledge is by doing
things for myself while exploring at the same time. Other people learn by reading and comprehend-
ing ideas. In this book, I've tried to present information in a number of ways to make the informa-
tion usable for all types of learners. That is why you see detailed discussions of the various
features along with tutorials that show these concepts in action.

The tutorials appear throughout the book and are clearly marked with the “Tutorial” label in front
of the title. They always include a series of logical steps, typically ending with a figure for you to
study and compare. These tutorial examples are provided on the book’s CD-ROM to give you a first-
hand look and a chance to get some hands-on experience.

I've attempted to “laser focus” all the tutorials down to one or two key concepts. This means that
you probably will not want to place the results in your portfolio. For example, many of the early
tutorials don’t have any materials applied because I felt that using materials before they’ve been
explained would only confuse you.

I've attempted to think of and use examples that are diverse, unique, and interesting, while striving
to make them simple, light, and easy to follow. I'm happy to report that every example in the book
is included on the CD-ROM along with the models and textures required to complete the tutorial.

The tutorials often don’t start from scratch, but instead give you a starting point. This approach
lets me “laser focus” the tutorials even more; and with fewer, more relevant steps, you can learn
and experience the concepts without the complexity. On the book’s CD-ROM, you will find the Max
files that are referenced in Step 1 of most tutorials.

I've put lots of effort into this book, and I hope it helps you in your efforts. I present this book as a
starting point. In each tutorial, I've purposely left most of the creative spice out, leaving room for
you to put it in — you’re the one with the vision.

Fourth time around

This book is now in its fourth edition and, like aged cheddar cheese, is getting better with time.
This edition posed an interesting dilemma. The edition for Max 4 clocked in at 1,246 pages, which
was the largest number of pages that can be bound into a paperback book. So, for Max 5, | needed
to rework and tighten the content to make room for pages where the new features could be cov-
ered, which was an tough task, but I was happy to say I succeeded by cramming in an additional
400 pages worth of content into the 3ds max 5 Bible. However, when the book came back from the
printer, it weighed in at only 1,106 pages, making the reader think that the book was put on a diet. It
turned out that the editors who laid out the book decided to use a tighter layout, thereby saving
140 pages while providing the additional content.
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Now that I'm working on a version covering Max 6, I'm delighted to have that extra 140 pages to
cram full of information, and the editors are already looking at an even tighter format. At this rate,
the next couple of editions will be shipping with a magnifying glass.

There have been several other changes to this edition. In an effort to add some new life to many of
the older tutorials (several of which desired a chance to retire), I have secured a new set of
Viewpoint models that I've used to replace many of the old tutorials. I've also included a new Quick
Start that lets you play with a monster truck.

How this book is organized

Many different aspects of 3D graphics exist, and in some larger production houses, you might be
focused on only one specific area. However, for smaller organizations or the general hobbyist, you
end up wearing all the hats — from modeler and lighting director to animator and post-production
compositor. This book is organized to cover all the various aspects of 3D graphics, regardless of
the hat on your head.

The book is divided into the following parts:

4 Quick Start — This single chapter (which is actually a chapter in Part I) is an entire anima-
tion project presented in several focused tutorials. It is designed to whet your appetite and
get you up to speed and producing animations immediately.

4 Part I: Learning the Max Interface — Whether it’s understanding the interface, working with
the viewports, dealing with files, or customizing the interface, the chapters in this part get
you comfortable with the interface so you won't get lost moving about this mammoth pack-
age.

4 Part II: Working with Objects — Max objects can include meshes, cameras, lights, Space
Warps, and anything that can be viewed in a viewport. This part includes chapters on how to
reference, select, clone, group, link, transform, and modify these various objects.

4 Part III: Modeling — Max includes several different ways to model objects. This part
includes chapters on working with spline shapes, meshes, polys, patches, NURBS, com-
pound objects like Lofts and Morphs, and particle systems.

4 Part IV: Materials and Maps — With all the various materials, maps, and parameters, under-
standing how to create just what you want can be difficult. These chapters explain all the
various types and how to use them.

4 Part V: Cameras — This part describes how to control cameras and use the Camera
Matching and Tracking utilities and the Multi-Pass Camera effects.

4 Part VI: Lighting — This part describes how to create and control the standard lights, as
well as coverage on advanced lighting, radiosity, and global illumination.

4 Part VII: Animation — To animate your scenes, you'll want to learn about keyframing, the
Track Views, constraints, and controllers. This part includes a chapter specifically on
expressions.

4 Part VIII: Character Animation — I cover creating and working with characters, bone sys-
tems, skinning, rigging, and character modeling in this part. I also provide complete cover-
age of the various inverse kinematics methods.

4 Part IX: Dynamics — This part includes coverage of Space Warps, the Dynamics utility, and
all the cool features found in Reactor.

4 Part X: Rendering — To produce the final output, you can render the scene as described in
this part. In addition, this part discusses environments, Render Elements, Render Effects,
network rendering, raytracing, and mental ray.

4 Part XI: Compositing and Post-Production — This part describes the compositing process
using external tools, as well as post-processing using the Video Post interface.

4 Part XII: MAXScript and Plug-Ins — This part provides details on using Max’s scripting lan-
guage, MAXScript, and on using plug-ins.
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4 Part XIII: Max in Action — Max is used in many different industries and this part addresses
specific features used to enable Max for games, visualization, and special effects.

4+ Appendixes — At the very end of this book, you'll find four appendixes that cover the new
features of Max 6, installation and system configuration, Max keyboard shortcuts, and the
contents of the book’s CD-ROMs.

Using the book’s icons

The following margin icons are used to help you get the most out of this book:

/'Note Note boxes highlight useful information that you should take into consideration.
‘,,p’
Tip Tips provide an additional bit of advice that will make a particular feature quicker or easier
2 to use.
4
Caution Cautions warn you of a potential problem before you make a mistake.
::\Iew \ The New Feature icon highlights features that are new to Release 6.
eature

- Cross-

| Referen

Watch for the Cross-Reference icon to learn where in another chapter you can go to find
CE more information on a particular feature.

This icon points you toward related materials that are included on the book’s CD-ROM:s.

The book’s CD-ROMs

Computer book CD-ROMs are sometimes just an afterthought that includes a handful of examples
and product demos. This book’s CD-ROMs, however, include a full, working trial version of 3ds max
6. Max is an expensive piece of software to just play around with, but the trial version gives you 30
days to try out the software and gain some valuable experience. Appendix D, “What’s on the
CD-ROMs,” supplies the details of the content on the CD-ROMs.

The CD-ROMs include a selection of 3D models that you can use in your projects if you choose. Many
of these models are used in the tutorials. The CD-ROMs also include the Max files for every tutorial.

If you haven’t noticed yet, most of this book is printed in black and white. This can make seeing the
details (and colors) of the figures difficult. The CD-ROM includes a complete searchable version of
the book along with all the figures in color.

Color insert pages

The possibilities of Max are endless, but many individuals and groups have pushed the software a
long way. As a sampling of the finished work that can be created, I've included a set of color insert
pages that showcase some amazing work done with Max. The 3D artists represented in these pages
give you some idea of what is possible.
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Quick Start:

Animating a

Monster Truck e
at the Beach

Quick Start project

+ o+ e

Creating the
background scene

hen you first got your hands on 3ds max, you were probably Importing the
' - truck model
focused on one goal —to create cool 3D images and anima-
tions. | know many of you bought Max to make money, claim a tax
write-off, earn a way to Hollywood, or impress your girlfriend or
boyfriend, but I'll just ignore those reasons for now. The goal is to
create something cool.

Adding scene props
Applying materials

Loading a background

If you've perused this book’s Table of Contents or thumbed through :
image

its many pages, you've seen sections on modeling, NURBS, dynamics,
and other topics. But if you're like me, you don’t want to wade

through tons of material before you have something to show off to Animating the truck

Mom. (Actually, if you're like me, then you’'ve opened straight to the with keys
special effects section, in which case you won’t be reading this.) Adding lights
The purpose of this Quick Start is to give you a taste of what Max can )

do. This soaring view of the software from 20,000 feet is intended to Zooming out
show you the big picture before you delve into the details. It exposes the camera

you to the most common features and whets your appetite for the

more in-depth chapters to follow. Adding special effects

This part of the book is intended for those new to the software. If Rendering the

you're an experienced user, then your mom is no doubt already final animation
impressed with your work, so you can happily advance to whichever

chapter appeals to you. (Forgive me for catering to the “newbie,” but + + + +

we were all beginners once.)

Relaxing at the Beach

No matter where you’re from, warm sunshine appeals to everyone, so
this Quick Start (as the chapter titles suggests) takes place at the
beach. Now, monster trucks aren’t a regular sight at the beaches that
I frequently visit, which brings me to the example concept. The first
step in any animation is to have a clear concept in mind and, I hope, a
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fleshed-out storyboard. (I'd include a figure of my storyboard for this example, but it wouldn’t
impress you, especially as the first figure in the book.)

The concept is a classic misdirection piece. This type of story is designed to get the viewer
to position his line of thinking in one direction, and then to reveal more information that
realigns his thinking. So, we start with a monster truck that is digging and grinding through
a rough terrain as if it were part of a monster truck rally. The camera then dollies out of the
scene to reveal a child’s sand bucket and shovel on the beach where the monster truck is
actually a toy.

Now that we have a good concept for the animation, we need a game plan for walking through
the example. To do this, the Quick Start is divided into several consecutive tutorials. Each
successive tutorial builds upon the previous one, and the final goal is to complete a rendered
animation. The tutorials include the following:

4+ Creating the background terrain and scene

4+ Importing a digital model of the monster truck

4 Adding props to the scene

4+ Applying materials to all the scene elements

4 Loading a background image

4 Animating the truck’s movements

4+ Adding lights to the scene

4 Adding a camera to the scene and animating its motion
4+ Adding special effects

4+ Rendering the final animation

This Quick Start is divided into separate tutorials, with each tutorial containing a series of
easy-to-follow steps. These steps are intended to show you the results of performing certain
Max operations, but feel free to deviate from these steps to create your own results. Being
creative and exploring the software is the best way to learn.
5 After each of the following tutorials, | saved the scene file. You can find these files on the
\\ book’s CD along with the examples in the Quick Start directory.
J

-’/

Tutorial: Creating the background terrain and scene

Our first step is to create the major elements that make up the scene. This gives the scene a
perspective that the other objects can reference. The major elements of the beach are a
ground plane of sand and another for the water. These can be created easily using Max primi-
tive objects.

To create Plane objects for the sand and the sea, follow these steps:

1. Select Create > Standard Primitives > Plane, and drag in the Top viewport to create a
Plane object. In the Name and Color rollout of the command panel, name this object
Sea. Click the color swatch in the Name and Color rollout, select a blue color in the
Object Color dialog box, and click OK.
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2. Click the Select and Move tool on the main toolbar (or press the W key), hold down the
Shift key, and select and drag the Transform Gizmo’s Y axis downward. This clones the
“Sea” plane object. Position it directly below its original so that the cloned object’s top
edge is aligned with the “Sea” object’s bottom edge. A Clone Options dialog box
appears; make sure that the Copy option is selected, type the name Sand for this
object, and click OK. Click the object color swatch in the Name and Color rollout of the
command panel, select a light brown color in the Object Color dialog box, and click OK.

3. With the “Sand” plane object selected, open the Modify panel and change the Length
and Width Segment values to 20. This adds more faces to the “Sand” object. Then set
the Scale Render Multiplier value to 4.0.

4. Select Modifiers > Parametric Deformers > Noise to apply the Noise modifier to the
“Sand” object. Change the Z-axis Strength in the Parameters rollout to 10 to add some
slight bumps to the “Sand” object.

5. Click the Select and Rotate tool on the main toolbar (or press the E key), and rotate the
“Sand” object two or three degrees about its Z axis in the Left viewport.

6. Click the “Sea” object to select it, and change its Scale Render Multiplier value to 4.0.

The Scale Render Multiplier value changes the scale of the object when rendered, giv-
ing us a long stretch of sea and sand.

The results of this tutorial created a shoreline that isn’t perfectly straight, and the sea meets
the sand along the entire edge. To see the results, select the Perspective viewport and choose
Rendering = ActiveShade Floater. This renders the active viewport in the ActiveShade Floater
window, as shown in Figure QS-1. This tutorial is saved on the CD as Sea and sand.max.

[ ActiveShade (1:1) (SE[%]
Hielele ¢ o X [Fooim | |

Figure QS-1: The shoreline was created using two simple Plane objects.
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Tutorial: Importing the monster truck model

Accurately modeling an object such as the monster truck can take many months of skilled
work, which brings me to my first tip of modeling— don’t rebuild it when it’s already been
done for you. You can find many repositories of digital models — from Web sites to software
dealers, to the CD-ROM in the back of this book. An untold number of models exist, covering
almost any possible subject matter you could think of. The difficult part is wading through all
the available models to find the exact model you need, and if it doesn’t fit your exact needs,
you can always modify an existing model to fit your needs.

—

The monster truck model was created and provided by Viewpoint Datalabs, and the book’s
CD-ROM includes a version of this model that you can use.

Follow these steps to learn the easiest method for modeling:

1.

Insert the CD-ROM from the back of the book, and then choose File &> Merge.

The Merge File dialog box appears.

. On the CD-ROM, locate the vp3417.max file in the Quick Start directory and click OK.

The Merge dialog box appears and lets you select which objects to merge with the
existing scene. Click the All button, and then click OK.

. The monster truck appears in the center of the viewports at the grid’s origin. The truck

is made up of many different objects, and moving them all together is easier if they are
grouped together, so while all the truck objects are still selected, choose Group =
Group. In the Group dialog box that appears, name the group Monster truck and

click OK.

. If you look at the truck object in the Left viewport, you can see that its wheels are

below the “Sand” object. To reposition the truck, select the Zoom Extents All Selected
button in the Viewport Navigation Controls in the lower-right corner of the interface.

This button is found as a flyout under the Zoom Extents All button. Or you can just
press the Z key. This zooms in on the selected object in all viewports.

. Click the Select and Move tool on the main toolbar (or press the W key), and drag the

truck upward and to the right in the Left viewport. Press the Z key again to center the
truck in its new location. Continue to move the truck to the right in the Left viewport
until it is in the center of the “Sand” plane.

. Click the Select and Rotate (E) button on the main toolbar, and rotate the truck 90

degrees clockwise in the Top viewport.

This orients the truck so that it is parallel to the water.

We now have our main actor in the scene and it is correctly positioned. This tutorial is saved
as Merged monster truck.max, and Figure QS-2 shows the truck positioned on the seashore.
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Figure QS-2: The monster truck is in position and ready to go.

Tutorial: Adding scene props

Now that you have the scene elements and the main actor in place, you'll want to dress up
the scene with other props that add to the scene. For this animation, these items are key and
provide the clues that help inform the viewer that the truck is really just a toy. The scale of

these objects is important.

As scene props, | decided to go with a child’s sand pail and shovel. These items make it obvi-
ous that we're at the beach and that that truck is only a toy. I've already created the shovel,
but you get a chance to model the bucket using a spline and the Lathe and Shell modifiers.

To add scene props to the scene, follow these steps:

1. Select File> Merge to open the Merge File dialog box. Locate and select the Toy

shovel.max file in the Quick Start directory on the CD-ROM. Then select the Toy shovel

object, and click OK.

2. With the shovel selected, press the Z key to zoom in on it in all viewports. The shovel is
too big, so click the Select and Scale button on the main toolbar (or press the R key),
and drag in the Top viewport until the shovel part is about as big as the truck object.
Then click the Select and Move button (W), and drag the shovel in the Top viewport

down and to the left so the shovel is positioned slightly in front of the truck.

7
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7.

. Select Create > Shapes = Line to enter line drawing mode. Then click in the Left view-

port to create the profile of a toy pail. I created it with five clicks, including a lip at the
top of the pail. Right-click in the Left viewport when you're finished to exit line drawing
mode. Name the Line01 object Toy pail.

. With the line object selected, choose Modifiers => Patch/Spline Editing > Lathe to apply

the Lathe modifier to the “Toy pail” object. In the Parameters rollout that appears,
enter a Degrees value of 360 and click the Align Min button.

. In the Perspective viewport, the pail appears black instead of the object color, indicat-

ing that there is a problem with the object’s normals. You could enable the Flip
Normals option to fix the problem, but instead, select Modifiers => Parametric
Deformers > Shell to apply the Shell modifier.

. Click the Select and Move (W) button on the main toolbar, and drag the pail object in

the Top viewport until it is positioned next to the shovel object.

Finally, press the Z key to zoom in on the “Toy pail” object.

Figure QS-3 shows the toys positioned on the same beach as the truck. This file is saved as
Toy shovel and pail.max.
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Figure QS-3: The viewports display the shovel and pail after being imported into Max.
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Dressing the Scene

Once you have all the models positioned within the scene, you can add realism by adding
materials to objects. Materials are created and applied using the Material Editor. Open this
separate dialog box with the Rendering => Material Editor menu command (or by pressing the
M shortcut).

Another detail that helps the scene is adding a background image. To do this, use the
Environment & Effects dialog box opened with the Rendering = Environment menu command
(or by pressing the 8 shortcut).

Tutorial: Applying materials

Try a quick smooth rendering in the ActiveShade window by selecting the Perspective view-
port and choosing Rendering => ActiveShade Floater to open the ActiveShade Floater window.
Rendering the scene computes the effects of the lights, material, and environment into a sin-
gle image. This process could take some time, depending on the complexity of the scene, but
the ActiveShade window is a quick rendering window that lets you see the results of materi-
als and lights. The results of the ActiveShade rendering, shown in Figure QS-4, show us a cou-
ple of things. First, the objects are positioned in the water; second, we need to apply materials
to liven up the dull object colors. Well, don’t worry; you're just getting started. You can close
the ActiveShade window by clicking the close icon in the upper-right corner of the window.

The next step is to use the Material Editor to apply some materials to the objects in the
scene, except for the monster truck, which came with its own materials.

& ActiveShade (1:1) (B[]
Hi[e/o[e o 8 x [foeapms | |

Figure QS-4: The ActiveShade Floater window gives us some feedback
on the progress of the scene.
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To apply materials to the scene objects, follow these steps:

1.

To assign materials, you must open the Material Editor. You can do this by choosing the
Rendering = Material Editor menu command, or by pressing the M key.

The Material Editor shows six sphere objects. These are called sample slots and can be
used to hold materials used in the scene.

. With the first sample slot in the Material Editor selected, click the color swatch to the

right of the Diffuse label in the Blinn Basic Parameters rollout. This opens the Color
Selector dialog box. Select a bright yellow color, and click the Close button. Scroll down
in the command panel, and set the Specular Level value to 95 and the Glossiness value
to 50. Click in the drop-down list where it says “01-Default” and type Yellow plastic as
the name of this material.

. Drag the yellow sphere from the first sample slot in the Material Editor, and drop it on

the sample slot directly below it. This copies the material into another sample slot.
With this lower sample slot selected, click again on the Diffuse color swatch and
change its color to bright red. Then name the material Red plastic.

. Select another empty sample slot, change its Diffuse color to a light brown color, and

name the material Sand.

. Select another empty sample slot, and name the material Sea. Then click the small

square button to the right of the Diffuse color swatch. This is a shortcut button for
applying a texture map to the Diffuse color and opens the Material/Map Browser dialog
box. Double-click the Waves map type to select it and load it within the material. In the
Waves Parameters rollout, change Color #1 to a light blue color and Color #2 to a dark
blue color. Then set the Num Wave Sets value to 50.

The Material Editor should now look like Figure QS-5.

Figure QS-5: The Material Editor now includes
four materials that you can use in the scene.
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6. To apply the materials to the scene, just drag each respective material to the object in
the viewport that it goes with.

This tutorial is saved as Scene with materials.max. You may want to try another test render to
see how the materials look.

Tutorial: Loading a background image

Although the one test render that we’ve looked at so far has looked down at the ground
and we haven’t needed a background image, as we pan out of the environment, we

see the background. Some nice clouds in the background will help it feel more like

a beach.

You can use two separate commands for dealing with background images:

4 Views > Viewport Background (Alt+B): Displays an image as a viewport background.
Be aware that you mainly use this background image just for aligning the objects to
the background, and it is not included as part of the rendered image.

4+ Rendering = Environment (8): Assigns a rendered background image called an
environment map.

To add a background image to the scene, follow these steps:

1. Open the Environment & Effects dialog box by choosing Rendering => Environment (or
press the 8 key). Enable the Use Map check box, and click the Environment Map button
labeled “None.”

The Material/Map Browser dialog box appears.

2. In the right pane of the Material/Map Browser is a list of materials and maps. Double-
click the Bitmap item.

The Select Bitmap Image File dialog box opens.

3. Locate the background image named Clouds.tif in the Quick Start directory on the
CD-ROM, and click it to select it.

When selected, the image appears in the Preview pane, as shown in
Figure QS-6.

4. Click Open to load the background image. When loaded, the image’s filename appears
on the button in the Environment panel, as shown in Figure QS-7. Click the close icon in
the upper-right corner of the Environment dialog box to close it.

5. To see the background image in a test render, you need to rotate the view. With the
Alt key held down, click and drag with the middle scroll wheel button to rotate
the view.

11
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Figure QS-7: Use the Environment
dialog box to set environment
properties, such as a background
image.

This tutorial is saved as Background clouds.max. Figure QS-8 shows another test render in
the ActiveShade Floater window.



Chapter QS + Quick Start: Animating a Monster Truck at the Beach 13

(@ ActiveShade (1:1)
B (e 0le ¢ 8 X [ReEims ;”:]

Figure QS-8: The background image adds to the beach scene.

Animating Motion

After loading and positioning all the models and dressing them with materials, you can add
motion to the scene by animating the objects. Animations can consist of moving objects, like
the truck, as well as secondary motion, like rotating the tires as the truck moves. Animation
is not limited to models; in this section we animate the camera too.

Special effects can also be part of the animating process. In this project we use a particle sys-
tem, which consists of many small particles that combine to look like a cloud of dust.

Tutorial: Animating the monster truck motion

By now, I'm sure that the monster truck is feeling very ready to throw some dirt around. To
animate the truck, we want to move it forward and rotate the wheels. The animation method
we're using is keyframes. This works by setting a beginning position and an ending position
and letting Max compute all the in-between positions.

To animate the monster truck moving, follow these steps:

1. First, we move the truck to its starting position at the end of the sand away from the
toy shovel and pail, but first we need to pan and zoom the Top viewport. Click and drag
the Top viewport with the middle scroll wheel button to pan the viewport to the left.
Then roll the middle scroll wheel to zoom out of the Top viewport so you can see the
truck and most of the sand behind it. Then click the Select and Move tool (W), and drag
the truck to the lower-right corner of the “Sand” plane object.
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2. With the truck selected, press the Z key to zoom in on it in all viewports. Then with the
Select and Move tool (W), drag the truck up in the Front viewport until its wheels are
above the “Sand” plane.

3. Right-click the Top viewport to make it the active viewport, and with the middle scroll
wheel, zoom out of the view so you can see the shovel object again.

4. Before we animate the monster truck, we need to ungroup it so we can animate the
wheels independent of the group. Select Group => Ungroup to ungroup the truck.

5. Click the Auto Key button (or press the N key), and drag the Time Slide to frame 100.
Auto Key mode records all transforms as keys. Click the Select and Move (W) tool, and
drag the truck from its position to the left in the Top viewport until it is just right of the
shovel.

6. Click the Auto Key button again to turn off Auto Key mode, and click the Play button (/)
to see the truck move in the Top viewport. Click the Pause button to stop the anima-
tion, and drag the Time Slider back to frame 0.

This tutorial is saved as Moving truck.max. Animating the movement of the truck is only half
the battle. We still need to animate the wheels rotating.

Tutorial: Animating the rotating wheels

The next animation task is to animate the rotating wheels. Because there are four wheels, you
can select the wheel and rim objects, position their pivot point to the center of the selected
objects, and create the animation.

To animate the wheels rotating, follow these steps:
1. With the truck selected, press the Z key to zoom in on the truck in all viewports.

2. Select the wheel and the rim of one of the tires by dragging over the wheel in the Top
viewport. This also selects the “Sand” plane underneath, so hold down the Ctrl key and
click the “Sand” plane to deselect it.

3. Before you can rotate the wheel, you need to set the location about which it rotates,
which should be the center of the wheel. Open the Hierarchy panel in the command
panel, and with the Pivot button selected, click the Affect Pivot Only button. The Pivot
is the point about which the rotations take place. Then click the Center to Object but-
ton. This places the Pivot at the center of the wheel. Then click the Affect Pivot Only
button again to exit Pivot mode.

4. With the entire wheel and rim selected, click the Select and Rotate (E) tool on the main
toolbar. Then press the Auto Key button (or press the N key), and drag the Time Slider
over to frame 100. Then press the Z key to zoom in on the wheel in all viewports. Select
Tools = Transform Type-In (or press the F12 key), and enter a value of -7200 in the
Offset:Screen field for the Y axis. Close the Transform Type-In floater, and disable Auto
Key mode.

5. With the middle mouse button held down, drag in the Top viewport until another one
of the tires is visible. Repeat Steps 2 through 4 for this wheel and then drag the view-
port again and repeat until all four tires are animated.

Figure QS-9 shows a tire selected and animated. This tutorial is saved as Rotating wheels.max.
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Figure QS-9: Subtle animation pieces like rotating tires are essential for a realistic scene.

Tutorial: Positioning and animating a camera

With the monster truck animated, you're now ready to add a camera to the scene and animate
its motion. Initially, we want it to focus on the monster truck and then slowly dolly away from
its focus to reveal the entire scene.

To add a camera to the scene and animate its motion, follow these steps:

1. Zoom out and pan with the middle scroll wheel in the Top viewport until you can see
most of the “Sand” pane, and then drag the Time Slider back to frame 0. Then select
Create > Cameras = Target Camera, and click and drag in the Top viewport near the
truck to create a camera.

2. In the Left viewport, zoom out, right-click the Target Camera, and choose the Select
Camera Target option from the pop-up quadmenu. Click the Select and Move (W) tool,
and drag the camera target up toward the center hub between the tires beneath the
monster truck. Then click the Select and Link button on the main toolbar, and drag
from the Camera Target to the center hub object to link the two together.

This causes the camera to point at this object wherever the truck moves.

3. Select the Perspective viewport, and right-click the Perspective title in the viewport in
the upper-left corner. In the pop-up menu that appears, select Views &> Camera01.

This changes the Perspective viewport to a view from the camera object.
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4. Drag the camera object in the Top and Left viewports until the Camera01l viewport

shows a good close-up of the monster truck. Then click the Auto Key button (N) to
enable this mode, and drag the Time Slider to frame 50. Using the Select and Move but-

ton (W), position the camera in the Top and Left viewports to show another close-up of
the monster truck.

. With the Auto Key button still enabled, drag the Time Slider to frame 75 and move the

camera up and away from the truck in the Top and Left viewports. Then drag the Time
Slider to frame 100, and drag the camera even further so the toy shovel and pail are vis-
ible. Click the Auto Key button again to disable it.

. Right-click the Camera01 viewport to make it the active viewport, and click the Play

Animation button (/) to see the resulting animation.

This tutorial is saved as Animated camera.max. Figure QS-10 shows the final position of the
camera.
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Figure QS-10: Linking the camera target to an object ensures that the object is always
visible.
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Tutorial: Adding special effects

Special effects are the little extras that you add to an animation that make the scene a little
more believable, and one of the best ways to add effects in Max is using particle systems. For
this animation, we use a particle system to kick up some dust from the tires as the truck
moves along.

To add some dust to the truck motion using particle systems, follow these steps:

1.

Drag the Time Slider back to frame 0, select a rear wheel, and press the Z key to zoom
in on it.

. Select Create = Particles => Super Spray, and drag in the Top viewport to create a Super

Spray icon. Click the Select and Rotate (E) tool, and rotate the icon in the Top and
Front viewports until the icon’s arrow points up and outward from the bottom of the
wheel.

. With the Super Spray icon selected, open the Modify panel and, in the Basic Parameters

rollout, set the Off Axis Spread value to 30 and the Off Plane Spread value to 45. In the
Particle Generation rollout, select the Use Rate option with 1000 particles, and set the
Speed to 2.0 with a Variation to 80% and the Emit Stop value to 95. Set the Life value to
20 with a Variation of 75, and a Size value of 0.5 with a Variation of 20%. In the Particle
Type rollout, select the Facing option.

. Press the M key to open the Material Editor, drag the “Sand” material to an open sam-

ple slot, and name the material Sand particles. Set the Opacity value to 15, and click
the mapping shortcut for the Diffuse color. In the Material/Map Browser, double-click
the Smoke map and set its colors to light brown and white. Then drag the “Sand parti-
cles” material to the Super Spray icon.

. In the Top viewport, hold down the Shift key and drag the Super Spray icon upward to

clone another particle system for the other rear wheel. In the Clone Options dialog box
that opens, click OK.

. Click the Select and Link tool on the main toolbar, and drag from each Super Spray icon

to the rear bumper object in the Front viewport.

This links the particle systems so they travel with the truck.

Having a monster truck kick up a little dust adds to the render time, but the effect is worth it
and makes the monster truck in the earlier scenes look like a real machine. Figure QS-11
shows a rendered frame of the particles being emitted behind the truck. This tutorial is saved
as Dust particles.max.
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Figure QS-11: Particles can be used to simulate dust and smoke effects.

Rendering the Final Animation

Rendering the final animation can take lots of time, depending on the output resolution and
the power of your computer. The final output is started through the Render Scene dialog box,
which you can open with the Rendering => Render menu command (or by pressing the F10
key). The Render Scene dialog box offers several options for customizing the output, but
before we render the final output, let’s create a preview animation to make sure that every-
thing looks okay.

Tutorial: Creating a preview animation

Before we render the final scene, it is a good idea to produce a Preview animation. Doing so
helps to eliminate some problems before the time is spent rendering the entire animation.
The Preview is simply the viewport scene stitched together into an animation. The shading
options are the same as those available for the viewports.

To create a Preview animation, follow these steps:
1. With the Camera01 viewport active, choose Animation > Make Preview.
The Make Preview dialog box appears, as shown in Figure QS-12.

2. In the Make Preview dialog box, you can select the Active Time Segment, which
includes all frames in the animation. Set the Image Size to 50 percent, and select the AVI
Output option. In the Display in Preview section, make sure to check the Geometry,
Lights, and Background check boxes. Select Camera(1 as the Render Viewport.
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Figure QS-12: The Make Preview dialog
box can produce a quick look at your
animation sequence.

3. Click the Create button.

Max begins the rendering, opens the default Media Player when finished, and plays the
preview.

4. Choose Animation > View Preview to view the preview again, if desired.

As you look at the preview, notice that the material maps and render scaled planes aren’t
included in the preview, but you can watch for the following types of errors:

4 Objects moving through one another
4 Insufficient lighting

4+ Erratic object (non-smooth) motion

Tutorial: Rendering the final animation

After you've fixed all the errors and you’re comfortable with the Preview animation, you can
open the Render Scene dialog box and prepare your final animation for rendering.

To view the final animation rendering settings, follow these steps:

1. Open the Render Scene dialog box, shown in Figure QS-13, by choosing Rendering =
Render (or by pressing F10).

2. In the Time Output section, select Active Time Segment. In the Output Size section,
select 320x240 as the resolution.

19
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Figure QS-13: The Render Scene dialog
box includes many diverse rendering
settings.
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. Next, we'll save the rendered scene to a file. In the Render Output section, click the

Files button to open the Render Output File dialog box. Select the location to save the
file, enter the name Monster truck at beach, and from the Save as type drop-down list,
select .AVI as the format. Click Save.

If you don't want to save the file, you can render the scene to the Rendered Frame Window.
After the rendering is complete, you can save the animation by clicking the Save Bitmap but-
ton. The Rendered Frame Window can save animation and bitmap formats.

The Video Compression dialog box appears.

. Select the Cinepak Codec by Radius Compressor with a Quality setting of 100 and a Key

Frame every 15 frames. Click OK to continue.

. Back in the Render Scene dialog box, check the viewport setting at the bottom of the

dialog box and make sure that Camera01 is selected. Then click the Render button to
start the rendering process.

Figure QS-14 shows some frames from the final animation. This final tutorial is saved as Final
render.max.

We could do much more to this animation, such as using lens effects or adding a motion blur,
but I wanted to save some effects for the rest of the book. Feel free to load and modify this
simple animation as you desire.
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Figure QS-14: Four frames from the final animation of our monster
truck playing in the sand

With the Quick Start completed, you're ready to dive into the features of Max, beginning with
Chapter 1, “Finding Your Way — Exploring the Max Interface.”

Summary

I hope you're happy with your first footsteps into Max. This chapter exposed you to a number
of important aspects of Max, including

4 Creating background elements and merging objects

4 Applying materials to scene objects

4+ Simple modeling of objects and using modifiers

4 Loading a background image for the scene

4 Animating objects with keyframes

4 Adding and animating a camera

4 Creating special effects like dust using a particle system
4 Rendering a preview and the final animation

But hold onto your seats because so much of the software lies ahead. In the first chapter, you
start easily with an in-depth look at the Max interface. If you feel ready for more advanced
challenges, review the Table of Contents and dive into any topic that looks good.

+ s+






CHAPITER

Finding Your Way —
Exploring the Max
Interface

¢+ s+

Well, here we are with a new version of Max, and the first ques-
tion on the minds of existing users is “Did the interface
change?” The answer is a gleeful “not much.” Most serious users
would rather go through root canal surgery than have their user
interface (UI) change, and although Discreet has learned and
respected this valued opinion, you’ll find some minor changes.

As you look around the new interface, you’ll see that everything is
still there, but Max has several clever, new additions. You may find
yourself saying, as you navigate the interface, “where did that come
from?” But, just like encountering a new house in your neighborhood,
over time you’ll become accustomed to the addition and might even
meet some new friends.

Why is the software interface so important? Well, consider this: The
interface is the set of controls that enables you to access the pro-
gram’s features. Without a good interface, you may never use many
of the best features of the software or spend a frustrating bit of time
locating it. A piece of software can have all the greatest features, but
if the user can’t find or access them, then the software won’t be used
to its full potential. Max is a powerful piece of software with some
amazing features, and luckily, the interface makes these amazing fea-
tures easy to find and use.

The interface is all about making the features accessible, and in Max
you have many different ways to access the same command. Some of
these access methods are faster than others. This design is inten-
tional because it gives beginning users an intuitive command and
advanced users direct access. For example, to undo a command, you
can choose Edit = Undo (requiring two mouse clicks), but as you gain
more experience, you can simply click the Undo icon on the toolbar
(only one click); an expert with his hands on the keyboard will press
Ctrl+Z without having to reach for the mouse at all. All three of these
methods have the same result, but you can use the one that is easiest
for you.

Has the Max interface succeeded? Yes, to a degree, but like most
interfaces, it always has room for improvement, and we hope that

In This Chapter

Learning the interface
elements

Previewing the
menu commands

Becoming familiar
with the foolbars

Using the Command
Panel

Examining the Lower
Interface Bar

Interacting with
the interface

Getting help
+ + + +
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each new version takes us closer to the perfect interface (but I'm still looking for the “read
my thoughts” feature). Discreet has built a loophole into the program to cover anyone who
complains about the interface — customization. If you don’t like the current interface, you
can change it to be exactly what you want.

Customizing the Max interface is covered in Chapter 4, “Customizing the Max Interface and
(B2 Setting Preferences.”

This chapter examines the latest incarnation of the Max interface and presents some tips that
make the interface feel comfortable, not cumbersome.

If you are an existing user, I've made liberal use of the New Feature icon throughout this
ﬂ_ chapter to highlight what has changed with this edition. If you're anxious to get to the new
4 stuff, I'd suggest that you quickly scan this chapter looking for the New Feature icons, which
refer you to the chapters where the new features are covered.

The Interface Elements

/-

If you’re new to the Max interface, the first order of business is to take a stroll around the
block and meet the neighbors. The Max interface has a number of interface elements that
neatly group all the similar commands together. For example, all the commands for control-
ling the viewports are grouped together in the Viewport Navigation Controls found in the
lower-right corner of the interface.

If all the details of every interface command were covered in this chapter, it would be an
s awfully long chapter. So I include a simple cross-reference to the chapter where more infor-
mation can be found about each command.

The entire interface can be divided into five easy elements. Each of these interface elements,
in turn, has groupings of sub-elements. The five main interface elements are listed here and
shown in Figure 1-1:

4 Menus: This is the default source for most commands, but also one of the most time-
consuming interface elements. The menus are found along the top edge of the Max
window.

4+ Toolbars: Max includes several toolbars of icon buttons that provide single-click access
to features. These toolbars can float independently or can be docked to an interface
edge.

4+ Viewports: Four separate views into the scene show the Top, Front, Left, and
Perspective viewpoints.

4 Command Panel: The major control panel located to the right of the four viewports, it
has six tabbed icons at its top that you can click to open the various panels. Each panel
includes rollouts containing parameters and settings. These rollouts change depending
on the object and tab that is selected.

4+ Lower Interface Bar: Along the bottom edge of the interface window is a collection of
miscellaneous controls.
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Figure 1-1: Max includes five main interface elements.

In addition to these default elements are several additional interface elements that you will
find useful. These controls aren’t initially visible when Max is first loaded, but they can be
accessed by working with the interface. These additional interface elements include the
following:

4+ Floating toolbars: Several toolbars are available as floating toolbars by default, but you
can create more if you like. You access them by choosing Customize > Show Ul => Show
Floating Toolbars or by selecting them from the toolbar’s right-click pop-up menu.

4 Quadmenus: Right-clicking on the active viewport makes a pop-up menu with up to
four panes appear. This is called a quadmenu. Quadmenus offer context-sensitive com-
mands based on the object or location being clicked.

4+ Dialog boxes and editors: Some commands open a separate window of controls. These
dialog boxes may contain their own menus, toolbars, and interface elements. A good
example of this element is the Material Editor, which has enough controls to keep you
busy for a while.
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The pull-down menus at the top of the Max interface include most of the features available in
Max and are a great place for beginners to start. Several of the menu commands have corre-
sponding toolbar buttons and keyboard shortcuts. To execute a menu command, you can
choose it from the menu with the mouse cursor, click its corresponding toolbar button if it
has one, or press its keyboard shortcut. You can also select the command using the keyboard
arrows and press the Enter key to execute it, but I'm sure you already knew that.

The main menu includes the following options: File, Edit, Tools, Group, Views, Create,
Modifiers, Character, reactor, Animation, Graph Editors, Rendering, Customize, MAXScript,
and Help. Unlike some other programs, these menu options do not disappear if not needed.
The list is set, and they are always there when you need them.

\ The reactor menu is new in 3ds max 6.

If a keyboard command is available for a menu command, it is shown to the right of the menu
item. If an ellipsis (three dots) appears after a menu item, that menu command causes a sepa-
rate dialog box to be opened. A small black arrow to the right of a menu item indicates that a
submenu for this item exists. Clicking the menu item or holding the mouse over the top of a
menu item makes the submenu appear. Toggle menu options (such as Views = Show
Ghosting) change state every time they are selected. If a toggle menu option is enabled, a
small check mark appears to its left; if disabled, no check mark appears.

\ A complete list of keyboard shortcuts can be found in Appendix C, “Max Keyboard Shortcuts.”
ce

—

Tip

You can also navigate the menus using the keyboard by pressing the Alt key by itself. Doing
so selects the File menu, and then you can use the arrow keys to move up and down and
between menus. With a menu selected, you can press the keyboard letter that is underlined
to select and execute a menu command. For example, pressing Alt, then F (for File) and N (for
New) executes the Filew> New command; or you can press Alt, use the down arrow to select
the New command, and press the Enter key.

By learning the underlined letters in the menu, you can use the keyboard to quickly access

h menu commands, even if the menu command doesn't have an assigned keyboard shortcut.

# And because you don't need to stretch for the Y key while holding down the Ctrl key, under-
lined menu letters can actually be faster. For example, pressing Alt, G, and U successively, you
can access the Group=> Ungroup menu command. The keyboard buffer remembers the
order of the letters you type regardless of how fast they are keyed, making it possible to
quickly access menu commands using the keyboard. Over time, you can learn patterns to
help you remember how to access certain menu commands, such as Alt, C, H, E for creating
an ellipse.

Not all menu commands are available at all times. If a menu command is unavailable, then it
is grayed out and you cannot select it. For example, the Clone command is available only
when an object is selected, so if no objects are selected, the Clone command is grayed out
and unavailable. After you select an object, this command becomes available.



Chapter 1 4+ Finding Your Way — Exploring the Max Interface

The File menu

The File menu includes commands for working with Max files. These commands enable you
to create a new scene, open and save scene files and objects, and work with externally refer-
enced (XRefs) objects and scenes. You can also reset the scene, merge scenes and animation
sequences, and replace objects in the current scene. The File menu also includes commands
to import and export objects.

At the bottom of the File menu, the Archive command copies all files used in a scene to an
easily portable archive file format. The Summary Info and File Properties commands open
dialog boxes where you can get information about the current scene file. The View Image File
command opens a dialog box where you can view an image before loading it, and the Exit
command ends the madness if you've had too much.

- Cross- Because most of the commands found in the File menu affect files, you can find information
| Reference about these commands in Chapter 3, “Working with Files and XRefs.”

The Edit menu

The Edit menu wins an award for having the most listed keyboard shortcuts per menu item
of all the menus. It includes commands for recovering from mistakes (Undo and Redo),
preparing for catastrophe (Hold and Fetch), and the ubiquitous Delete. The Hold command
(Alt+Ctrl+H) saves the current scene in a buffer. This scene can be recalled at any time using
the Fetch (Alt+Ctrl+F) command. These simple commands can really save your bacon if you
remember to use them. The Edit menu also includes a Clone command (Ctrl+V) for making
copies of an object, which is covered in (no surprise) Chapter 7, “Cloning Objects and
Creating Object Arrays.”

The Edit menu also includes several commands for selecting objects — Select All (Ctrl+A),
Select None (Ctrl+D), Select Invert, and Select By Color and/or Name (H). You can also specify
the type of selection region and whether objects are selected by dragging the cursor across
the object (Crossing) or by enclosing the entire object in the dragged region (Window). The
Edit Named Selection Sets command opens a dialog box where you can name a selected set of
objects for easy recalling. Finally, the Object Properties command opens a dialog box where
you can find all the properties for the selected object.

[gr?ss- \ Most of the Edit menu commands are covered in Chapter 6, “Selecting Objects and Setting
GLEL L Object Properties.”

The Tools menu

The Tools menu can be considered dialog box heaven because almost every menu command
opens a dialog box. The Transform Type-In (F12) command opens a dialog box that lets you
enter precise values for moving, rotating, and scaling objects (see Chapter 10, “Transforming
Objects — Translate, Rotate, and Scale”). The Display Floater opens a dialog box where you
can hide, freeze, and set the object display options. The Selection Floater (H) opens a dialog
box that lets you select objects by several different criteria. The Layer Manager lets you spec-
ify and work with layers. The Display and Selection Floater dialog boxes, along with the Layer
Manager, are covered in Chapter 6 on selecting objects.
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continue.

The Light Lister command opens a dialog box with details on all the lights in the scene. You
can learn to use this helpful dialog box in Chapter 27, “Basic Lighting Techniques.”

The Mirror command uses the Mirror dialog box to create a symmetrical copy of an object
across a designated axis. The Array command opens an Array dialog box where you can cre-
ate multiple instances of an object with each instance offset from the others. The Snapshot
command clones objects over time using the Snapshot dialog box. The Spacing Tool com-
mand (Shift+]) opens the Spacing Tool dialog box, which creates and spaces objects along a
path. All of these commands are different ways to clone objects and create object arrays,
which are covered in Chapter 7.

The Tools menu also includes several ways to align objects. The Align command (Alt+A)
opens an Align dialog box where you can line up objects by axis, edges, or centers. The
Normal Align command (Alt+N) enables you to align the face normals of two objects. The
Align Camera command moves the selected camera to be directly in front of the point you
select, and the Align to View command aligns the object to one of the standard views. Place
Highlight (Ctrl+H) moves the selected light in order to reproduce a highlight in the location
you specify. The alignment commands are covered in Chapter 10 on transforms; the Place
Highlight command is covered with basic lighting in Chapter 27.

The Isolate Selection (Alt+Q) command hides all objects except for the selected object. It also
opens a simple dialog box with an Exit Isolation button in it. Clicking this button or selecting
the Isolate command again exits isolation mode and displays all the objects again. This com-
mand is another way to select an object and is covered in Chapter 6. The Rename Objects
command opens the Rename Objects dialog box where you can rename several objects at
once. This command is covered along with naming objects in Chapter 5, “Creating and Editing
Primitive Objects.”

\ Several standard utilities (Assign Vertex Colors, Color Clipboard, and Camera Match) that
were previously accessed from the Utilities panel have graduated to become real menu com-
mands. You can find these new additions at the bottom of the Tools menu. In addition to
these new menu commands, several new features have been added to the Tools menu,
including Grab Viewport, Measure Distance, and Channel Info.

The Assign Vertex Colors, Color Clipboard, and Camera Match menu commands open and
select their respective utilities in the Utilities panel. The Grab Viewport command is a nice
new feature that captures a picture of the active viewport. The Measure Distance command
provides an easy way to measure the distance between two points. The Channel Info command
opens the Map Channel Info dialog box where you can add objects to a specific channel, which
game developers will appreciate.

The details on the Tools menu commands are spread across the rest of the book, but the
g8 Assign Vertex Colors and Channel Info features deal with games and are covered in Chapter 50,
“Max and Games."
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The Group menu

The Group menu commands let you control how objects are grouped together. Grouping
objects together becomes key as you begin to move objects because grouped objects all
move together. Selecting several objects and using the Group command opens a simple dialog
box where you can type a name for the group. The Ungroup command disassembles the
group and is active only if a group is selected. You can nest groups one inside another. You
can also open and close groups, which lets you attach or detach objects from the group or
move individual group objects within the group. The Explode command ungroups all nested
group objects.

- Cross- For a more complete examination of groups and grouping, check out Chapter 8, “Grouping
| Reference \  and Linking Objects.”

The Assembly submenu includes all the same commands as the Group menu including Open,
Close, Attach, Detach, and Explode, but assemblies are unique in that they can have a light
source as a head object. Assemblies are covered along with groups in Chapter 8.

New '\ The Assembly feature is new to 3ds max 6.
Feature

The Views menu

The Views menu includes commands for controlling the viewports. The Undo View Change
(Shift+Z) and Redo View Change (Shift+Y) commands give you control over viewport
changes, enabling you to undo and redo any changes made with the Viewport Navigation
Controls. You can also save and restore each viewport’s active view with the Save Active View
and Restore Active View commands.

/'Note Keep in mind that Undo View Change (Shift+Z) is distinct from undoing changes made to
o the current object accomplished with the Edit=> Undo (Ctrl+Z) command.

Grids are helpful in establishing your bearings in 3D space. The Grids command opens a sub-
menu with the following options: Show Home Grid, Activate Home Grid, Activate Grid Object,
and Align Grid to View. Grids are covered in Chapter 10 as part of transforming objects.

The Viewport Background command (Alt+B) opens a dialog box in which you can select an
image or animation to appear as a background behind a viewport. If the background image
changes, you can update the viewport using the Update Background Image command
(Alt+Shift+Ctrl+B). The Reset Background Transform command automatically rescales and
recenters the background image to fit the viewport.

Next on the Views menu are several commands that control what is displayed in the view-
port. If a command is enabled, a check mark appears to the left of the command. The Show
Transform Gizmo command displays axes and special handles to move, rotate, and scale the
object in different directions. The Show Ghosting command displays the position of the
selected object in the previous several frames, the next several frames, or both. The Show
Key Times command displays frame numbers along the trajectory path where every anima-
tion key is located. The Shade Selected command turns on shading for the selected object in
all viewports, and the Show Dependencies command shows any objects that are linked or
instanced from a parent object.
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The Create Camera from View (replacing the Match Camera to View) command (Ctrl+C) cre-
ates a camera and positions it to match the current view. The Add Default Lights to Scene
command converts the default lights to actual light objects in the scene. This feature lets you
start with the default lights and modify them as needed.

Caution The keyboard shortcut for the Create Camera from View command is Ctrl+C, which is the
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same as the commonly used Copy command in most other Windows programs. The con-
cepts of Cut, Copy, and Paste don't really work in Max, and you might find yourself using this
keyboard shortcut by accident occasionally. If you find that you've used this command incor-
rectly, you can use the Undo View Change (Shift+Z) to undo the change.

The Redraw All Views (keyboard shortcut, ) command refreshes each viewport and makes
everything visible again (as objects get moved around, they often mask one another and lines
disappear). Activate All Maps turns on all maps, and Deactivate All Maps turns off all maps.
Material maps can take up lots of memory and can slow the viewport rendering. Update
During Spinner Drag causes a viewport to interactively show the results of a parameter value
change set with spinner controls. Spinners are controls with up and down arrows to their
right that can be changed by clicking and dragging on the control. The Adaptive Degradation
Toggle (O) is an option that enables the animation to degrade the image resolution (by down-
grading the rendering method) in order to maintain a consistent frame rate. This can help
when you're trying to perfect the timing of an animation sequence and you don’t need the
prettiest-looking images in the viewports.

The Expert Mode command (Ctrl+X) maximizes viewport space by removing the menus, main
toolbar, Command Panel, Viewport Navigation buttons, status bar, and prompt line from the
interface.

Most of the Views menu commands are covered in detail in Chapter 2, “Seeing It All—
CE Working with the Viewports!”

The Create menu

The Create menu includes an easy way to create objects without your having to access the
Command Panel. Selecting an object from the Create menu automatically opens the Create
panel and selects the correct category, subcategory, and button needed to create the object.
After selecting the menu option, you simply need to click in one of the viewports to create
the object.

\ Several new categories have been added to the Create menu in 3ds max 6, including AEC
Objects, Compound, Patch Grids, NURBS, Dynamics, Helpers, Space Warps, and Systems. The
previous categories must have been really lonely.

The Create menu includes several categories, and you can find a corresponding button for
each submenu item in the Command Panel. Table 1-1 lists the Create menu and submenus.

\ Almost all the submenus found in the Create menu have a chapter dedicated to them. For
c8 example, coverage of primitive objects can be found in Chapter 5, “Creating and Editing
Primitive Objects.” The one exception is the Helpers category, which is scattered throughout
many chapters, but you can find several helpers discussed in Chapter 12, “Modeling Basics."
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Table 1-1: Create Menu Items

Menu

Submenu Items

Standard Primitives

Extended Primitives

AEC Objects

Compound

Particles
Patch Grids
NURBS
Dynamics
Shapes
Lights

Cameras

Helpers

SpaceWarps

Systems

Plane, Box, Cone, Sphere, GeoSphere, Cylinder, Tube, Torus, Pyramid, Teapot

Hedra, Torus Knot, Chamfer Box, Chamfer Cylinder, Oil Tank, Capsule, Spindle,
L-Extrusion, C-Extrusion, Ring\Wave, Hose, Prism

Foliage, Railing, Wall, Terrain, Pivot Door, Sliding Door, BiFold Door, Straight
Stair, L-Type Stair, U-Type Stair, Spiral Stair, Awning Window, Casement
Window, Fixed Window, Pivoted Window, Sliding Window, Projected Window

Morph, Scatter, Conform, Connect, BlobMesh, ShapeMerge, Boolean, Terrain,
Loft, Mesher

Particle Flow Source, Spray, Snow, Blizzard, PArray, PCloud, Super Spray
Quad Patch, Tri Patch

CV Surface, Point Surface, CV Curve, Point Curve

Damper, Spring

Line, Rectangle, Section, Arc, Circle, Donut, Ellipse, Helix, NGon, Star, Text
Standard Lights (Target Spotlight, Free Spotlight, Target Directional,
Directional, Omni, Skylight, mr Area Spot, mr Area Omni), Photometric Lights

(Target Point, Free Point, Target Linear, Free Linear, Free Area, Target Area,
Presets), Daylight System

Free Camera, Target Camera, Create Camera from View (Ctrl+C)

Dummy, Point, Grid, Tape Measure, Protractor, Compass, Camera Point,
Atmospherics (Box Gizmo, Cylinder Gizmo, Sphere Gizmo), Manipulators
(Slider, Plane Angle, Cone Angle), Particle Flow (Speed by Icon, Find Target),
VRML 97 (Anchor, Audio Clip, Background, Billboard, Fog, Inline, LOD,
Navinfo, ProxSensor, Sound, TimeSensor, TouchSensor)

Forces (Motor, Push, Drag, Vortex, Path Follow, PBomb, Displace, Gravity,
Wind), Deflectors (PDynaFlect, POmniFlect, SDynaFlect, SOmniFlect,
SDeflector, UDynaFlect, UOmniFlect, UDeflector, Deflector),
Geometric/Deformable [FFD(Box), FFD(Cyl), Wave, Ripple, Displace, Conform,
Bomb], Modifier-Based (Bend, Noise, Skew, Taper, Twist, Stretch)

Bones IK Chain, Daylight System

The Modifiers menu

The Modifiers menu offers a way to apply modifiers without your having to go to the Modify
panel. Before you can apply a modifier, you must select an object. Only the modifiers that you
can apply to the selected object are enabled.

31
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New '\ The Modifiers menu has two new categories in 3ds max 6 — Conversion and Cameras. You'll
Feature also find a handful of new modifiers including the Select by Channel, UYW Mapping Add,
UVW Mapping Clear, Shell, and Camera Correction.

Selecting a modifier from the Modifiers menu automatically opens the Modify panel where
you can adjust the Parameters for the applied modifier. The modifiers in the Modifiers menu
are grouped into several categories listed in Table 1-2.

- Cross- Modifiers can be used to help you in many areas such as modeling and animation, so cover-

| Refe’e“"x age of them is found throughout the entire book, but a general discussion of modifiers and
how to use them is presented in Chapter 11, “Introducing Modifiers for Basic Object
Deformation.”

Table 1-2: Modifiers Menu Items

Menu Submenu Items

Selection Modifiers Mesh Select, Poly Select, Patch Select, Spline Select, Volume Select, FFD
Select, Select by Channel

Patch/Spline Editing Edit Patch, Edit Spline, Cross Section, Surface, Delete Patch, Delete Spline,
Lathe, Normalize Spline, Fillet/Chamfer, Trim/Extend

Mesh Editing Cap Holes, Delete Mesh, Edit Mesh, Edit Normals, Extrude, Face Extrude,
MultiRes, Normal Modifier, Optimize, Smooth, STL Check, Symmetry,
Tessellate, Vertex Paint, Vertex Weld

Conversion Turn to Mesh, Turn to Patch, Turn to Poly

Animation Modifiers Skin, Morpher, Flex, Melt, Linked XForm, PatchDeform, PatchDeform (WSM),
PathDeform, PathDeform (WSM), SurfDeform, SurfDeform (WSM), Splinelk
Control

UV Coordinates UVW Map, UVW Mapping Add, UVW Mapping Clear, UVW XForm, MapScaler
(WSM), Unwrap UVW, Camera Map (WSM), Camera Map

Cache Tools Point Cache, Point Cache (WSM)

Subdivision Surfaces MeshSmooth, HSDS Modifier

Free Form Deformers FFD 2x2x2, FFD 3x3x3, FFD 4x4x4, FFD Box, FFD Cylinder

Parametric Deformers Bend, Taper, Twist, Noise, Stretch, Squeeze, Push, Relax, Ripple, Wave, Skew,
Slice, Shell, Spherify, Affect Region, Lattice, Mirror, Displace, XForm, Preserve

Surface Material, Material By Element, Disp Approx, Displace Mesh (WSM)
NURBS Editing Surface Select, Surf Deform, Disp Approx
Radiosity Modifiers Subdivide (WSM), Subdivide

Cameras Camera Correction
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The Character menu

The Character menu lets you create and work with characters as separate entities. The
Create and Destroy Character commands add characters to or delete characters from the
scene. Characters can be locked or unlocked to allow free movement. Characters can also
be saved as a separate entity and inserted into another scene.

The Bone Tools command opens a dialog box where you can edit the underlying bone sys-
tem. Characters also have skin, and the Character menu includes commands for setting and
assuming a skin pose.

- Cross- To learn about characters in more detail, see Chapter 35, “Rigging Characters.”
| Reference

The reactor menu

The reactor menu includes everything you need to access the reactor physics simulation
engine. With reactor, you can define objects as rigid bodies like chairs or bowling balls or as
soft bodies like stuffed animals. You can also define specialized objects including cloth and
rope.

New '\ Although reactor isn't new to Max 6, the upgraded version of reactor called reactor 2, which
Feature includes many new features, is new. Max 6 has included reactor as a menu item to provide
easy access to these features.

After physical properties are defined, you can define physical forces to act on these objects
and simulate the resulting animation. Not only does reactor make difficult physical motions
realistic, but it also is fun to play with.

- Cross- Because reactor is the heart of dynamics in Max, you can find it in the part of this book that
| Reference covers dynamics, specifically, Chapter 40, “Animating with reactor.”

The Animation menu

The Animation menu contains many commands that help in producing animation sequences
such as IK Solvers, Constraints, and Controllers. The IK Solvers menu command lets you
select from a submenu of Inverse Kinematics (IK) Solvers. The options include HI Solver, HD
Solver, IK Limb Solver, and SplinelK Solver.

The Constraints menu includes options that limit the motion of an object during an animation
sequence. This feature is helpful for keeping the movement of objects within certain bound-
aries. Controllers, like Constraints, are parameter-driven options for animating objects. Table
1-3 lists the available Constraints and Controllers.
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Table 1-3: Constraints and Controllers Menu Items

Menu Submenu Items

Constraints Attachment Constraint, Surface Constraint, Path Constraint, Position
Constraint, Link Constraint, Look-At Constraint, Orientation Constraint

Transform Controllers Link Constraint, Position/Rotation/Scale, Script

Position Controllers Audio, Bézier, Expression, Linear, Motion Capture, Noise, Quaternion (TCB),
reactor, Spring, Script, XYZ, Attachment Constraint, Path Constraint, Position
Constraint, Surface Constraint

Rotation Controllers Audio, Euler XYZ, Linear, Motion Capture, Noise, Quaternion (TCB), reactor,
Script, Smooth, Look-At Constraint, Orientation Constraint

Scale Controllers Audio, Bézier, Expression, Linear, Motion Capture, Noise, Quaternion (TCB),
reactor, Script, XYZ

The Add Custom Attribute menu command opens the Add Parameter dialog box. Using this
dialog box, you can add new parameters to an object. These new parameters, once defined,
show up in the Custom Attributes rollout of the Command Panel. You can use the Wire
Parameters menu command and Parameter Wire dialog box to make objects respond to the
changes of another object. For example, you can make a character object move up a tree
when a bear character moves closer.

Previews give you a chance to see your animation (rendered in the active viewport) before
you spend time rendering it. Preview commands include Make Preview, View Preview, and
Rename Preview. Previews are saved to a temporary buffer.

\ Although the basics of animation, including parameter wiring and previews, are covered in

ce Chapter 30, “Animation Basics,” Constraints and Controllers are covered in Chapter 31,
“Animating with Constraints and Controllers,” and the IK Solvers are covered in Chapter 37,
“Using Inverse Kinematics.”

The Graph Editors menu

The Graph Editors menu includes commands for opening the Track View (including the Curve
Editor and Dope Sheet), the Schematic View and the Particle View (keyboard shortcut, 6)
windows, along with several menus of commands for creating, opening, and deleting saved
views. The Track View editors provide a detailed way to examine the object and animation
parameters as graphs and bars.

The Schematic View is a high-level, node-based view of the scene. It actually provides the eas-
iest way to link objects and clearly represents the relationships between different objects.

\ The newcomer in this menu is Particle View. The Schematic View interface has been
endowed with many new features.
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The Particle View interface (keyboard shortcut, 6) lets you control how particles interact
with the scene. Using icons that can be linked into a workflow, you can specify how particles
act with one another and with objects in the scene.

The Track View is covered in Chapter 33, “Working with the Track View,” The Schematic View
ce interface is covered in Chapter 9, “Working with the Schematic View,” and the Particle View
interface is covered in Chapter 18, “Creating Particles and Particle Flow.”

The Rendering menu

The Rendering menu is the doorway to the final output. The Render command (F10) opens
the Render Scene dialog box where you can set output options such as which frames to ren-
der and the final image size. The Environment command (keyboard shortcut, 8) opens the
Environment dialog box where you can specify the environment settings such as a back-
ground color or image, global lighting settings, and atmospheric effects such as Combustion,
Fog, and Volume Lights.

The Effects command opens the Rendering Effects dialog box. You use the Rendering Effects
dialog box to add rendered effects to an image without having to use the Video Post dialog
box. The Effects categories include options such as Lens Effects, Blur, and Color Balance. The
Advanced Lighting command opens a control panel where the settings for the Light Tracer,
Radiosity, Exposure Control, and Lighting Analysis tools are located.

\ The Rendering menu holds several features new to 3ds max 6; foremost is the inclusion of
the mental ray rendering engine. Also new to 3ds max 6 are the Panorama Exporter and the
Print Size Wizard.

The Render to Texture command (keyboard shortcut, 0) allows you to render the current
scene as an image to be used as a texture. The Raytracer Settings command opens a dialog
box for enabling raytracing options, and the Raytrace Global Include/Exclude command
opens a dialog box where you can specify which objects are rendered using raytracing and
which are not. The mental ray Message Window opens a window where you can view error
and status messages produced by the mental ray rendering engine.

The ActiveShade Floater opens the ActiveShade window, where you can get immediate ren-
dered results. The ActiveShade Viewport command displays the immediate rendered results
in the active viewport. The Material Editor (keyboard shortcut, M) and Material/Map Browser
commands open their respective dialog boxes for creating, defining, and applying materials.

The Video Post command opens a dialog box for scheduling and controlling any post-
processing work. The dialog box manages events for compositing images and including
special effects such as glows, lens effects, and blurs. The Show Last Rendering command
immediately recalls the last rendered image produced by the Render command.

The Panorama Exporter command allows you to render a panoramic scene. The Print Size
Wizard is a godsend for anyone who is printing images from Max. It relates the current scene
to the common paper sizes that printers use. The RAM Player can display images and anima-
tions in memory and includes two channels for overlaying images and comparing animations
side by side.

35
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The basics of rendering are covered in Chapter 41, “Rendering Basics!” More advanced ren-
ce dering topics, including Atmospheric Effects and Raytracing, are covered in the subsequent

e chapters found in Part X. The Material Editor is covered in Chapter 19, “Exploring the Material

- Cross-
| Referen

- Cross-
| Referen

Editor,” and the Video Post dialog box is covered in Chapter 47, “Using the Video Post
Interface.”

The Customize menu

The Customize menu provides commands for customizing and setting up the Max interface.
The Customize User Interface command opens the Customize User Interface dialog box. This
dialog box includes panels for customizing the keyboard shortcuts, the toolbars, quadmenus,
menus, and colors. The Load Custom Ul and Save Custom UI As commands let you load and
save different custom interfaces. If your customization creates more problems than it solves,
you can switch back and forth between your custom Ul and the defaults with the Custom Ul
and Defaults Switcher command.

The Show Ul menu contains a submenu of interface elements that you can toggle on or off.
Elements that you can toggle include the Command Panel, Floating Toolbars, the main tool-
bar (Alt+6), and the Track Bar.

A random click and drag can really mess up your interface. To prevent this from happening,
you can lock the interface. The Lock Ul Layout prevents an interface from being changed.
This feature is helpful if you accidentally keep dragging toolbars out of place. The Configure
Paths command opens the Configure Paths dialog box where you can define all the default
paths. These paths let Max know where it can find things like plug-ins, scenes, materials,
and so on.

The Units Setup command opens the Units Setup dialog box for establishing system units.
The Grid and Snap Settings command opens the Grid and Snap Settings dialog box for con-
trolling grid objects and determining which points to snap to.

The Viewport Configuration command lets you configure the viewport using the Viewport
Configuration dialog box. The Plug-in Manager command opens the Plug-in Manager dialog
box, which contains a detailed list of all the loaded plug-ins. This dialog box includes the
plug-in name, description, status, size, and its full path. The Preferences command opens the
Preference Settings dialog box for controlling many aspects of Max.

You can learn about most of the commands found in the Customize menu in Chapter 4,
(B2 “Customizing the Max Interface and Setting Preferences,” except for Viewport Configuration,
which is covered in Chapter 2, “Seeing It All — Working with the Viewports."

The MAXScript menu

From the MAXScript menu, you can create, open, and run scripts. You can also open the
MAXScript Listener (F11) and enable the Macro Recorder. The MAXScript menu also includes
a command for loading the Visual MAXScript Editor, which simplifies the process of building
scripts.

\ Chapter 48, “Automating with MAXScript,” covers the basics of MAXScript.
ce
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The Help menu

The Help menu is a valuable resource that provides access to reference materials and tutori-
als. The New Features Guide, User Reference, and MAXScript Reference are comprehensive
help systems that work like a Web browser. The Tutorial command loads the tutorials, which
offer a chance to gain valuable experience.

The Hotkey Map displays an interactive interface for learning all the keyboard shortcuts.
Additional Help presents help systems for any external plug-ins that are loaded. The 3ds max
on the Web options (Online Support, Updates, Resources, and Partners) automatically opens
a Web browser and loads the Discreet Support Web pages or looks for updates.

The Authorize 3ds max command lets you enter an authorization number to authorize the
software. The About 3ds max command opens the About dialog box. This dialog box displays
the serial number and current display driver.

- Cross- Most of the Help menu commands are covered at the end of this chapter in the section titled
| Reference “Getting Help.”

Using the Toolbars

Now that you've learned the menu two-step, it is time for the toolbar one-step. The main tool-
bar appears by default directly under the menus at the top of the Max window; the reactor
toolbar appears docked to the left edge of the interface. Using toolbars is one of the most
convenient ways to execute commands because most commands require only a single click.

You can make any docked toolbar a floating toolbar by clicking and dragging the two vertical
lines on the left (or top) end of the toolbar away from the interface edge. After you separate it
from the window, you can resize the floating toolbar by dragging on its edges or corners. You
can then drag and dock it to any of the window edges or double-click on the toolbar title to
automatically dock the toolbar to its latest location. Figure 1-2 shows the main toolbar as a
floating panel.

If you right-click on any toolbar away from the buttons, you can access a pop-up menu
that includes options to Dock, Float, Customize, show, or hide any of the toolbars or the
Command Panel. You can also show or hide all floating toolbars or the main toolbar with
the Customize => Show Ul menu command. The main toolbar can be hidden with the Alt+6
keyboard shortcut.

Main Toolbar B
P RIR I L LI S0 Ak T2
kol e s=E8%> Je
Figure 1-2: The main toolbar includes buttons and

drop-down lists for controlling many of the most popular
Max functions.

All icon buttons (including those found in toolbars, the Command Panel, and other dialog
boxes and windows) include tooltips, which are identifying text labels. If you hold the mouse
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Tip

cursor over an icon button, the tooltip label appears. This feature is useful for identifying but-
tons. If you can’t remember what a specific button does, hold the cursor over the top of it
and the tooltip gives you its name.

All toolbar buttons with a small triangle in the lower-right corner are flyouts. A flyout is a sin-
gle toolbar button that expands to reveal additional buttons. Click and hold on the flyout to
reveal the additional icons, and drag to select one. Figure 1-3 shows the flyout for the Align
button on the main toolbar.

Figure 1-3: Flyout menus bundle several toolbar buttons together.

If you're looking for the Tab Panel, you won't find it. The Tab Panel, although it was a good

o idea, never really caught on and has been removed from this version of Max. Its former key-

board shortcut, Y, hasn't been reused, so if you often use a command that needs a shortcut,
the letter Y is available.

Starting with the main toolbar

On smaller resolution screens, the main toolbar is too long to be entirely visible. To see the
entire main toolbar, you need to set your monitor resolution to be at least 1280 pixel wide. To
scroll the toolbar to see the end, position the cursor on the toolbar away from the buttons,
such as underneath one of the drop-down lists (the cursor changes to a hand), then click and
drag the toolbar in either direction. Using the hand cursor to scroll also works in the
Command Panel, Material Editor, and any other place where the panel exceeds the given
space.

The easiest way to scroll the main toolbar is to drag with the middle mouse button.
’

Table 1-4 lists the controls found in the main toolbar. Buttons with flyouts are separated with
commas.

Table 1-4: Main Toolbar Buttons

Toolbar Button Name Description
Undo (Ctrl+2) Removes the last performed command. You
f‘ can set the levels of Undo in the Preferences
dialog box.
Redo (Ctrl+Y) Brings back the last command that was
'?-’ undone.
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Toolbar Button Name Description
% Select and Link Establishes links between objects.
o Unlink Selection Breaks links between objects.
us D
gg Bind to Space Assigns objects to be modified by a
Warp space warp.
Al = Selection Filter Limits the type of objects that can be

v

{8

drop-down list

Select Object (Q)

Select by Name (H)

Rectangular
Selection Region,
Circular Selection
Region, Fence
Selection Region,
Lasso Selection
Region (Ctrl+F
to cycle)

Window/
Crossing Toggle

Select and
Move (W)

Select and
Rotate (E)

Select and Uniform
Scale, Select and
Non-Uniform Scale,
Select and Squash
(R to cycle)

Reference
Coordinate System
drop-down list

Use Pivot Point
Center, Use
Selection Center,
Use Transform
Coordinate Center

Select and
Manipulate

selected.

Chooses an object.

Opens a dialog box for selecting objects
by name.

Determines the shape used for selecting
objects.

Specifies whether an object must be crossed
or windowed to be selected.

Selects an object and allows positional
translations.

Selects an object and allows rotational
transforms.

Selects an object and allows scaling
transforms using different methods.

Specifies the coordinate system used for
transforms.

Specifies the center about which rotations
are completed.

Selects an object and allows parameter
manipulation via a manipulator.

Continued

39
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Table 1-4 (continued)

Toolbar Button

Name

Description

& &

Snap Toggle 2D,
Snap Toggle 2.5D,
Snap Toggle 3D (S)

Angle Snap
Toggle (A)

Percent Snap
(Shift+Ctrl+P)

Spinner Snap Toggle

Named Selection Sets

Named Selection
Sets drop-down list

Mirror Selected
Objects

Align (Alt+A),

Normal Align (Alt+N),
Place Highlight
(Ctrl+H), Align to
Camera, Align to View

Layer Manager

Open Curve Editor
Open Schematic View
Material Editor (M)
Render Scene (F10)
Render Type

drop-down list

Quick Render
(Production), Quick
Render (ActiveShade)

Specifies the snap mode. 2D snaps only to
the active construction grid, 2.5D snaps to
the construction grid or to geometry
projected from the grid, and 3D snaps to
anywhere in 3D space.

Causes rotations to snap to specified angles.

Causes scaling to snap to specified
percentages.

Determines the amount a spinner value
changes with each click.

Opens a dialog box for creating and
managing selection sets.

Lists and allows you to select a set of named
objects.

Creates a mirrored copy of the selected
object.

Opens the alignment dialog box for
positioning objects, allows objects to be
aligned by their normals, determines the
location of highlights, or aligns object to a
camera or view.

Opens the Layer Manager interface where
you can work with layers.

Opens the Function Curves Editor.
Opens the Schematic View window.
Opens the Material Editor window.
Opens the Render Scene dialog box for
setting rendering options.

Selects the area or objects to render.

Produces a quick test rendering of the current
viewport without opening the Render Scene
dialog box.
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New '\ The only change in the main toolbar was to move the Keyboard Shortcut Override Toggle

Feature button to the Extras floating toolbar and to add the Layer Manager button. The Selection
Filter drop-down list and the Select and Manipulate buttons changed position and the Quick
Render (Draft) button was dropped. Everything else is unchanged. Thanks, Discreet.

Viewing the default floating toolbars

If you select the Customize &> Show Ul => Show Floating Toolbars menu command, three more
toolbars appear. These are floating toolbars. You can also make them appear by selecting
them from the toolbar right-click pop-up menu. The floating toolbars are Axis Constraints,
Layers, and Extras and Reactor, but the Reactor toolbar is docked to the left side of the inter-
face by default. Figure 1-4 shows the Axis Constraints and Extras toolbars.

New '\ The Extras and reactor toolbars are new to 3ds max 6.
Feature

Restrict to X

Restrictto Y

—— Restrictto Z

Axjs Con ;train}:s
t

=
XY Z ’;—T— Restrict to XY, YZ, XZ Plane

Extras

=
¥ g | 838 [oatPiecel 'H— Render Presets drop-down list

' Array, Snapshot, Spacing Tool
AutoGrid

Keyboard Shortcut Override Toggle

Figure 1-4: The Axis Constraints and Extras toolbars are
available as floating toolbars.

The Axis Constraints toolbar includes buttons for restricting transformations to the X (F5), Y
(F6), or Z (F7) axes or to restrict transformations to a single plane: XY, YZ, or ZX (F8 to cycle).
The Extras toolbar includes the Keyboard Shortcut Override Toggle, AutoGrid, and a flyout
button for the Array, Snapshot, and Spacing Tool (Shift+I) dialog boxes. It also includes the
Rendering Presets drop-down list.

The Layers toolbar includes several buttons for creating, enabling, locking, and selecting lay-
ers. You can also set the properties for each layer. The reactor toolbar includes buttons for
accessing all the reactor functions.

- Cross- Layers are discussed in Chapter 6, “Selecting Objects and Setting Object Properties,” and
| Reference reactor is covered in Chapter 40, “Animating with reactor.”
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Using the Viewports

The four viewports make up the largest area of the entire interface and provide a way of view-
ing the objects within the scene. Each of the viewports is configurable and can be unique
from the others.

- Cross- Understanding how to work with the viewports is vital to accomplishing tasks with Max, so
| Reference viewports have an entire chapter dedicated just to them — Chapter 2, “Seeing It All — Working
with the Viewports.”

Using the Command Panel

If there is one place in Max, besides the viewports, where you’ll spend all your time, it’s the
Command Panel (at least until you’re comfortable enough with the quadmenus). The
Command Panel is located to the right of the viewports along the right edge of the interface.
This is where the object parameters, settings, and controls are located. The Command Panel
is split into six panels, each accessed via a tab icon located at its top. These six tabs are
Create, Modify, Hierarchy, Motion, Display, and Utilities.

You can pull away the Command Panel from the right window edge as a floating dialog box, as
shown in Figure 1-5, by clicking on the open space to the right of the tabbed icons at the top
of the Command Panel and dragging away from the interface edge. You can also dock it to the
left window edge, which is really handy if you're left-handed. While it’s a floating panel, you
can resize the Command Panel by dragging on its edges or corners.

After you've pulled it away from the interface, you can re-dock it to its last position by dou-
ble-clicking on its title bar. You can also right-click on the title bar to access the pop-up menu
to Dock (either Left or Right), Float, Customize, or hide the Command Panel.

Create

Modify Motion

—Display
c d Panel | =
w| | B 1@| @] T——Utilities

o v @ o = & [ Hierarchy

ISlandard Prinitises =

AutoGrid [T

Box Cone
Sphere GeoSphere
Cylinder Tube

Torus Pyramid
Teapot Plane

= Name and Color i
ISuherEUT

—

Figure 1-5: The Command Panel
includes six separate panels
accessed via tab icons.
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Most of the controls, buttons, and parameters in the Command Panel are contained within
sections called rollouts. A rollout is a grouping of controls positioned under a gray, boxed
title, as shown in Figure 1-6. Each rollout title bar includes a plus or minus sign (a minus sign
indicates that the rollout is open; a plus sign shows closed rollouts). Clicking the rollout title
opens or closes the rollout. You can also reposition the order of the rollouts by dragging the
rollout title and dropping it above or below the other rollouts.

.-/Note You cannot reposition some of the rollouts, such as the Object Type and the Name and Color
o rollouts found in the Create panel.

'Command Panel =
w| @ &)@/ T|
(0™ % 2ok

ISlandald Primitives hd

AutoGrid [

Box Cone
Spheie | GeoSpher |
Cylinder Tube

Torus Pyramid
Teapot Plane

[ = Name and Color i

Sphere02

ﬂ

[—Opened rollout

" Edge @ Center

)

[+ KeboadEny - — Closed rollout
¥ Pammeters i

Figure 1-6: Open and close rollouts
by clicking on the rollout title.

Right-clicking away from the buttons in a rollout presents a pop-up menu where you can
select to close the rollout you've clicked in, Close All, Open All, or Reset Rollout Order. The
pop-up menu also lists all available rollouts within the current panel with a check mark next
to the ones that are open.

Expanding all the rollouts often exceeds the screen space allotted to the Command Panel. If
the rollouts exceed the given space, then a small vertical scroll bar appears at the right edge
of the Command Panel. You can drag this scroll bar to access the rollouts at the bottom of the
Command Panel, or you can click away from the controls when a hand cursor appears. With
the hand cursor, click and drag in either direction to scroll the Command Panel. You can also
scroll the Command Panel with the scroll wheel.

- Cross- You can customize the Command Panel like the other toolbars. Customizing the Command
| Reference Panel is covered in Chapter 4, “Customizing the Max Interface and Setting Preferences.”

The Command Panel can also be doubled or tripled (or any multiple as long as you have
room) in width by dragging its left edge toward the center of the interface. The width of the
Command Panel is increased at the expense of the viewports. Figure 1-7 shows the Command
Panel double its normal size.

43
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Tutorial: Rearranging the interface for lefties

I used to work for a company that required that all computers have the mouse to the left of
the keyboard. We swapped computers often, and the boss felt that this would enable us to
work the mouse and the keypad at the same time (and you thought your work environment
was weird). The reality is that some people like it on the left and others prefer it on the right,
and Max can accommodate both.

With the Command Panel on the right side of the interface, the default Max interface obvi-
ously favors right-handers, but with the docking panels, you can quickly change it to be
friendly to lefties.

To rearrange the interface to make it friendly for lefties, follow these steps:

1. Click the Command Panel on the empty space to the right of the Utilities tab, and drag
toward the center of the interface. As you drag the Command Panel away from the right
edge, the cursor changes.

2. Continue to drag the Command Panel to the left edge, and the cursor changes again
to indicate that it will be docked when released. Release the mouse button, and the
Command Panel docks to the left side.
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3. For an even easier method, you can right-click on the Command Panel’s title bar and
select Dock > Left from the pop-up menu.

4. Next dock the reactor toolbar on the right side by dragging it from the left to the right.

Figure 1-8 shows the rearranged interface ready for all you southpaws.

Create panel

The Create panel is the place you go to create objects for the scene. These objects could be
geometric objects like spheres, cones, and boxes or other objects like lights, cameras, or
Space Warps. The Create panel contains a huge variety of objects. To create an object, you
simply need to find the button for the object that you want to create, click it, click in one of
the viewports, and voila —instant object.

Creating objects is covered in detail in chapters throughout the rest of the book, but the first
chapter that really gets into creating objects is Chapter 5, “Creating and Editing Primitive
Objects!” You can buzz over to that chapter if you are anxious to start creating things.

& untitled - 3ds max 6 BEF]
File Edit Tools Group Views Create Modifiers Character reactor Animation Graph Editors Rendering Customize MAXScript Help
PRI EP L RIS 0 Al T £e® & oo =i &,g
lv IN|& @@ T
[om % @ a %

futelrid T
Box Cone.
Sphere | GeoSphers
Cplnder Tube
Torns Pyrarid
Teapot Plang

%%@%@W%h#@%&@ﬁ@ﬁ@@&

; 0100 ;
E I HHHIHIIQDHHHHI:J’]IHHHHHHHH\S!B\IHH\HGHHHHI%HHIHHgﬂl\l\l\l\%l\l\\ll\\& )
[Nmésél;eigd 2 Bl o 2] [ Gid=100 uto Key| [Selected <] b | 5] e (ol | Q B TS
[ i [Tt Semey] Kepfies. | ™[ B (>0 6

Figure 1-8: Left-handed users can move the Command Panel to the left side.
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The Create panel includes several categories and subcategories of objects. The categories,
shown in Figure 1-9, are displayed as icons directly under the Command Panel tabs. The cate-
gories include Geometry, Shapes, Lights, Cameras, Helpers, Space Warps, and Systems.
Subcategories are displayed in the drop-down list under the category icons. Each subcategory
displays a different set of buttons in the Object Type rollout when selected.

Selecting an object from the Create menu automatically opens the Create panel and selects

o the requested object type.

New
Feature

Geometry
Shapes
Lights

Cameras
Helpers

C d Panel B

§ @ E}:\@FM—Space Warps

) B ¥ & w. 3% %—— Systems
StandadPimiives _~———Sub-category

T mmeamee 1 | drop-down list

o

Autatid [~
Box Cone
Sphere GeoSphere
Cylinder Tube
Tomg Pyramid
Teapot Flane

Sphere03

)

Figure 1-9: The Create panel includes
seven different categories of objects.

Table 1-5 lists all the available Create panel buttons for each category and subcategory.

\ Many new items were added to the Create panel including the BlobMesh compound object
and all the AEC Objects such as Foliage, Railing, Wall, Doors, Windows, and Stairs. Other new
features include the mental ray Area Omni and Area Spot lights, the Assembly Heads, Particle
Flow, reactor Helper subcategories, and the reactor and Particles & Dynamics Space Warps
subcategories.
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Table 1-5: Command Panel Buttons per Subcategory

Subcategory
Category (icon) (drop-down list) Available Buttons
Standard Primitives Box, Cone, Sphere, GeoSphere, Cylinder,
':' Tube, Torus, Pyramid, Teapot, Plane
Geometry

Shapes

¥
Lights

@I

Cameras

el
Helpers

Extended Primitives

Compound Objects

Particle Systems

Patch Grids
NURBS Surfaces
AEC Extended
Dynamics Objects
Stairs

Doors

Windows

Splines

NURBS Curves
Standard

Photometric

Standard

Standard

Atmospheric Apparatus

Camera Match

Assembly Heads

Hedra, Torus Knot, ChamferBox, ChamferCyl,
OilTank, Capsule, Spindle, L-Ext, Gengon, C-
Ext, RingWave, Hose, Prism

Morph, Scatter, Conform, Connect, BlobMesh,
ShapeMerge, Boolean, Terrain, Loft, Mesher

PF Source, Spray, Snow, Blizzard, PArray,
PCloud, Super Spray

Quad Patch, Tri Patch
Point Surf, CV Surf
Foliage, Railing, Wall
Damper, Spring
Straight Stair

Pivot, Sliding, BiFold

Awning, Casement, Fixed, Pivoted, Projected,
Sliding

Line, Rectangle, Circle, Ellipse, Arc, Donut,
NGon, Star, Text, Helix, Section

Point Curve, CV Curve

Target Spot, Free Spot, Target Direct,
Free Direct, Omni, Skylight, mr Area Omni,
mr Area Spot

Target Point, Free Point, Target Linear, Free
Linear, Target Area, Free Area, IES Sun, IES Sky

Target, Free

Dummy, Grid, Point, Tape, Protractor,
Compass

BoxGizmo, SphereGizmo, CylGizmo
CamPoint
Luminaire

Continued
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Table 1-5 (continued)

Subcategory
Category (icon) (drop-down list) Available Buttons
Manipulators Cone Angle, Plane Angle, Slider
Particle Flow SpeedBylcon, Find Target
VRML97 Anchor, AudioClip, Background, Billboard,
Fog, Inline, LOD, Navinfo, ProxSensor, Sound,
TimeSensor, TouchSensor
reactor RBCollection, Csolver, Point-Point, Point-Path,
Hinge, Ragdoll, Carwheel, Prismatic, L
Dashpot, A Dashpot, CLCollection,
DMCollection, RPCollection, SBCollection,
Fracture, Motor, Plane, Spring, Toy Car, Wind
e Forces Motor, Push, Vortex, Drag, Path Follow,
=g PBomb, Displace, Gravity, Wind
Space Warps
Deflectors PDynaFlect, POmniFlect, SDynaFlect,

£

Geometric/Deformable

Modifier-Based
reactor

Standard

Systems

—

SOmniFlect, UDynaFlect, UOmniFlect,
SDeflector, UDeflector, Deflector

FFD (Box), FFD (Cyl), Wave, Ripple, Displace,
Conform, Bomb

Bend, Noise, Skew, Taper, Twist, Stretch
Water

Bones, Ring Array, Sunlight, Daylight

For the most part, the Create panel and the Create menu are the same, but there are a cou-
ple of differences. The biggest difference is the order of many of the items. In addition, the
Extended Primitives <> Gengon object was left out of the Create menu. Oops.

Below the Object Type rollout is the Name and Color rollout. Every object created with the
Create panel is given a default name and color. Using this rollout, you can change the object
name and color. The color is used to display the object in the viewports if no material is
applied. Both the Object Type and Name and Color rollouts are visible in all the categories
found in the Create panel.

After you select a button, the button is highlighted yellow and several additional rollouts
magically appear. These new rollouts hold the parameters for the selected object and are
displayed in the Create panel below the Name and Color rollout. Altering these parameters
changes the object. The button remains selected, allowing you to create more objects until
you select a different button, click on a toolbar button, or right-click in the active viewport.
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Modify panel

The parameters found in the Create panel are great for changing an object, but they are avail-
able only while you're creating the object. If you select another object and then return to the
Create panel with the first object selected, all its parameters are gone. Actually, they aren’t
gone, but rather they’ve migrated to the Modify panel. The Modify panel is the permanent
location of object parameters.

In addition to modifying object parameters, you can use the Modify panel to apply modifiers
to the selected object. Modifiers are parameter-driven functions for modifying an object. You
can see a complete list of modifiers in the Modifier List drop-down list (or in the Modifiers
menu).

Once applied, you can control the modifiers via parameters displayed in the Modify panel.
All modifiers that are applied to an object are displayed in the Modifier Stack (like the Twist
modifier applied to a sphere object in Figure 1-10), which appears at the top of the Modify
panel (directly under the Modifier List drop-down list). You can also apply modifiers using
the Modifiers menu.

.Enmmand Panel X
|2 8@ @) T
ISpheraU2 ’—
Muodifier List -
e H—Modifier Stack

w s e ez

Had\us:lw ﬂ

55gments:|32— g
¥ Smoath

Hemisphere: IUU— g
@ Chop ¢ Squash
[ Slice On

Figure 1-10: Use the Modify panel to
apply modifiers and to modify object
parameters.

The Modifier Stack is like an object’s medical history: It details everything that has happened
to an object. The Modifier Stack displays all modifiers that have been applied to the current
selected object. This stack lets you revisit any modifier and change its parameters, reorder it
in the stack, or delete it.

\ An introduction to modifiers is presented in Chapter 11, “Introducing Modifiers for Basic

g8 Object Deformation,” but you can find coverage of other modifiers sprinkled throughout the
rest of the chapters. For example, see Chapter 24, “Working with Cameras,” for coverage of
the Camera Correction modifier.
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Hierarchy panel

The Hierarchy panel, shown in Figure 1-11, includes three different sets of controls. You
access them by using the three buttons located at the top of the panel. These sets are Pivot,
Inverse Kinematics (IK), and Link Info. Each of these buttons when selected presents several
different rollouts of parameters.

i dPanel [J| Figure 1-11: The Hierarchy panel offers controls for
w|#| &)@ BT | adjusting pivot points, among other things.
|

o Tk Link Irfo

- Adjust Pivat

- Move/Rotate/Scale:

Affect Pivot Only
Affect Object Only
Affect Hierarchy Only
~alignment ———————

Center to Object
Aligrito Dbject
Aligry tatwiord

r~ Fivat:

Resat Pivat

L+ Adjust Transform i
(T —

The Pivot button opens rollouts that let you move and reorient an object’s pivot point. A
pivot point is the point about which transformations are applied. The IK button opens roll-
outs that let you set up an inverse kinematics structure and to define how the joints of such
a structure can move. Finally, the Link Info button opens rollouts for setting locks, which pre-
vent an object from moving, rotating, or scaling along certain axes.

Check out the details on pivots in Chapter 10, “Transforming Objects — Translate, Rotate, and

— Scale,” Inverse Kinematics in Chapter 37, “Using Inverse Kinematics,” and links in Chapter 8,

“Grouping and Linking Objects”

Motion panel

Similar to the Hierarchy panel, the Motion panel has a dual personality. The two buttons at
the top of the Motion panel, shown in Figure 1-12, are Parameters and Trajectories. One com-
mon way of modifying object motion is to apply Controllers and Constraints. The Parameters
button opens several rollouts that enable you to apply animation Controllers and Constraints.
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Controllers affect the position, rotation, and scaling of objects in preset ways, and Constraints
limit the motion of an object. You can access a list of Controllers by clicking the Assign
Controller button positioned at the top of the Assign Controller rollout or by choosing one
from the Animation menu.

Command Panel )
@5 @@ T|
ISuherEUZ |—

Selection Level

Sub-Dbject v i
Pararneters Trajectories

- Assign Contraller

fid Assign Controller button
={fi] Transform : Position/

&[] Position : Positior
Rotation : Euler >
e [[@] Scale : Bezier Se

P

I+ PRS Parameters i
[+ Position =2 Parameters |
|+ Key Info [Basic) i

|+  Keylnfo[Advanced] i

Figure 1-12: The Motion panel offers an interface
for assigning animation Controllers to an object.

The Trajectories button opens a single rollout that lets you set parameters for the animation
path.

 Cross- Constraints and Controllers are the subjects of Chapter 31, “Animating with Constraints and
| Reference Controllers!” Trajectories are covered in Chapter 30, “Animation Basics."

Display panel

The Display panel, shown in Figure 1-13, controls how objects are seen within the viewports.
You can set display parameters for individual objects. Using this panel, you can hide or freeze
objects and modify all display parameters. Many of these same commands are found in the
Display Floater and in the Object Properties dialog box.

|, grt;ss- \ | cover the Display panel in Chapter 6, “Selecting Objects and Setting Object Properties.”
ererence

—
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Figure 1-13: The Display panel includes
settings for the color of the object.

You can find an assortment of miscellaneous tools in the Utilities panel, shown in Figure 1-14.
The default utilities include the Asset Browser, Camera Match, Collapse, Color Clipboard,
Measure, Motion Capture, Reset XForm, MAXScript, and reactor. Click the More button at the
top of the Utilities panels to open an additional list of utilities. To execute a utility, simply
click its button or select it from the list. Some utilities open dialog boxes, and others present
rollouts in the bottom of the Utilities panel. The button for the selected utility is highlighted

in yellow.

Ci d Panel £

w5 @@ T
T |
More, Sets E

Aisset Browser
Camera Match
Collapze
Color Clipboard
Measure
Motion Capture
Reset=Form
M5 cript
reactor

This panel also includes the Configure Button Sets button for customizing which buttons
appear in the default Utilities rollout. See Chapter 4, “Customizing the Max Interface and
Setting Preferences,” for more information.

Figure 1-14: The Utilities panel includes
several miscellaneous tools.
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Using the Lower Interface Bar Controls

The last major interface element isn’t really an interface element, but just a collection of sev-
eral different sets of controls located along the bottom edge of the interface window. These
controls cannot be pulled away from the interface like the main toolbar, but you can hide
them using Expert Mode (Ctrl+X). These controls, shown in Figure 1-15, include the following
from left to right:

T Untiled 305 man & e
File Edit Tools Group Views Create Maodifiers Character reactor  Animation  Graph Editers  Rendering  Costomize MAXScript  Halp
R %G EF L EDRe0al B s o Al i @)
W@ A8 T
I—

S T St O R T Sz 0 Y e Rt~

‘ﬁﬁ%lli ||||I|UI$IIIIIIlII*IIIIIIIllbllIPIIlllé’llllllllulilﬂliil

H“””'W”““'w””"'
Hane Selected @ R

[Big-100 hl %
| m-gaeu»mujmmm | Ak T Tag Setkey

|

Prompt Line  Status Bar Key Controls ~ Time Controls

QBT R
) & B

Track Bar Viewport Navigation Controls

MAXScript Mini-Listener

—Time Slider
Figure 1-15: The Lower Interface Bar includes several sets of controls.

4 Time Slider and Track Bar: The Time Slider, located under the viewports, enables you
to quickly locate a specific frame. The Track Bar displays all animation keys on a scale
of frames.

4 Status Bar and Prompt Line: The Status Bar is below the Track Bar. It displays informa-
tion on the selected objects and includes some buttons. It also includes the Transform
Type-In fields. The Prompt Line is text located at the bottom of the window. It offers
information about the scene and describes what Max expects you to do next.
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4+ MAXScript Mini-Listener: This displays MAXScript commands as they are executed.
You can open and close this control by dragging its left edge.

4+ Key Controls: These controls are for creating animation keys and include two different
modes — Auto Key and Set Key.

4 Time Controls: Resembling the controls on an audio or video device, the Time Controls
offer an easy way to move through the various animation frames and keys.

4+ Viewport Navigation Controls: In the lower-right corner of the interface are the con-
trols for manipulating the viewports.

Accessing frames and keys with the
Time Slider and the Track Bar

Directly beneath the viewports is a slider control known as the Time Slider. It spans the num-
ber of frames included in the current animation. Dragging the Time Slider can move you
quickly between frames. The arrows surrounding the slider select the previous or next frame.

The Track Bar, positioned under the Time Slider, displays animation keys as color-coded
rectangles with red for positional keys, green for rotational keys, and blue for scale keys.
Parameter change keys are denoted by gray rectangles. You can hide the Track Bar with the
Customize > Show Ul=> Show Track Bar menu command. Using the Track Bar, you can select,
move, and delete keys.

At the left end of the Track Bar is the Open Mini Curve Editor button that you can use to
expand the Track Bar to show function curves.

See Chapter 30, “Animation Basics,” for more information on the Track Bar. More information
g8 on the Curve Editor can be found in Chapter 33, “Working with the Track View."

Learning from the Status Bar and the Prompt Line

As you work, the Status Bar provides valuable information, such as the number and type of
objects selected, transformation values, and grid size. The Status Bar has two buttons —
the Selection Lock Toggle button (keyboard shortcut, space) and the Absolute/Offset Mode
Transform Type-In toggle button. Clicking the Selection Lock Toggle button prevents the
selection of any additional objects. The button is yellow when selected.

The Transform Type-In fields display the world coordinates of the cursor in the active view-
port, unless an object is selected. For the selected object, these fields show the absolute
world coordinate values if the Absolute Mode Transform Type-In toggle button is selected.

If the Offset mode is selected, then the fields show the offset values as the object is trans-
formed. The values that are displayed depend on the type of transformation that is taking
place (units for moves, degrees for rotation, and percentages for scaling). You can also enter
values into these fields to transform the object.

The Prompt Line is directly below the Status Bar. If you're stuck as to what to do next, look at
the Prompt Line for information on what Max expects. To the right of the Prompt Line is a
field marked Add Time Tag. Click this field to pop up a menu with options to Add or Edit a
Time Tag. You can set Time Tags for each frame in the scene. Once set, the Time Tags are visi-
ble in the Time Tag field whenever you select that time.
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Controlling the MAXScript Mini-Listener

The MAXScript Mini-Listener consists of two simple text areas where you can enter
MAXScript commands and immediately see the results. The pink area is where MAXScript
commands are entered, and the white area is where the results are displayed. You can think
of the MAXScript Mini-Listener as a calculator that is at your fingertips.

- Cross- MAXScript and the MAXScript Mini-Listener are covered in detail in Chapter 48, “Automating
| Reference with MAXScript”

Using the Key Controls

You can use the Key Controls to set animation keyframes for objects in the scene. Setting
keys can be done in two modes — Auto Key (keyboard shortcut, N) or Set Key (keyboard
shortcut, '). Auto Key mode sets keys for any changes made to the scene objects. Set Key
mode gives you more precise control and sets keys for the selected filters only when you
click the Set Keys button (keyboard shortcut, K). You can set keys for the selected object
or for a specified character.

Using the Time Controls

Although the Time Controls sound like an interface to a time machine, you use them to con-
trol animation sequences.

Based on the selected mode (keys or frames), the Time Controls can move between the first,
previous, next, or last frames or keys. You can also reset the number of frames and the frame
rate using the Time Configuration dialog box.

|, Crt;ss- \ Chapter 30, “Animation Basics,” covers both the Key Controls and the Time Controls in detail.
Reference

L/——
Using the Viewport Navigation Controls

The Viewport Navigation Controls are the eight buttons located in the lower-right corner of
the interface. They enable you to zoom, pan, and rotate the active viewport’s view. You can
undo any viewport changes with the Views = Undo Viewport Change (Shift+Z) menu command.

- Cross- I cover the Viewport Navigation Controls in detail in Chapter 2, “Seeing It All —Working with
| Reference Viewports.”

Interacting with the Interface

Knowing where all the interface elements are located is only the start. Max includes several
interactive features that make the interface work. Learning these features makes a difference
between an interface that works for you and one that doesn’t.
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Tip

§ “6’!

Gaining quick access with the right-click quadmenus

Quadmenus are pop-up menus with up to four separate sections that surround the cursor, as
shown in Figure 1-16. Right-clicking in the active viewport opens these quadmenus. The con-
tents of the menus depend on the object selected.

Many of the real pros use quadmenus extensively. One of the reasons they do is because
they can access the commands from the mouse’s current location using a couple of clicks
» without having to go all the way to the Command Panel to click a button.

Clicking with the left mouse button away from the quadmenu closes the quadmenu. For each
menu, the last menu item selected is displayed in blue. To quickly access the blue menu item
again, simply click the gray-shaded bar. Using Customize = Customize User Interface, you can
specify which commands appear on the quadmenus, but the default options have just about
everything you need.
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Figure 1-16: Quadmenus contain a host of commands in an easily accessible location.

Understanding the button color cues

Max’s interface uses color cues to help remind you of the current mode. When a button is yel-
low, it warns that it has control of the interface. For example, if one of the select buttons is
selected, it turns yellow and any dragging in the viewport affects the object; however, if one
of the Viewport Navigation Control buttons is selected, it turns yellow and dragging the view-
port changes the view. Knowing what the current mode is at all times can keep you out of
trouble.
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Tip Right-clicking in the active viewport exits any mode that has control and returns control to
.. the Select Object mode. Right-clicking in one of the inactive viewports keeps the focus
# Wwhere it is and makes that clicked viewport active.

Another common color is red. When the Auto Keys or Set Keys buttons are depressed, they
turn red. The edge of the active viewport being animated also turns red. This reminds you
that any modifications will be saved as a key.

Toggle buttons are buttons that can be turned on or off. Example toggle buttons include the
Snap buttons. When a toggle button is enabled, it also turns yellow. Toggle buttons high-
lighted in blue are non-exclusive, but they notify you of a mode that is enabled, such as the
Key Mode Toggle or the Affect Pivot Only button.

- Cross- All interface colors can be customized using the Customize User Interface dialog box that is
| Reference discussed in Chapter 4, “Customizing the Max Interface and Setting Preferences.”

Using drag-and-drop features

Dialog boxes that work with files benefit greatly from Max’s drag-and-drop features. The
Material Editor, Background Image, View File, and Environmental Settings dialog boxes all use
drag and drop. These dialog boxes let you select a file or a material and drag it on top of where
you want to apply it. For example, with the Maps rollout in the Material Editor open, you can
drag a texture image filename from Windows Explorer or the Asset Manager and drop it on the
Map button. You can even drag and drop Max files into the Max interface to open them.

Controlling spinners

Spinners are those little controls throughout the interface with a value field and two small
arrows to its right. As you would expect, clicking the up arrow increases the value and click-
ing the down arrow decreases the value. The amount of the increase or decrease depends on
the setting in the General tab of the Preference Settings dialog box. Right-clicking on the spin-
ner resets the value to its lowest acceptable value. Another way to control the spinner value
is to click the arrows and drag with the mouse. Dragging up increases the value and dragging
down decreases it.

The effect of the spinner drag is shown in the viewport if the Update During Spinner Drag
menu option is enabled in the Views menu. If the cursor is located within a spinner, you can
press Ctrl+N to open the Numeric Expression Evaluator, which lets you set the value using an
expression. For example, you can set a spinner value by adding numbers together like you
would using a calculator. An expression of 30+40+35 sets the value to 105.

-~ Cross- C|Iapte 32, Usir g t] e EXPIESSIOII Cor tIO[|EI, covers tlle Numeric EXPIESSIOII EVa[uatOl n
| e1e C more detall-

Finding keyboard shortcuts

Many features include keyboard shortcuts. These shortcuts can give you direct access to a
command without moving the mouse. The default shortcuts for the menu commands are
listed to the right of the command. You can use the Keyboard panel of the Customize User
Interface dialog box to view and change the keyboard shortcut for any feature.
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- Cross-

| Referen
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| Referen

\ Appendix C, “Max Keyboard Shortcuts,” lists all the default keyboard shortcuts.
ce

Using strokes

Strokes are similar to the keyboard shortcuts, except they allow you to draw a pre-defined
shape using the middle mouse button as a shortcut to a command. For example, you can set
up a stroke to undo the last action using a shape that looks like the letter U. Then you can
undo the last action by clicking the middle button and dragging in the shape of the letter U.
Strokes are convenient because they use the mouse, and you don’t need to reach for the
keyboard.

Setting up and using strokes is covered in more detail in Chapter 4, “Customizing the Max
g8 Interface and Setting Preferences.”

Understanding modeless and persistent dialog boxes

Many dialog boxes in Max are modeless, which means that the dialog box doesn’t need to be
closed before you can work with objects in the background viewports. The Material Editor is
an example of a modeless dialog box. With the Material Editor open, you can create, select,
and transform objects in the background. Other modeless dialog boxes include the Material/
Map Browser, the Render Scene dialog box, the Video Post dialog box, the Transform Type-In
dialog box, the Display and Selection Floaters, and the various graph editors.

Another feature of many, but not all, dialog boxes is persistence, which means that values
added to a dialog box remain set when the dialog box is reopened. This feature applies only
within a given Max session. Choosing the File > Reset command button or exiting and restart-
ing Max resets all the dialog boxes.

Getting Help

New
Feature

If you get stuck, Max won'’t leave you stranded. You can turn to several places in Max to get
help. The Help menu is a valuable resource that provides access to references and tutorials.

Browser-based reference guides

The New Features Guide, User Reference, MAXScript Reference, and Tutorials are Web
browser-based help interfaces. An organized list of topics is available in the left navigation
pane, as shown in Figure 1-17, and the right includes a pane where the details on the selected
topic are displayed. Across the top are five toolbar buttons used to control the interface. The
Hide button hides the left navigation pane, the Back and Forward buttons move between vis-
ited pages, the Print button prints the information in the right pane, and the Options button
displays a pop-up menu of options.

\ The New Features Guide is new to 3ds max 6.
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Above the left navigation pane are five tabs that open separate panels when selected. The
Contents panel displays a list of topics; the Index panel lists all topics alphabetically; the
Search panel includes a text field where you can search for specific keywords; the Favorites
panel keeps a list of bookmarks to topics you add to the list; and the Query panel lets you
type in a question and query for answers.

Throughout the textual descriptions, keywords that are linked to other related topics are
highlighted in blue and underlined.

Online help

The Web offers many sites that can also help, and Max links to the Online Support, Updates,
Resources, and Partners pages on the Discreet site from the Help => 3ds max on the Web
menu. Selecting either of these menu commands automatically opens a Web browser and
loads the Discreet Web pages.
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Welcome to the 3ds max User Reference.
This reference contains detailed information about all the features and capabilities of 3ds max. 3ds max brings 2D
modeling and animation to your desktop system,

Fa| T 1 IF3 The reference is organized by functional areas. The User Interface chapter gives you a guide to program controls and

where to find them. s

Figure 1-17: The User Reference includes panels for viewing the index of commands and
searching the reference.
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Summary

You should now be familiar with the interface elements for Max. Understanding the interface
is one of the keys to success in using 3ds max. Max includes a variety of different interface
elements. Among the menus, toolbars, and keyboard shortcuts, several ways to perform the
same command exist. Discover the method that works best for you.

This chapter covered the following topics:
4 The interface elements
4 Viewing and using the pull-down menus
4+ Working with toolbars
4 Using the Command Panel and learning its six panels
4 Learning the lower interface controls
4 Interacting with the Max interface
4+ Getting additional help

In this chapter, we’ve skirted about the viewports covering all the other interface elements,
but in the next chapter, we're going to hit the viewports head-on.

+ o+«



Seeing It All -
Working with the
Viewports

Although Max consists of many different interface elements, such
as panels, dialog boxes, and menus, the viewports are the main
areas that will catch your attention. The four main viewports make up
the bulk of the interface and are the one place where scene objects
are visible. You can think of the viewports as looking at the television
screen instead of the remote. Learning to control and use the view-
ports can make a huge difference in your comfort level with Max.

The viewports are powerful and have numerous settings that you can
use to provide thousands of different ways to look at your scene, and
beginners can feel frustrated at not being able to control what they
see. This chapter includes all the details you need to make the view-
ports reveal their secrets.

Understanding 3D Space

It seems silly to be talking about 3D space because we live and move
in 3D space. If we stop and think about it, 3D space is natural to us.
For example, consider a filing cabinet with four drawers. Within each
drawer, you can stuff papers in the front, back, or sides, as well as in
the drawers above or below. These positions represent three unique
directions.

When [ ask my wife where our passports are (don’t ask why I'm look-
ing for my passport) and she says, “They’re in the top drawer toward
the back on the left side,” [ know exactly where they are and can find
them immediately (unless, of course, my kids have been in the cabi-
net). The concept of three dimensions is comfortable and familiar.

Now consider the computer screen, which is inherently 2D. If | have
many windows open, including a scanned image of my passport, and |
ask my wife where the scanned image is, she would reply, “It’s some-
where behind the large window where you’re writing that book.” And
[ would look and search before locating it. In 2D space, | understand
top and bottom and left and right and have a little notion of above
and below.

CHAPTER

¢+ 0+ o+
In This Chapter

Understanding 3D
space

Using the Viewport
Navigation Control
buttons

Controlling the viewport
settings with the
Viewport Configuration
dialog box

Loading a viewport
background image

¢+ s+
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This conundrum is what 3D computer artists face—how do you represent 3D objects on a 2D
device? The answer that 3ds max provides is to present several views, called viewports, of the
scene. A viewport is a small window that displays the scene from one perspective. These
viewports are the windows into Max’s 3D world. They are probably called viewports instead
of windows because the word Windows has a different meaning in the computer world, and it
is copyrighted. Each viewport has numerous settings and viewing options.

Axonometric versus Perspective

When it comes to views in the 3D world, two different types exist— Axonometric and
Perspective. Axonometric views are common in the CAD world where the viewer is set at an
infinite distance from the object such that all parallel lines remain parallel. A Perspective
view simulates how our eyes actually work and converges all points to a single location off in
the distance.

You can see the difference between these two types of views clearly if you look at a long line
of objects. For example, if you were to look down a long row of trees lining a road, the trees
would eventually merge on the horizon. In Axonometric views, lines stay parallel as they
recede off into the distance. Figure 2-1 shows this example with the Axonometric view on the
left and the Perspective view on the right.

(1:1) : =[E=)
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Figure 2-1: Axonometric and Perspective views

Orthographic and Isometric views

If you dig a little deeper into Axonometric views, you find two different types — Orthographic
and Isometric. Orthographic views are displayed from the perspective of looking straight
down an axis at an object. This reveals a view in only one plane. Because orthographic
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viewports are constrained to one plane, they show the actual height and width of the object.
Isometric views are not constrained to a single axis and can view the scene from any location,
but all dimensions are still maintained.

Learning Viewports in Max

Available orthographic viewports in Max include Front, Back, Top, Bottom, Left, and Right.
Max starts up with the Top, Front, and Left orthographic viewports visible. The top-left corner
of the viewport displays the viewport name. The fourth default viewport is a Perspective view.

Figure 2-2 shows the viewports with Viewpoint model of a PT-328 U.S. Torpedo boat. You can
see the model from a different direction in each viewport. If you want to measure the boat’s
length from aft to stern, you could get an accurate measurement using the Top or Left view-
ports, whereas you can use the Front and Left viewports to measure its precise height. So,
using these different viewports, you can accurately work with all object dimensions.
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Figure 2-2: The Max interface includes four viewports, each with a different view.

Isometric views in Max are called User viewports. You can create a User viewport by rotating
any of the Orthographic views.

Max includes several keyboard shortcuts for quickly changing the view in the active viewport
including T (Top View), B (Bottom View), F (Front View), L (Left View), C (Camera View),
$ (Spotlight View), P (Perspective View), and U (Isometric User View). Pressing the V key
opens a quadmenu that lets you select a new view.
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Using the Viewport Navigation Controls

The standard viewports show you several different views of your current project, but the
default views aren’t necessarily the ones you want. To alter these default views, you need to
use the Viewport Navigation Control buttons. These eight buttons are located at the bottom-
right corner of the window. With these buttons, you can Zoom, Pan, and Rotate the active
view. In Table 2-1, the keyboard shortcut for each button is listed in parentheses next to its

Tip

name.
The active viewport is always marked with a yellow border.
Table 2-1: Viewport Navigation Controls
Toolbar Button Name Description

Zoom (Alt+Z or [ or ])

Zoom All

Zoom Extents (Ctrl+Alt+Z),
Zoom Extents Selected

Zoom Extents All (Ctrl+Shift+Z),
Zoom Extents All Selected (Z)

Field of View, Region Zoom

(Ctrl+Ww)

Pan (Ctrl+P or I)

Arc Rotate (Ctrl+R), Arc Rotate
Selected, Arc Rotate SubObject

Min/Max Toggle (Alt+W)

Moves closer to or farther from the objects
in the active viewport by dragging the
mouse or zooming by steps with the
bracket keys.

Zooms into or out of all the viewports
simultaneously by dragging the mouse.

Zooms in on all objects or just the selected
object until it fills the active viewport.

Zooms in on all objects or just the selected
object until it fills all the viewports.

The Field of View button (only available in
the Perspective view) controls the width
of the view. The Region Zoom button
zooms in to the region selected by
dragging the mouse.

Moves the view to the left, to the right, up,
or down by dragging the mouse or by
moving the mouse while holding down
the | key.

Rotates the view around the global axis,
selected object, or subobject by dragging
the mouse.

Makes the active viewport fill the screen
replacing the four separate viewports.
Clicking this button a second time shows all
four viewports again.
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Caution When one of the Viewport Navigation buttons is selected, it is highlighted yellow. You cannot
select, create, or transform objects while one of these buttons is highlighted. Right-clicking in
the active viewpoint reverts to select object mode.

Zooming a view

You can zoom in to and out of the scene in several ways. Clicking the Zoom (Alt+Z) button
enters zoom mode where you can zoom in to and out of a viewport by dragging the mouse.
This works in whichever viewport you drag in. To the right of the Zoom button is the Zoom
All button, which does the same thing as the Zoom button, only to all four viewports at once.
The Zoom Extents (Ctrl+Alt+Z) button zooms the active viewport so that all objects (or the
selected objects with the Zoom Extents Selected button) are visible in the viewport. A Zoom
Extents All (Ctrl+Shift+Z) button is available for zooming in all viewports to all objects’
extents; the most popular Zoom Extents All Selected (Z) is for zooming in to the extents of
the selected objects in all viewports.

You can use the brackets keys to zoom in ([) and out (]) by steps. Each key press zooms in
(or out) another step. The Region Zoom (Ctrl+W) button lets you drag over the region that
you want to zoom in on. If you select a non-orthogonal view, such as the Perspective view, the
Region Zoom button has a flyout called the Field of View. Using this button, you can control
how wide or narrow the view is. This is like using a wide angle or telephoto lens on your cam-
era. This feature is different from zoom in that the perspective is distorted as the Field of
View is increased.

|, gr?ss- \ Field of View is covered in more detail in Chapter 24, “Working with Cameras.”
eference

Panning a view

The Viewport Navigation Controls also offer two ways to pan in a viewport. In Pan mode
(Ctrl+P), dragging in a viewport pans the view. Note that this doesn’t move the objects, only
the view. The second way to pan is to hold down the I key while moving the mouse. This is
known as an interactive pan.

Rotating a view

Rotating the view can be the most revealing of all the view changes. When the Arc Rotate
(Ctrl+R) button is selected, a rotation guide appears in the active viewport, as shown in
Figure 2-3. This rotation guide is a circle with a square located at each quadrant. Clicking and
dragging the left or right squares rotates the view side to side; the same action with the top
and bottom squares rotates the view up and down. Clicking within the circle and dragging
rotates within a single plane, and clicking and dragging outside of the circle rotates the view
about the circle’s center either clockwise or counterclockwise. If you get confused, look at
the cursor, which changes depending on the type of rotation.
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Rotation guide

& vp5846.max - 3ds max 6 [S]E1x]
File Edit Tools Group Views Create Modifiers Character reactor Animation Graph Editors Rendering Customize MAXScript Help —I
M""' Bl Sk Ee O AR 9|4 % & P od i P & 15215

w7 8, @\ T
0B mays
Standard Primitives -
Box Cane
Sphere GeaSphers
Cplinder Tube
Torus Pyramid
Teapot Plane

Ce=AEF4 L EDPIOR |- D B

S T
‘59) E ‘HWH.HH‘II'%I‘I‘IHHBJ!]HHHH-uﬂ”HHHEDHHHHQ]HHH”%‘HHHH&U””””HDIHHIH'MB

‘Nnna‘&'ale‘_:tad_ ) E-xjsmzr r:l—zsaaz z‘|nn [ Gid = 100 e Auto Key| Selected <] e 5] e i |G B HF
[ Cick ard dragto rtste the view. Cickingin he labs corstains the otaton [ddTine Tag Setkey|  Keyfites. | W[ @ > 85

Figure 2-3: The rotation guide appears whenever the Arc Rotate button is selected.

/ Note If you rotate an orthogonal view, it automatically becomes a User view.
‘.,.n-"

-

Controlling viewports with a scroll wheel

Now that I've explained the Viewport Navigation Control buttons and listed their keyboard
shortcuts, I explain the easiest way to control the viewports —and clicking on the buttons
isn’t it. Often, the quickest way to control the viewports is with the mouse. To really get the
benefit of the mouse, you need to use a mouse with a scroll wheel.

Rolling the scroll wheel in the active viewport zooms in to and out of the viewport by steps
just like the bracket keys ([ and ]). You can zoom precisely by holding down the Ctrl and Alt
keys while dragging the scroll wheel. Clicking and dragging the scroll wheel button pans the
active viewport. Clicking and dragging with the Alt button held down rotates the active view-
port. If the scroll wheel isn’t working, check the Viewports panel in the Preference Settings
dialog box. You can select to use the scroll wheel control to pan and zoom in the viewports or
to define and use Strokes.
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| Referen

L’/——
Controlling camera and spotlight views

You can set any viewport to be a camera view (C) or a spotlight view ($) if a camera or a spot-
light exists in the scene. When either of these views is active, the Viewport Navigation
Control buttons change. In camera view, controls for dolly, roll, truck, pan, orbit, and field of
view become active. A light view includes controls for falloff and hotspots.

 Cross- \ Strokes are covered in Chapter 4, “Customizing the Max Interface and Setting Preferences.”
ce

- Cross- Chapter 24, “Working with Cameras,” and Chapter 27, “Basic Lighting Techniques,” cover
| Reference these changes in more detail.

Viewing grids

Grids are helpful in establishing your bearings in 3D space. For the active viewport, the G key
turns the grids on and off. The Views menu also includes several options for working with
grids.

|, gr?ss- \ Chapter 10, “Transforming Objects — Translate, Rotate, and Scale,” covers grids in more detail.
eference

Disabling and refreshing viewports

If your scene gets too complicated, you can experience some slow-down waiting for each
viewport to be updated with changes, but fear not because several options will come to your
rescue. The first option to try is to disable a viewport.

You can disable a viewport by right-clicking on the viewport’s name and selecting the Disable
View menu command from the pop-up menu, or you can press the keyboard shortcut, D.
When a disabled viewport is active, it is updated as normal; when it is inactive, the viewport
is not updated at all until it becomes active again. Disabled viewports are identified by the
word “Disabled,” which appears next to the viewport’s name in the upper-left corner.

Another trick to increase the viewport update speed is to disable the View => Update During
Spinner Drag menu option. Changing parameter spinners can cause a slow-down by requiring
every viewport to update as the spinner changes. If the spinner is changing rapidly, it can
really slow even a powerful system. Disabling this option causes the viewport to wait for the
spinner to stop changing before updating.

Sometimes when changes are made, the viewports aren’t completely refreshed. This typically
happens when dialog boxes from other programs are moved in front of the viewports. If this
happens, you can force Max to refresh all the viewports with the Views => Redraw All Views
(keyboard shortcut, *) menu command.

67
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Undoing and saving changes made with
the Viewport Navigation Controls

If you get lost in your view, you can undo and redo viewport changes with Views &> Undo View
Change (Shift+Z) and Views = Redo View Change (Shift+Y). These commands are different
from the Edit => Undo and Edit ©=> Redo commands, which can undo or redo geometry changes.

You can save changes made to a viewport by using the Views => Save Active Viewport menu
command. This command saves the Viewport Navigation settings for recall. To restore these
settings, use Views > Restore Active Viewport.

/ Note The Save and Restore Active Viewport commands do not save any viewport configuration
.~ settings, just the navigated view. Saving an active view uses a buffer, so it remembers only
one view for each viewport.

Maximizing the active viewport

Sooner or later, the viewports will feel too small. When this happens, you have several ways to
increase the size of your viewports. The first trick to try is to change the viewport sizes by
clicking and dragging any of the viewport borders. Dragging on the intersection of the view-
ports resizes all the viewports. Figure 2-4 shows the viewports after being dynamically resized.

Tip You can return to the original layout by right-clicking on any of the viewport borders and
A selecting Reset Layout from the pop-up menu.
_:_-_l
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Figure 2-4: You can dynamically resize viewports by dragging their borders.




Chapter 2 4+ Seeing It All — Working with the Viewports

The second trick to try is to use the Min/Max Toggle (Alt+W) to expand the active viewport to
fill the space reserved for all four viewports, as shown previously in Figure 2-3. Clicking the
Min/Max Toggle (or pressing Alt+W) a second time returns to the defined layout.

Maximizing the viewport helps temporarily, but you can take another step before convincing
your boss that you need a larger monitor. You can enter Expert Mode by choosing Views =
Expert Mode (Ctrl+X). It maximizes the viewport space by removing the toolbars, the
Command Panel, and most of the Lower Interface Bar.

With most of the interface elements gone, you'll need to rely on the menus, keyboard short-
cuts, and the quadmenus to execute commands. To re-enable the default interface, click the
Cancel Expert Mode button in the lower right of the Max window (or press Ctrl+X again).
Figure 2-5 shows the interface in Expert Mode.
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Figure 2-5: Expert Mode maximizes the viewports by eliminating most of the interface
elements.

Tutorial: Navigating the active viewport

Over time, working with the Viewport Navigation controls will become second nature to you,
but you need to practice to get to that point. In this tutorial, you get a chance to take the
viewports for a spin — literally.
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To practice navigating a viewport, follow these steps:
1. Open Bruce the dog.max file from the Chap 02 directory on the CD-ROM.

This file includes a model of a dog (affectionately named Bruce) created by Viewpoint.
It provides a reference as we navigate the viewport. The active viewport is the
Perspective viewport.

2. Click the Min/Max Toggle button (or press Alt+W) to make the Perspective viewport fill
the space of all four viewports.

3. Click the Pan button (or press Ctrl+P), and drag the window until Bruce’s head is cen-
tered in the viewport. Then click the Zoom button (or press Alt+Z), and drag in the
Perspective viewport until Bruce’s head fills the viewport, as shown in Figure 2-6.
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Figure 2-6: The Perspective viewport zoomed in on the dog's head using the Zoom and
Pan controls

4. Choose Views > Save Active Perspective View to save the current view of the
dog’s head.

5. Click the Zoom Extents button (or press Ctrl+Alt+Z) to size the entire dog body in the
current viewport.

6. Click the Arc Rotate button (or press Ctrl+R), and drag from the left square on the rota-
tion guide to the right. This rotates Bruce to make his front side more visible, as shown
in Figure 2-7. Good boy, Bruce.
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If you tried this tutorial as outlined, try it again using the mouse’s scroll wheel.
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Figure 2-7: The Perspective viewport after a slight rotation shows Bruce's good side.

Configuring the Viewports

If the Viewport Navigation Controls help define what you see, then the Viewport Configuration
dialog box helps define how you see objects in the viewports. You can configure each view-
port using this dialog box. To open this dialog box, choose the Customize > Viewport
Configuration menu command. You can also open this dialog box by right-clicking the view-
port’s name located in the upper-left corner of each viewport and choosing Configure from
the pop-up menu. The pop-up menu itself includes many of the settings found in the Viewport
Configuration dialog box, but the dialog box lets you alter several settings at once. You can
also make this dialog box appear for the active viewport by right-clicking any of the Viewport
Navigation Control buttons in the lower-right corner.

The Viewport Configuration dialog box contains several panels, including Rendering Method,
Layout, Safe Frames, Adaptive Degradation, and Regions. The Preference Settings dialog box
also includes many settings for controlling the behavior and look of the viewports.

See Chapter 4, “Customizing the Max Interface and Setting Preferences” for more on the
Preference Settings dialog box and all its options.
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Setting the viewport rendering method

Complex scenes take longer to display and render. The renderer used for the viewports is
highly optimized to be very quick, but if you're working on a huge model with lots of complex
textures and every viewport is set to display the highest quality view, then updating each
viewport can slow the program to a crawl. The Viewport Configuration dialog box’s
Rendering Method panel, shown in Figure 2-8, lets you set the rendering settings for the
Active Viewport, All Viewports, or All but Active viewport.

Tip If you ever get stuck waiting for Max to complete a task, such as redrawing the viewports, you
) can always press the Escape key to immediately suspend any task and return control to the
» interface.
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Figure 2-8: The Rendering Method panel holds controls
for specifying the Rendering Level and several other
rendering options.

/Note These settings have no effect on the final rendering specified using the Rendering menu.
s They affect only the display in the viewport.

Rendering levels

The Rendering Level options, from slowest to fastest, include the following:

4+ Smooth+Highlights: Shows smooth surfaces with lighting highlights. This rendering
type is the slowest.

4+ Smooth: Shows smooth surfaces without any lighting effects.
4+ Facets+Highlights: Shows individual polygon faces and lighting highlights.

4 Facets: Shows individual polygon faces without any lighting effects.
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4 Lit Wireframes: Shows polygon edges with lighting effects.
4 Wireframe: Shows polygon edges only.

4+ Bounding Box: Shows a box that would enclose the object. This rendering type is the
quickest.

/ Note Although it really isn't a rendering method, the Edged Faces option shows the edges for each
‘.,.n-"

face when a shaded rendering method is selected. You can enable and disable this option
with the F4 keyboard shortcut.

Figure 2-9 shows, side by side, all the various viewport rendering methods applied to a simple
sphere.

Figure 2-9: The viewport rendering methods from left to right are
First Row: Smooth+Highlights, Smooth, Facets+Highlights, Facets.
Second Row: Lit Wireframes, Wireframe, Bounding Box, and
Edged Faces applied to Smooth-+Highlights.

The most common rendering setting is Wireframe. It gives a good representation of the object
while redrawing very quickly. Faceted rendering displays every face as a flat plane, but it
shows the object as a solid model and is good for checking whether objects overlap. The
Smooth rendering level shows a rough approximation of the final rendering. Setting the ren-
dering level to include highlights shows the effect of the lights in the scene.

/Note Many effects, such as bump maps, transparent maps, and shadows, cannot be seen in the
‘.,.n-"

viewport and show up only in the final render.

Viewing transparency

In addition to these shading types, you can set the viewport to display objects that contain
transparency (which is set in the Object Properties dialog box). The three Transparency
options are None, which doesn’t display any transparency; Simple, which cross-hatches
the transparent object; and Best, which includes a transparency effect for a smooth look.
Figure 2-10 shows these three transparency options with the help of a Pacman-like creature
and his ghostly rival.
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Figure 2-10: The viewport transparency options include None, Simple,
and Best.

Rendering options

The Rendering Options section within the Rendering Method panel includes several other
options, such as Disable View (D) and Disable Textures. These options can help speed up
viewport updates or increase the visual detail of the objects in the viewport.

At any time during a viewport update, you can click the mouse or press a key to cancel the

,‘ redraw. Max doesn’t make you wait for a screen redraw to be able to execute commands
.

“» with the mouse or keyboard shortcuts.

Disable Textures turns off texture rendering for quick viewport updates. The Texture
Correction option speeds rendering updates by interpolating the current texture rather than
re-rendering. Texture Correction (along with Disable View) is one of the options available in
the pop-up menu by right-clicking the viewport name.

A Z-Buffer is used to keep track of each object’s distance from the camera. Enabling Z-Buffer
Wireframe Objects causes the wireframe objects to be drawn from back to front. If your wire-
frame lines seem to be disappearing, it could be that the viewport is drawing the lines in
whatever order and some lines that should appear in the back are being drawn on top of the
ones in the front. Enabling this option helps prevent that.

Force 2-Sided makes both sides of all faces visible. For example, suppose you have a sphere
with a hole in it. This setting enables you to see the interior surface of the sphere through the
hole. Figure 2-11 shows a sphere with a star-shape cutout of its surface. The left image has the
Force 2-Sided option disabled, and the image on the right has it enabled.

Figure 2-11: The Force 2-Sided option makes the interior of objects
visible.

The Default Lighting toggle deactivates your current lights and uses the default lights. This
option can be helpful when you’re trying to view objects in a dark setting because the default
lighting illuminates the entire scene without requiring you to remove or turn off lights. You
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can also specify whether default lighting uses one light or two. The one-light option creates a
single light positioned behind the viewer and at an angle to the scene. Scenes with one light
update quicker than scenes with two.

Making selected objects visible

You use Shade Selected Faces (F2) to shade selected subobject faces in red, making them
easy to see.

/ Note The Shade Selected Faces (F2) option, which shades selected subobject faces, is different
e from the Views > Shade Selected menu command, which turns on shading for the selected
object in all viewports.

The Use Selection Brackets option displays white corners around the current selection.
Selection brackets are useful for helping you see the entire size of a grouped object but can
be annoying if left on with many objects selected. Uncheck this option (or press the J key) to
make these brackets disappear.

The option to Display Selected with Edged Faces helps to highlight the selected object. If this
option is enabled, then the edges of the current selection are displayed regardless of whether
the Edged Faces check box is enabled. Figure 2-12 shows a dinosaur with his upper fin
selected with the Display Selected with Edged Faces option and the Use Selection Brackets
options enabled. These options make the current selection easy to see.
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Figure 2-12: The Display Selected with Edged Faces and Use Selection Brackets options
make identifying the current selection easy.
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Using clipping planes

Clipping planes define an invisible barrier beyond which all objects are invisible. For exam-
ple, if you have a scene with many detailed mountain objects in the background, working with
an object in the front of the scene can be difficult. By setting the clipping plane between the
two, you can work on the front objects without having to redraw the mountain objects every
time you update the scene. This affects only the viewport, not the rendered output.

Enabling the Viewport Clipping option places a yellow line with two arrows on the right side
of the viewport, as shown in Figure 2-13. The top arrow represents the back clipping plane,
and the bottom arrow is the front clipping plane. Drag the arrows to set the clipping planes.
You can quickly turn Viewport Clipping on or off by right-clicking the viewport name and
choosing Viewport Clipping from the pop-up menu.

Clipping plane markers
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Figure 2-13: The clipping planes can be used to hide the front and rear of this ship to
focus on the center section.

Enabling Fast View
The Fast View option speeds viewport updates by drawing only a limited number of faces.
The spinner value determines how often faces are drawn. For example, a setting of 5 would

draw only every fifth face. This option renders viewport updates much quicker and gives you
an idea of the objects without displaying the entire object.
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Tutorial: Creating interesting patterns with the Fast View setting

You can use the Fast View setting in the Viewport Configuration dialog box to create some
interesting patterns.

To create patterned spheres, follow these steps:
1. Open the Patterned sphere.max file from the Chap 02 directory on the CD-ROM.
This file has a simple smooth sphere.

2. Click in the Top view, and choose Customize > Viewport Configuration to open the
Viewport Configuration dialog box. Select the Smooth Rendering Level and the Fast
View Nth Faces options. Set the Fast View Nth Faces value to 2.

3. Repeat Step 2 for the Front, Left, and Perspective viewports, setting the Fast View Nth
Faces values to 3, 4, and 5, respectively.

Figure 2-14 shows a sphere rendered using the Fast View option. Notice that the settings for
each viewport can be different.
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Figure 2-14: Cool patterns created with the Fast View setting in the Viewport Configuration
dialog box
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/Note If any of these spheres were rendered using the Rendering menu, the entire sphere would
e be visible. The Fast View option affects only the viewport display.

Setting the Field of View

You can also alter the Field of View (FOV)for the Perspective view in the Viewport
Configuration dialog box. To create a fish-eye view, increase the FOV setting to 10 or more.
The maximum FOV value is 180, and the default value is 45. You can also change the Field of
View using the Field of View button in the Viewport Navigation Controls. The Viewport
Configuration dialog box, however, lets you enter precise values.

r Cross- See Chapter 24, "Working with Cameras,” for more coverage on Field of View.
Reference \

Grabbing a viewport image

It’s not rendering, but you can grab an image of the active viewport using the Tools => Grab
Viewport. Before grabbing the image, a simple dialog box appears asking you to add a label
to the grabbed image. The image is loaded into the Rendered Frame Window, and its label
appears in the lower-right corner of the image, as shown in Figure 2-15.

plew \ The Grab Viewport menu command is new to 3ds max 6.
eature
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Figure 2-15: A viewport image can be
grabbed using a menu command found
in the Tools menu.

Altering the Viewport layout

Now that you've started to figure out the viewports, you may want to change the number and
size of viewports that are displayed. The Layout panel, shown in Figure 2-16, in the Viewpoint
Configuration dialog box offers several layouts as alternatives to the default layout (not that
there is anything wrong with the default and its four equally sized viewports).
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Figure 2-16: The Layout panel offers many layout options.

After selecting a layout from the options at the top of the panel, you can assign each individ-
ual viewport a different view by clicking the viewport and choosing a view from the pop-up
menu. The view options include Perspective, User, Front, Back, Top, Bottom, Left, Right,
ActiveShade, Schematic, Grid (Front, Back, Top, Bottom, Left, Right, Display Planes),
Extended (Asset Browser, MAXScript Listener), and Shape.

Views can also be set to Camera and Spotlight if they exist in the scene. Each camera and
light that exists is listed by name at the top of the pop-up menu.

Using Safe Frames

Completing an animation and converting it to some broadcast medium, only to see that the
whole left side of the animation is being cut off in the final screening, can be discouraging. If
you rely on the size of the active viewport to show the edges of the final output, you could be
way off. Using the Safe Frames feature, you can display some guides within the viewport that
show where these clipping edges are.

The Safe Frames panel of the Viewport Configuration dialog box lets you define several safe
frame options, as shown in Figure 2-17, including the following:

4 Live Area: Marks the area that will be rendered, shown as yellow lines. If a background
image is added to the viewport and the Match Rendering Output option is selected,
then the background image will fit within the Live Area.

4 Action Safe: The area ensured to be visible in the final rendered file, marked with light
blue lines; objects outside this area will be at the edge of the television screen and
could be distorted.

4 Title Safe: The area where the title can safely appear without distortion or bleeding,
marked with orange lines.

4 User Safe: The output area defined by the user, marked with magenta lines.

4 12-Field Grid: Displays a grid in the viewport, marked with a pink grid.

79
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Figure 2-17: The Safe Frames panel lets you specify
areas to render.

For each type of safe frame, you can set the percent reduction by entering values in the
Horizontal, Vertical, or Both fields. The 12-Field Grid option offers 4 x 3 and 12 x 9 aspect
ratios.

The Show Safe Frames in Active View option displays the Safe Frame borders in the active
viewport. You can quickly enable or disable Safe Frames by right-clicking the viewport name
and choosing Show Safe Frame in the pop-up menu (or you can use the Shift+F keyboard
shortcut).

Figure 2-18 shows an elongated Perspective viewport with all the safe frame guides enabled.
The Safe Frames show that the top and bottom of my covered wagon will be cut off whe
rendered.

Understanding Adaptive Degradation

When you are previewing a complex animation sequence in a viewport, slow updates can
affect the timing of the animation. This can make proofing your work difficult and would
require many additional, fully rendered tasks. The feature in Max that addresses this issue

is called Adaptive Degradation, and although it sounds like a weapon that some alien would
use to disarm you, it enables you to force a viewport to display at a prespecified number of
frames per second. If the display update takes too long to maintain this rate, then it automati-
cally degrades the rendering level in order to maintain the frame rate. This option is very
helpful because when you're testing an animation, you are not as concerned about the model
details or textures.

The Adaptive Degradation panel is available in the Viewport Configuration dialog box, as
shown in Figure 2-19.
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Figure 2-18: Safe frames provide guides that help you see when the scene objects are
out of bounds.
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Figure 2-19: The Adaptive Degradation panel maintains
a defined frame rate by degrading the rendering level.
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You can enable Adaptive Degradation by using the Views => Adaptive Degradation menu
command (or by pressing the O key). Adaptive Degradation, when enabled, is used only for
animation sequences where the objects are updated within the viewport quickly. If the anima-
tion isn’t progressing, then enabling and disabling Adaptive Degradation has no effect.

\ You learn to animate objects in Chapter 30, “Animation Basics."
ce

You enter the frame rate that you want to maintain into the Maintain FPS box in the Degrade
Parameters section. The General Degradation selection specifies the render level used by all
inactive viewports; the Active Degradation selection is used by the active viewport. You can
select several rendering levels in each section.

Another way to speed the frame rate in the active viewport is to disable (D) the inactive
.~ viewports.
4

The Reset on Mouse Up option forces Max to render at the specified rendering levels when
the mouse is released. The Show Rebuild Cursor option makes the cursor visible as the view-
ports are rendered. The Update Time is the amount of time between rendering updates.

At a setting of 0, each frame must be completely rendered before the next frame is attempted.
The Interrupt Time value is how long Max waits before checking to see whether the mouse
has moved.

Defining regions

Regions, the final panel in the Viewport Configuration dialog box, enables you to define regions
and focus your rendering energies on a smaller area. Complex scenes can take considerable
time and machine power to render. Sometimes, you want to test render only a portion of a
viewport to check material assignment, texture map placement, or lighting.

You can define the size of the various Regions in the Regions panel of the Viewport
Configuration dialog box, shown in Figure 2-20.

After you've specified a Blowup Region or a Sub Region, you can select to render using these
regions by selecting Region or Blowup from the Render Type drop-down list on the far-right
end of the main toolbar and clicking the Quick Render button. After clicking the Quick Render
button, the specified region is displayed as an outline in the viewport and an OK button
appears in the lower-right corner of the viewport. You can move this outline to reposition

it or drag its edge or corner handles to resize the region. The new position and dimension
values are updated in the Regions panel for next time. Click the OK button to begin the
rendering process.

The difference between these two regions is that the Sub Region displays the Rendered Frame
Window in black except for the specified sub-region. The Blowup Region fills the entire
Rendered Frame Window, as shown in Figure 2-21.

You can learn more about Render Types and the Rendered Frame Window in Chapter 41,
c8 “Rendering Basics.”
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Figure 2-20: The Regions panel enables you to work
with smaller regions within your scene.
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Figure 2-21: The image on the left was rendered using the
Sub Region option; the right image used the Blowup Region.

The Virtual Viewport is a feature that lets you zoom in and pan within the viewport image
using the numeric keypad. This feature is available only if you are using the OpenGL display
driver. You can check to see which display driver you are using by selecting Help => About 3ds
max. This command opens a credits screen that lists the current driver. You can change the
current display driver in the Viewport panel of the Preference Settings dialog box.

If you have OpenGL set up as the current display driver, then you can select Use Virtual
Viewport to display the viewport in the area to the right. Using the Zoom, X, and Y Offset val-
ues, you can specify where the Virtual Viewport looks or you can drag the rectangular outline
in the visible screen to the right.
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Once enabled, you can use the divide key (/) on the numeric keypad to turn the virtual view-
port on and off. Use the plus (+) and minus (-) numeric keypad keys to zoom in and out, and
use the 2, 4, 6, and 8 keys on the numeric keypad to pan within the virtual viewport.

Caution The Virtual Viewport feature is available only if you are using the OpenGL driver. If you've
specified either the Software Z-Buffer or the Direct X driver, then this option isn't available.

Working with Viewport Backgrounds

Remember in grade school when you realized that you could immediately draw really well
using tracing paper (where all you needed to do was follow the lines)? Well, it’s not quite trac-
ing paper, but you can load background images into a viewport that can help as you create
and position your objects.

Loading viewport background images

The Views = Viewport Background menu command (Alt+B) opens a dialog box, shown in
Figure 2-22, where you can select an image or animation to appear behind a viewport. The
displayed background image is helpful for aligning objects in a scene, but it is for display pur-
poses only and will not be rendered. To create a background image to be rendered, you need
to specify the background in the Environment dialog box, opened using the Rendering =
Environment (keyboard shortcut, 8) menu command.
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Figure 2-22: The Viewport Background
dialog box lets you select a background
source image or animation.
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If the background image changes, you can update the viewport using the Views => Update
Background Image menu command (Alt+Shift+Ctrl+B). This is helpful if you have the back-
ground image opened in Photoshop at the same time. You can update the background image,
save it, and then immediately update the image in Max. The Views ©> Reset Background
Transform menu command automatically rescales and recenters the background image to

fit the viewport. You should use this if you've changed the viewport size or changed the
background’s size.

Each viewport can have a different background image. To load and configure a viewport back-
ground image, choose Views > Viewport Background (or press the Alt+B keyboard shortcut).
This opens the Viewport Background dialog box, shown previously.

The Files button opens the Select Background Image dialog box, where you can select the
image to load. The Devices button lets you obtain a background from a device such as a
Video Recorder. If an environment map is already loaded into the Environment dialog box,
you can simply click the Use Environment Background option. Keep in mind that the back-
ground image will not be rendered unless it is made into an Environment map.

\ I cover environment maps in Chapter 41, “Rendering Basics.”
ce

Loading viewport background animations

The Animation Synchronization section of the Viewport Background dialog box lets you set
which frames of a background animation sequence are displayed. The Use Frame and To val-
ues determine which frames of the loaded animation are used. The Step value trims the num-
ber of frames that are to be used by selecting every Nth frame. For example, a Step value of 4
would use every fourth frame.

Loading an animation sequence as a viewport background can really help as you begin to
h animate complex motions, like a running horse. By stepping through the frames of the ani-

%

4  mation, you can line up your model with the background image for realistic animations.

The Start At value is the frame in the current scene where this background animation would
first appear. The Sync Start to Frame value is the frame of the background animation that
should appear first. The Start and End Processing options let you determine what appears
before the Start and End frames. Options include displaying a blank, holding the current
frame, and looping.

If you select an animation as the background, make sure that the Animate Background option
is selected. Also note that the viewport background is not visible if the Display Background
option is not selected.
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The Aspect Ratio section offers options for setting the size of the background image. You can
select to Match Viewport, Match Bitmap, or Match Rendering Output.

The Lock Zoom/Pan option is available if either the Match Bitmap option or the Match
Rendering Output option is selected. This option locks the background image to the geome-
try so that when the objects in the scene are zoomed or panned, the background image fol-
lows. If the background gets out of line, you can reset its position with the Views => Reset
Background Transform command.

Caution When the Lock Zoom/Pan option is selected, the background image is resized when you
zoom in on an object. Resizing the background image fills the virtual memory, and if you
zoom in too far, the background image could exceed your virtual memory. If this happens, a
dialog box appears that informs you of the problem and gives you the option of not display-
ing the background image.

You can set the Apply Source and Display to option to display the background in All Views or
in the Active Only.

Tutorial: Loading reference images for modeling

When modeling a physical object, you can get a jump on the project by taking pictures with a
digital camera of the front, top, and left views of the object and then load them as background
images in the respective viewports. The background images can then be a reference for your
work. This is especially helpful with models that need to be precise. You can even work from
CAD drawings.

To load the background images of a brass swan, follow these steps:
1. Choose File> New (or press Ctrl+N) to open a blank scene file.

2. Right-click on the Front viewport to make it the active viewport, and choose Views =
Viewport Background (or press Alt+B).

The Viewport Background dialog box opens.

3. Click on the Files button, and in the File dialog box that opens, select the Brass swan-
front view.jpg image from the Chap 02 directory on the CD-ROM.

4. Select the Match Bitmap, Display Background, Lock Zoom/Pan, and Active Only
options, and click OK to close the dialog box.

The image now appears in the background of the Front viewport.
5. Repeat Steps 2 through 4 for the Top and Left viewports.

Figure 2-23 shows the Max interface with background images loaded in the Front, Top, and
Left viewports.
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Figure 2-23: Adding a background image to a viewport can help as you begln to modeI
objects.

Summary

Viewports are the window into the Max world. Remember that if you can’t see it, you can’t
work with it, so you need to learn to use the viewports. You can also configure viewports to
display just the way you desire.

In this chapter, you
4 Learned about 3D space and the various viewport types
4 Covered the various Viewport Navigation Control buttons
4+ Set the Rendering Level and Display options in the Viewport Configuration dialog box

4 Used the other panels of the Viewport Configuration dialog box to change the layout,
safe frames, and regions
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4 Learned how you can use Adaptive Degradation to maintain a constant frame rate for
viewport animation sequences

4+ Loaded a viewport background image

In the next chapter, you find out all the details about working with files, including loading,
saving, and merging scene files. You also learn about External References (XRefs) and how to
use them to manage scene creation in a workgroup. The next chapter also covers import and
export options for interfacing with other software packages.

+ o+ 4



CHAPTER

Working with Files
and XRefs

COmplex scenes can end up being a collection of hundreds of files,
and misplacing any of them will affect the final output, so learn-
ing to work with files is critical. This chapter focuses on working with
files whether they be object files, texture images, or background
images. Files enable you to move scene pieces into and out of Max.
You can also export and import files to and from other packages.

Max scenes can also be composed from several different objects that
have been created by a team. Using external references (XRefs), you
can pull all the different pieces together into a single scene.

Working with Max Scene Files

Of all the different file types and formats, there is one file type that
you will probably work with more than any other —the max format.
Max has its own proprietary format for its scene files. These files
have the .max extension and allow you to save your work as a file and
return to it at a later time. Max also supports files saved with the .chr
extension used for character files.

When Max starts, a new scene opens. You can start a new scene at
any time with the File=> New (Ctrl+N) command. Although each
instance of Max can have only one scene open at a time, under
Windows XP, you can open multiple copies of Max, each with its own
scene instance.

Starting a new scene deletes the current scene, but Max asks you
whether you want to keep the objects and hierarchy, keep the
objects, or make everything new, as shown in Figure 3-1. Starting a
new scene with the File> New menu command maintains all the cur-
rent interface settings, including the viewport configurations, any
interface changes, viewport backgrounds, and any changes to the
Command Panel. To reset the interface, choose File > Reset. When
reset, all interface settings return to their default states, but interface
changes aren’t affected.

¢+ 0+ o+
In This Chapter

Saving, opening,
merging, and
archiving files

Importing and exporting
objects and scenes

Importing objects from
external packages like
Illustrator and Poser

Externally referencing
objects and scenes

Working with file
utilities such as the
Asset Browser

Accessing scene files
information

+ + o+
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New Scene @i Figure 3-1: When creating a new scene, you can
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Saving files

After you start up Max, the first thing you should learn is how to save your work. After a
scene has changed, you can save it as a file. Before a file is saved, the word “Untitled” appears
in the title bar; after you save the file, its name appears in the title bar. Choose File > Save
(Ctrl+S) to save the scene. If the scene hasn’t been saved yet, then a Save File As dialog box
appears, as shown in Figure 3-2. You can also make this dialog box appear using the File =>
Save As command. After a file’s been saved, using the File=> Save command saves the file
without opening the File dialog box. Pretty simple —just don’t forget to do it often.
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Figure 3-2: Use the Save File As dialog box to save a scene
as a file.

The Save File As dialog box keeps a history list of the last five directories that you've opened.
You can select these directories from the History drop-down list at the top of the dialog box.
The buttons in this dialog box are the standard Windows file dialog box buttons used to go to
the last folder visited, go up one directory, create a new folder, and to view a pop-up menu of
file view options. The options include Large Icons, Small Icons, List, Details, and Thumbnails.
The thumbnail option displays an image of the active viewport, which is useful when you
open files, but when you save files for the first time, the thumbnail is blank.
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_./Note If you try to save a scene over the top of an existing scene, then Max presents a dialog box
o confirming this action.

Clicking the button with a plus sign to the right of the Save button automatically
appends a number onto the end of the current filename and saves the file. For example,
if you select the myScene.max file and click the plus button, a file named myScene(01.max is

saved.
Tip Use the auto increment file number and Save button to save progressive versions of a scene.
.. This is an easy version control system. If you need to backtrack to an earlier version, you can.
/

The File menu also includes an option to Save Selected. This option saves the current
selected objects to a separate scene file. If you create a single object that you might possibly
use again, select the object and use the Save Selected option to save it to a directory of mod-
els. A Save Copy As menu command is also available that lets you save the current scene to a
different name without changing its current name.

Another useful feature for saving files is to enable the Auto Backup feature in the File panel
of the Preference Settings dialog box. This dialog box can be accessed with the Customize =
Preferences menu command, which is covered later in this chapter.

Opening files

After you've saved a file, you might want to know how to open it again. Choosing File > Open
(Ctrl+O) opens a file dialog box that is the same as the one used to save files, shown in Figure
3-2. Max can open files saved with the .max and .chr extensions. Max can also open VIZ
Render files that have the .drf extension. Selecting a file and clicking on the plus button opens
a copy of the selected file with a new version number appended to its name.

Elew \ The ability to open VIZ Render (DRF) files is new to 3ds max 6.
eature

If Max cannot locate resources used within a scene (such as maps) when you open a Max file,
then the Missing External Files dialog box, shown in Figure 3-3, appears, enabling you to

Continue without the file or to Browse for the missing files. If you click the Browse button, the
Configure External File Paths dialog box opens, where you can add a path to the missing files.

Missing External Files &

Z:\modpubiMaxBiblet odelsytp58514d_shark_grwhtOlh.tf
Z:smodpubihaxBibletd odelsytpS8514d_shark_fins01 h.tif

<] | B

Continue | Browse ‘

Figure 3-3: The Missing External Files dialog box
identifies files for the current scene that are missing.
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If you open a file that includes features that have changed since the previous version, then
Max presents an obsolete data format warning statement. Resaving the file can fix this prob-
lem. However, if you save a file created with a previous version of Max as a Max 6 scene file,
then you won’t be able to open the file again in the previous versions of Max.

You can disable the Obsolete File Message in the Files panel of the Preference Settings
dialog box.

y

The most recently opened scenes are listed in the File=> Open Recent submenu. Selecting
these scenes from the list opens the scene file.

You can also open files from the command line by placing the filename after the executable
- name, i.e., 3dsmax.exe myFile.max. You can also use the —L switch after the executable name
to open the last file that was opened.

Merging and replacing objects

If you happen to create the perfect prop in one scene and want to integrate the prop into
another scene, you can use the Merge menu command. Choose File ©> Merge to load objects
from another scene into the current scene. Using this menu command opens a file dialog box
that is exactly like the Save As dialog box, but after you select a scene and click the Open
button, the Merge dialog box, shown in Figure 3-4, appears. This dialog box displays all the
objects found in the selected scene file. It also has options for sorting the objects and filtering
certain types of objects. Selecting an object and clicking the OK button loads the object into
the current scene.

The Merge dialog box is very similar to the Select Objects dialog box.

—
Merge - vp20810.max [2]%]
rSort
& Alphabetizal
e £ o
Bl " By Color
landz2
leafs i ==
afez List types
leafsd v Geometry Al
ocean
palm2 [ Shapes M
palm3 .
e [V Lights Ivert
trunk. ¥ LCameras
¥ Helpers
¥ Space'wWaips
£l i > IV Groups/ssemblies
v Bone Objects
All ‘ Hone | Irwveert ‘
[ Display Subtree ™ Case Sensiive oK Cancel
[ Select Sublies

Figure 3-4: The Merge dialog box lists all the objects
from a merging scene.
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If you ever get involved in a modeling duel, then you’ll probably be using the File &> Replace
menu command at some time. A modeling duel is when two modelers work on the same
rough model of named objects and the animator (or boss) gets to choose which object to use.
With the File=>Replace menu command, you can replace a named object with an object of the
same name in a different scene. The objects are selected using the same dialog box shown in
Figure 3-4, but only the objects with identical names in both scene files display. If no objects
with the same name appear in both scene files, a warning box is displayed.

- Cross- The File menu also includes a Merge Animation menu command, which is covered in
| Reference Chapter 30, “Animation Basics.”

Archiving files

By archiving a Max scene along with its reference bitmaps, you can ensure that the file
includes all the necessary files. This is especially useful if you need to send the project to
your cousin to show off or to your boss and you don’t want to miss any ancillary files.
Choose File = Archive to save all scene files as a compressed archive. The default archive for-
mat is .zip (but you can change it in the File panel of the Preference Settings dialog box to use
whatever archive format you want). The Archive System lets you specify which archive pro-
gram Max uses to archive your files. Maxzip is the default, but you can change it to whichever
program you want to use.

Saving an archive as a .zip file compiles all external files, such as bitmaps, into a single com-
pressed file. The File Type drop-down list of the File Archive dialog box also includes an
option to create a List of Files. When you select this file type, a text file is created that lists
all relevant files and their paths.

Getting out

As you can probably guess, you use the File & Exit command to exit the program, but only
after it gives you a chance to save your work. Clicking on the window icon with an X on it in
the upper right has the same effect (but I'm sure you knew that).

Setting File Preferences

The Files panel of the Preference Settings dialog box holds the controls for backing up,
archiving, and logging Max files. You can open this dialog box using the Customize &>
Preferences menu command. Figure 3-5 shows this panel.

Handling files

The Files panel includes several options that define how to handle files. The first option is to
Backup on Save. When you save a file using the File => Save (Ctrl+S) menu command, the exist-
ing file is overwritten. The Backup on Save option causes the current scene file to be saved as
a backup (with the name MaxBack.bak in the 3dsmax\autobak directory) before saving the
new file. If the changes you made were a mistake, you can recover the file before the last
changes by renaming the MaxBack.bak file to MaxBack.max and reopening it in Max.
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Preference Settings =JE3
Inverse Kinematics ‘ Gizmos: | Iddse<S cript ‘ Radiosity | mental ray |
General | Files ‘ “Wiewports | Gamma | Rendering | Animation |
rFleHanding——————— | LogFile Maintenance
[ Backup on Save " Never delete log
[ Inciement on Save © Maintain only lT ﬂ daps
[™ Compress on Save @ Mairtain oy [256 2] KBptes
v Save Viewport Thumbnail Image:
v Save Schematic View ¥ Enors
¥ Save File Properties ¥ Wwamings
v Display Obsolete File Message ¥ Irfo
¥ Reload testures on change ¥ Debug
Recent Files in File Menu: IEI_ g
r~ Import Options
BB ¥ Zoom Extents on Import
¥ Enable

Number of Autobak files: |3 ﬂ
Backup Interval [minutes):  |5.0 g

Auto Backup File Name: IAutubak manzip

rAichive System

Program:

Cancel

Figure 3-5: The Files panel includes an Auto Backup feature.

Another option to prevent overwriting your changes is the Increment on Save option. This
option adds an incremented number to the end of the existing filename every time it is saved.
This retains multiple copies of the file and is an easy version-control method for your scene
files. This way, you can always go back to an earlier file when the client changes his mind.
With this option enabled, the MaxBack.bak file isn’t used.

The Compress on Save option compresses the file automatically when it is saved. Compressed
files require less file space but take longer to load. If you're running low on hard drive space,
then you’ll want to enable this option.

The Save Viewport Thumbnail Image option saves a 64x64-pixel thumbnail of the active view-
port along with the file. This thumbnail is displayed in the Open dialog box and can also be
seen from Windows Explorer, as shown in Figure 3-6. Saving a thumbnail with a scene adds
about 9K to the file size.

The Save Viewport Thumbnail Image option is another good option to keep enabled.
. Thumbnails help you to find scene files later, and nothing is more frustrating than seeing a
# scene’s filename without a thumbnail.

In addition to a thumbnail, Max also offers an option to save the Schematic View with the file.
Although Max can generate a new Schematic View from an existing file, saving the Schematic
View with the file is quicker if you work with this view often. Saving File Properties with the
file is also helpful, but be warned that saving this extra info with the file increases its file size
slightly. Still, doing so is worth the effort because you can easily locate and understand the
scene file later on.
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Figure 3-6: Max files with thumbnails show up in Windows Explorer.

When a Max file created in a previous version of Max is opened, a warning dialog box appears
that says, “Obsolete data format found — Please resave file.” To eliminate this warning, dis-
able the Display Obsolete File Message option. The warning dialog box also includes an
option to Don’t Display Again that enables this option when selected.

When textures are updated, the Reload Textures on Change option forces the textures to be
reloaded when they are altered. This slows your system while Max waits for the textures to
reload, but offers the latest look immediately.

The Recent Files in File Menu option determines the number of recently opened files that
appear in the File=> Open Recent menu. The maximum value is 9.

I like to set the Recent Files in File Menu option at its highest value because I find that this is
the easiest way to open up the latest scenes.

& 4

Backing up files

The Auto Backup feature in Max can save you from the nightmare of losing all your work due
to a system crash. With Auto Backup enabled, you can select the number of Autobak Files to
keep around and how often the files are backed up. The backup files are saved to the direc-
tory specified by the Configure Paths dialog box. The default is to save these backups to the
3dsmax\autoback directory. You can also select a name for the backup files.
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Even if you have this feature enabled, you should still save your file often.
-',,.l-’

This is how it works: If you've set the number of backup files to 2, the interval to 5 minutes,
and the backup name to MyBackup, then after five minutes, the current file is saved as
MyBackupl.max. After another five minutes, another file named MyBackup2.max is saved,
and then after another five minutes, the MyBackupl.max file is overwritten with the latest
changes.

If you lose your work due to a power failure or by having your toddler accidentally pull out
the plug, you can recover your work by locating the autobak file with the latest date and
reloading it into Max. This file won’t include all the latest changes, only updates up to the last
backup save.

I highly recommend that you keep the Auto Backup option enabled. This feature has saved
.. my bacon more than once.
4
Tutorial: Setting Auto Backup

Now that I have stressed that setting up Auto Backup is an important step to do, let’s run
through exactly how to set it up.

To set up the Auto Backup feature, follow these steps:

1. Open the Preferences Settings dialog box by choosing Customize = Preferences, and
click the Files panel.

2. Turn on Auto Backup by selecting the Enable option in the Auto Backup section.
3. Set the number of Autobak files to 3.
To maintain version control of your Max scenes, use the Increment on Save feature instead of
o increasing the Number of Autobak Files.
4. Set the Backup Interval to the amount of time to wait between backups.

The Backup Interval should be set to the maximum amount of work that you are willing
to redo. (I keep my settings at 5 minutes.) You can also give the Auto Backup file a name.

5. Auto Backup saves the files in the directory specified by the Auto Backup path. To view
where this path is located, choose Customize => Configure Paths.

Maintaining log files

You can also use the Files panel to control log files. Log files keep track of any errors and
warnings, general command info, and any debugging information. You can set log files to
never be deleted, expire after so many days, or keep a specified file size with the latest infor-
mation. If your system is having trouble, checking the error log gives you some idea as to
what the problem is. Logs are essential if you plan on developing any custom scripts or plug-
ins. You can select that the log contain all Errors, Warnings, Info, and Debug statements.
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Each entry in the log file includes a date-time stamp and a three-letter designation of the type
of message with DBG for debug, INF for info, WRN for warning, and ERR for error messages
followed by the message. The name of the log file is Max.log. It is saved in the 3dsmax\
network subdirectory.

Importing and Exporting

If you haven’t noticed, Max isn’t the only game in town. A number of different 3D packages
exist, and exchanging files between them is where the importing and exporting menu com-
mands come in. You can find both of these commands in the File menu.

Importing supported formats

Choose File = Import to open the Import dialog box. This dialog box looks like a typical
Windows file dialog box. The real power comes with the various Import Settings dialog boxes
that are available for each format. The settings in the Import Settings dialog box are different
for the various format types.

Another common import dialog box offers options to merge the imported objects with the
current scene or to completely replace the current scene. For many formats, you can also

convert units on the imported file. For example, importing a 3D Studio file opens a simple

dialog box, shown in Figure 3-7. With the Convert Units option selected, Max assumes that
the 3DS file is based in inches and converts it to the currently defined units.

305 Import @] Figure 3-7: The 3DS Import dialog box enables
et you to merge objects into or completely replace
& Merge objects with curent scene. the current scene.

" Completely 1eplace curent sceng.
V¥ Convert units

Cancel

If any of the object names in the imported scene match those in the current scene, an Import
Name Conflict dialog box opens, allowing you to rename the imported objects, or you can
Skip or Cancel the import.

::\Iew \ The ability to import VIZ Material XML files is new to 3ds max 6.
eature

Max can import several different formats, including the following:
4+ 3D Studio Mesh, Projects, and Shapes (3DS, PRJ, SHP)
4+ Adobe Illustrator (Al
4+ AutoCAD (DWG, DXF)
4+ FILMBOX (FBX)
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4 Initial Graphics Exchange Standard (IGE, IGS, IGES)
4 Lightscape (LS, VW, LP)

4 StereoLithography (STL)

4+ VRML (WRL, WRZ)

4 VIZ Material XML Import (XML)

In addition to importing, you’ll sometimes want to export Max objects for use in other pro-
grams. You access the Export command by choosing File &> Export. You also have the option
to Export Selected (available only if an object is selected).

\ The ability to export to the Shockwave 3D Scene (W3D) is new to 3ds max 6.

Max can export to several different formats, including the following:
4+ 3D Studio (3DS)
4 Adobe Illlustrator (Al
4 ASCII Scene Export (ASE)

4+ Lightscape Material, Blocks, Parameters, Layers, Preparations, and Views (ATR, BLK,
DF, LAY, LP, VW)

4+ AutoCAD (DWG, DXF)

4+ FILMBOX (FBX)

4 Initial Graphics Exchange Standard (IGS)
4 StereoLithography (STL)

4+ Shockwave 3D Scene Export (W3D)

4+ VRML (WRL)

Import preference

The File panel of the Preference Settings dialog box has a single option dealing with importing—
Zoom Extents on Import. When this option is enabled, it automatically zooms all viewports to
the extent of the imported objects. Imported objects can often be scaled so small that they
aren’t even visible. This option helps you to locate an object when imported.

Importing and exporting 3D Studio files (3DS, PRJ, SHP)

It shouldn’t be a surprise that Max can import 3D Studio (3DS) files without much headache —
after all, 3D Studio was the predecessor to Max.

Everything in a 3DS file is imported into Max except for Morph Keys, Keyframer Instances,
.CUB cubic maps, and decal transparency defined by the upper-left pixel. Imported SHP files
convert 2D polygons created with 3D Studio’s Shaper tool into Bézier splines. The shapes
can be imported as a single object or as multiple objects. PRI files are simply 3DS files that
include shapes. Or, you can select to not import shapes.
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Max used to ask whether you want to set the animation length of the current scene to match

o the animation length in the 3DS file, but it now automatically creates a keyframe for every

frame. You may want to use the Reduce Keys function in the Track View to simplify the ani-
mation keys after importing.

Max can export only to the 3DS format, not to the PRJ and SHP formats. After you select
Export, the Export Scene to .3DS File dialog box appears with only one option —to Preserve
Max’s Texture Coordinates. When you are exporting to the 3DS format, all mesh characteris-
tics are exported except for any composite or procedural maps, UV mapping coordinates, any
transformations applied to a group, and global shadow parameters.

Any objects that aren’t represented by meshes, such as NURBS and procedural primitives, are
converted to meshes.

Importing and exporting lllustrator files (Al)

You can import files created using Adobe Illustrator into Max. After you have selected an
Illustrator file, the Al Import dialog box offers the same options of merging the objects into
the current scene or replacing the current scene. Next, the Shape Import dialog box appears
with options to import the shapes as a single object or as multiple objects. During the import
process, the 2D polygons are all converted to Bézier curves. Max can import only curves

and paths from Illustrator. All effects such as fills, gradients, and filter effects are lost in the
translation.

Max cannot import text created in lllustrator unless it has been converted to outlines.
-',,.l-’

Only shapes and splines can be exported to the Al format. If you try to export a Max file that
doesn’t include any shapes, you get a warning message, “No Data to export.” If you export a
scene that includes shapes, the shapes are exported and all other objects are ignored. 3D
splines can be exported, but their z-axis values are dropped.

Caution Helix shapes cannot be exported from Max unless they have converted to Editable Spline

New

objects.

Importing and exporting AutoCAD files (DWG, DXF)

AutoCAD is a sister product to Max, aimed at the computer-aided design market. It was pro-
duced by the same parent company, so it interacts very well with Max. AutoCAD uses two
main formats: DWG (which stands for Drawing files) and the older DXF (which stands for
Drawing Exchange Format).

Objects in AutoCAD are named differently from Max objects. For example, AutoCAD includes
a 3D Face object, a Polyline Mesh object, a Polyface Mesh object, and an ACIS object. During
the import process, all these objects are converted to corresponding mesh objects in Max,
because Max doesn’t distinguish among these types.

\ The AutoCAD DWG/DXF Import Options and export dialog boxes have been changed in

Feature 3ds max 6.

99
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The AutoCAD DWG/DXF Import Options dialog box, shown in Figure 3-8, includes many
options that help define the translation process. The dialog box is split into three panels —
Geometry, Layers, and Spline Rendering. The Geometry panel includes options defining how
to handle 3D objects and surfaces; the Layers panel lists all the various layers and their prop-
erties; and the Spline Rendering panel includes options defining how to handle imported
splines.

AutoCAD DWG/DXF Import Options [ZJEJ| [ Export to AutoCAD File
CA3dsmaxBhscenesidugtest DWE Export version: |AutoCAD 2004 D'Wia x
Geometry | Lapers | Spline Rendering | & Entire Scene ¢ Selected Dbjects

—Soak
= Geometry Optiors

todel size:  [Drawing extents not known) o R T

¥ Rescale Incaming file units; | Inches i fw Skip Hidden Objects

¥ Ignore Extrude Capping

i Geometry Option:
[V Combine Objects by Layer
[ iwield Weld thieshold: [TT_ | 2] Help oK Cancel
& éu{_D'smUUth SLFEL |15'D J = ﬁurt\ons'de\)‘el'ubed b"y Animeti: Technologies
| Uniify nommals ‘exclusively For Discreet, & division of Autodesk, Inc.

[~ LCap closed ohiects

Curve steps |1D ﬂ
Surface deviation for 30 solids: |1 1] g

rInclud
[V Extemal references [wets) I Lights
™ Hatches I™ Views [cameras]
[ Paints I~ UCSs [grids)

Cancel

Figure 3-8: The AutoCAD DWG/DXF import and export dialog boxes
include many options.

Exporting to the DXF format opens the Export to AutoCAD File dialog box, which includes
options to save the scene using the AutoCAD 2004 or AutoCAD 2000 formats.

Importing and exporting FilmBox files (FBX)

Another common 3D format was created by a company named Kaydara for its FilmBox prod-
uct. FilmBox is used to work with motion capture data. Files saved in this format have the .fbx
extension.

The Import FBX File dialog box, shown in Figure 3-9, lets you import any animation sequences
listed in the top list box. These animation sequences can be merged, exclusive merged, or
added to a new scene. You can also specify to import a Bones, Geometries, Cameras, Lights,
Markers, Shapes, Animations, and Human IK. You also have the options to Rescale scene root
nodes to unit size and rotate the root nodes with Y-up to Z-up.

Both Softimage and Maya support the FilmBox file format, so this format can be used to
. move scenes between these systems.
s
The export options include the same set of objects with the addition of Skin objects. You can
also set the Resampling rate and enable options to Show Warnings and to embed textures.
The Export FBX File dialog box is also shown in Figure 3-9.
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Figure 3-9: The Import and Export FBX File dialog boxes allow you to
import and export animation sequences.

Importing and exporting IGES files (IGES)

IGES stands for Initial Graphics Exchange Standard. The IGES format supports NURBS and
provides a standard way to import and export NURBS objects. With IGES import and export
features, Max files can share objects with packages such as Mechanical Desktop, Maya,
Pro/ENGINEER, Softlmage, and CATIA, among others.

When you import an IGES file, the only dialog box to appear is the Merge/Replace dialog box
shown in earlier sections.

In the IGES format, all entities have an entity number and name. The Max Online Reference
includes a table that correlates the conversion of the various IGES entities to Max objects. For
example, an IGES element labeled 100 is a Circular Arc that is converted to a Max Arc Shape.

IGES conversion can be tricky, so a log file of the process is saved with the XLI extension.
An IGES file with several meshes is converted to a single NURBS surface in Max with each
original mesh being a separate subobject surface. To work with these subobject surfaces,
you need to make them independent from the NURBS object.

| Referen

—

- Cross- \ Chapter 16, “Working with NURBS,” covers NURBS in more detail.
ce

Exporting objects to the IGES format presents a single simple dialog box with options to

Export Hidden Objects and to Export Selected Objects Only.

101
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Importing and exporting Lightscape files

Lightscape is an architectural rendering system that can generate scenes with an advanced
lighting method known as radiosity. Radiosity simulates real lighting effects by taking into
account how light bounces off objects.

Many of the features from the Lightscape product have been included in Max. You can find
c8 information on these features in Chapter 29, “Advanced Lighting and Radiosity."

—

Files saved in Lightscape with the .LS, .VW, or .LP extensions can be imported into Max.
These represent older Lightscape files, Lightscape Views, and Lightscape Preparation files.
Importing a Lightscape Preparation file opens the dialog box shown in Figure 3-10. This dialog
box lets you group entities by layers, materials, or materials within layers. You can also select
to skip any layers that are off and replace the current scene.

Import Lightscape Preparation Figure 3-10: The |mP0|’t Lightscape Preparation dlalog
EntiyGrouping ———————— | box can specify how entity grouping is derived.

™ Derive from Layers

® Derive from Materials

€ Derive from Material within Layer

[~ Skip Lapers that are Off
™ Replace cument scene

Impart | Cancel ‘ Help |

Exporting Lightscape files offers many more options. Max files can be exported to Lightscape
as Lightscape Materials (ATR), Blocks (BLK), Parameters (DF), Layers (LAY), Preparation
(LP), and Views (VW). Each of these formats has its own unique export options.

The Lightscape format with the most options is the Preparation files. The other Lightscape
formats have many of the same options. Figure 3-11 shows two panels (General and Lights)
on the Export Lightscape Preparation File dialog box.

Export Lightscape Preparation File Export Lightscape Preparation File
General | Lights | Animation | Daplight | Windouws | General | Lights | Arimation | Dayight | Windows |
Master Units:~ [Inches =] ¢* Enliie Soene - Standard Ligh
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e R
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Block Creatiors |Broup =] Name: [sphere € Ayerage Taiget Distarce i
Layer Creatiors |Instance = | Name: [sphere [V UssAttenuation ¥ Preserve Spotiight Angles
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e  Trangles ’7l7 Relative Photometric \Web Paths ‘
0.0195851 ® L (e - Luminaire a
@ Any Quads I~ Average Map Color for Projectars
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Figure 3-11: The Export Lightscape Preparation File dialog
box includes multiple panels of options.
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Importing and exporting StereoLithography files (STL)

StereoLithography is a file format used by various manufacturing machines for rapid proto-
typing of products. Importing an STL file opens the Import STL File dialog box, shown in

Figure 3-12. Available options include Weld Vertices (including a Quick Weld feature), which
you use to combine vertices closer than the Weld Threshold value; Auto-Smooth, which defines
whether adjacent polygon faces should be smoothed; Unify Normals, which causes all normals
to point the same direction; and Remove Double Faces, which simplifies the geometry.

Import STL File Figure 3-12: The Import STL File dialog box enables
rNsme———————————| you to name the STL file and set other options.
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v Urify Nomals

Copyright 1996 ok
CEBAS Computer
Giermany Cancel

The Export STL File dialog box offers options for choosing whether to export the STL file as
a Binary or ASCII file. Be aware that StereoLithography objects must be closed surfaces. Max
includes the STL-Check modifier that verifies this. Using this modifier can save you some
headaches when exporting.

- Cross- You can learn about modifiers such as the STL-Check modifier in Chapter 11, “Introducing
| Reference Modifiers for Basic Object Deformation.”

Importing and exporting VRML files (WRL, WRZ)

VRML stands for Virtual Reality Modeling Language and, like HTML, defines scenes that can
be interpreted by VRML browsers embedded within a Web browser. Max can import VRML
files with .WRL and .WRZ (which are compressed VRML files) file extensions, but can export
only to the VRMLI7 standard with the .WRL extension.

Importing VRML files

The VRML Import dialog box includes options to Reset Scene, Turn to 3DS Coordinates, and
Create Primitives. The Reset Scene option deletes the existing scene. Once deselected, the
imported file merges into the current scene. The Turn to 3DS Coordinates option switches the
Y and Z coordinates. In VRML scenes, the Y-axis points up, but in Max the Z-axis points up.
The Create Primitives option converts VRML primitives to their Max equivalents.
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Exporting VRML97

VRML97 is the only VRML format to which Max can export. The VRML97 Exporter dialog box,
shown in Figure 3-13, includes many options, including generating Normals, Primitives, Color
per Vertex, Coordinate Interpolators, and a Flip-Book.

VRMLYY Exporter ZJEd] [Animation Sample Rates
Generate P
TIE li
™ Nomals I™ Coordinate Interpolatars Ll IU.E[S.
¥ Indentation I~ Export Hidden Dbiscts ¢ Once per Animation Frame
I¥ Primitives I~ Fip-Back ® Custom  FPS: [0 2|

I™ Color per Vertex
r~ Coordinate Interpolators:

Folygans Type: Iriafgies ]' " Dnce per Animation Frame

Iritial Vigw: > @ Custom  FPS: 3 =

Initial M avigation Info; x.
i Flip-Book

Initial Backaground X

" One File per dnimation Frame

Initial Fog: o ® Custom FPS: [0 2
Digits of Precisior: 4 T
Caneel

i Show Progress Bar

Yertax Color Source
’7 & Lze Man's € Caleulate an Export ‘

Bitmap URL Prefi
’]7 Uz Prefix J /maps ‘

Sample Rates .. ‘ ‘wharld Info . |

Ok Cancel

Figure 3-13: The VRML97 Exporter dialog box includes options
set by the VRML97 Helper. The Animation Sample Rates dialog
box lets you define the frames per second.

The Initial View drop-down list lets you select a camera to display when the file first loads
into a browser. Many VRML browsers support multiple viewpoints. Each camera in the scene
becomes a different viewpoint when the VRML file is viewed in a browser. You can select
Export Hidden Objects, but by default they are not exported. The Show Progress Bar displays
a progress bar as the file is being exported, which is useful if you are trying to export a com-
plex scene.

The Normals option aids the browser in rendering smooth objects. The Indentation option
aligns the actual code to make it more readable in a text editor.

Primitives supported by the VRML browser are much more efficient than polygonal meshes.
The Primitives option converts objects to primitive objects when possible.

The Color per Vertex option exports any vertex colors that are defined in the scene. You can
also select Use Max’s Settings or Calculate on Export, which calculates vertex colors based
on scene lighting. The Digits of Precision value can also be defined.

By default, all texture maps must reside in the same directory as the .WRL file. The Use Prefix
option lets you define a subdirectory for holding any texture maps.

The Coordinate Interpolators option exports animation effects caused by Modifiers and
Space Warps. The Flip-Book option exports VRML scenes as multiple files. Clicking the
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Sample Rates button opens the Animation Sample Rates dialog box, also shown in Figure 3-13,
which enables you to specify custom frame rates for the Flip-Book, for the Transform
Controllers, and for the Coordinate Interpolators.

/ Note Exporting animation effects using the Coordinate Interpolators can produce huge VRML files.
‘,,.l-’

The Polygons Type section of the VRMLI97 Exporter dialog box lets you specify how individ-
ual faces are exported. Options include Ngons, Quads, Triangles, and Visible Edges. The
Initial View drop-down list is still available, and below it are drop-down lists for Initial
Navigation Info, Initial Background, and Initial Fog. All three are set by the VRML97 helper
and are found as subcategories under the Helpers category in the Create panel.

The World Info button opens the World Info dialog box, in which you can give the VRML file a
Title and file description.

The VRML97 Helper objects

To aid in the creation of VRML worlds, Max includes several additional helper objects. The
VRMLI7 helper objects provide a way to add features such as anchors and sensors to scene
objects in preparation for exporting a scene to the VRML97 format. You can find these tools
as a subcategory under the Helpers category in the Create panel and also in the Create =
Helpers => VRMLI97 menu.

The VRML97 subcategory from the Helper category in the Create panel includes buttons

for the following VRMLI7 features: Anchor, TouchSensor, ProxSensor, TimeSensor, Navinfo,
Background, Fog, AudioClip, Sound, Billboard, LOD, and Inline, shown in Figure 3-14. Each of
these buttons opens a rollout containing its parameters. Many of these features are beyond the
scope of this book but are covered in detail in the many VRML references that are available.

c dPanel ]| Figure 3-14: Use the VRML97 Helper objects
w|#| @@ T || to define export options for VRML files.

0y &lu ¥ %
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Pick Trigger Dbject

Trigger Object: Sphere01

The Anchor rollout lets you pick a Trigger object that hyperlinks the user to a separate
URL. The TouchSensor rollout lets you select objects to animate when a Trigger object is
touched. The ProxSensor rollout lets you set a trigger when a user gets within a certain
defined proximity to an object. The TimeSensor rollout sets regular time intervals.
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The Navlinfo rollout tells the VRML Browser how the user can navigate about the VRML
Scene. The Background rollout specifies the sky and ground colors and any images to use
for the background. The Fog rollout lets you define how fog appears in the scene.

The AudioClip rollout is used in conjunction with the Sound rollout. The Sound rollout
defines the sound characteristics, and the AudioClip rollout specifies where the sound clips
are located. The Billboard rollout creates images that always face the user.

LOD stands for Level of Detail. This button opens a rollout containing a Pick Object button, a
Distance value, and a list of objects. To add an object to the list, click the Pick Object button
and then specify a Distance value for that object. When the VRML Browser gets closer than
the specified distance, the object appears. You can use this procedure to display both a
scaled-down version of an object when far away and a more detailed version up close.

The Inline button opens a rollout where you can add a Web URL link to the selected object.
VRML browsers recognize this link when the object is clicked on.

Exporting ASCII scene files (ASC, ASE)

To see all the gritty detail of a Max file, try exporting the file as an ASCII Scene file. The ASCII
Export dialog box, shown in Figure 3-15, includes Output Options and Mesh Options. With
this dialog box, you can also select which object types to export and specify an individual
frame to export.

ASCIl Export
r— Output Dption; — Object Typ: 7
¥ Mesh Definition IV Geometric
¥ Materials ¥ Shapes Cancel
¥ Transform Animation Keys ¥ Cameras Static Output
I Animated Mesh ¥ Lights Framed [0 3]
I Animated CamerarLight $ettings ¥ Helpers Precision
I Inverse Kinematics Joints ’7 Decimals: [§ 3]
~Mesh Options——————— —Controller Dutput
I Mesh Nomals Frames per S ample:
I™ Mapping Coordinates ® UssKeys Cantrollers: IE_ ﬂ
[ Pensy olors ¢ ForceSample  Animated Objects: [5 3]

Figure 3-15: The ASCII Export dialog box exports the Max
scene to a file that a text editor can read.

Exporting to the Shockwave 3D (W3D) format

Shockwave 3D is an interactive format used by Macromedia’s Director software. The exporter
includes an Analysis tool and a Preview window. To export a Max scene to the Shockwave 3D
format, select File Export or File > Export Selected and select the Shockwave 3D format as
the File Type in the file dialog box.

After giving the file a name and clicking OK, the Shockwave 3D Scene Export Options dialog
box opens, as shown in Figure 3-16. This dialog box includes several options that you can
include in the export file. You can also select a camera to use or choose to use the Active
Viewport. The Compression Settings for Geometry, Texture, and Animation can be set to dif-
ferent quality settings between 0 and 100, and you can choose to limit the texture size.
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Figure 3-16: The Shockwave 3D Scene Export
Options dialog box lets you choose which
resources to export.

The Shockwave 3D Export Options dialog box includes buttons that enable you to check the
objects for any geometry abnormalities that will cause problems within a Shockwave viewer.
After clicking the Author Check button, all geometries are checked, and another dialog box
listing potential problems opens. Possible problems include the following:

4 Geometries with holes

4 Isolated vertices

4+ Unsupported textures

4+ Use of any Shaders other than Blinn

4 Unsupported modifier and controller animations

The Analyze button opens the Shockwave 3D File Analysis dialog box, shown in Figure 3-17.
This dialog box shows a pie chart of the size of the various objects used in the scene.

The Preview button opens a Preview window, shown in Figure 3-18, where you can view the
exported Shockwave 3D file. You can navigate about the Preview window by clicking and
dragging with the left mouse button. Holding down the Shift key while dragging spins the
viewpoint about its axis. Holding down the Ctrl key while dragging zooms in and out of the
view, and dragging with the spacebar held down pans the view. Pressing the Shift key and the
spacebar together constrains the panning motion to either horizontal or vertical.
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Figure 3-17: The Shockwave 3D File Analysis dialog box shows
the size of your scene’s objects.

"1 Shockwave 30 Export Preview 1)

Figure 3-18: The Shockwave 3D Export Preview window lets you
see what the exported Shockwave file will look like before exporting.

Exporting utilities

In addition to the menu commands found in the File menu, Max includes a couple of utilities
that export specific information: the Lighting Data Export Utility and the Material XML
Exporter Utility. You can access these utilities from the Utilities panel by clicking on the
More button and selecting them from the pop-up list that appears.
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::\lew \ The Lighting Data Export and Material XML Exporter are new to 3ds max 6.
eature
Lighting Data Export utility
The Lighting Data Export utility exports exposure control data for a scene’s llluminance and
Luminance values. These files can be saved as PIC or TIF files, which you can select in the 2D
Lighting Data Exporter rollout. You also can set an image’s Width and Height dimensions.
Caution Exposure Control must be enabled for this utility to be enabled. You can learn about expo-

/ Note

sure control in Chapter 41, “Rendering Basics.”

Material XML Exporter utility

The Material XML Exporter utility exports a selected material to an XML file format, where it
can be easily shared with other users. After you select this utility, the Parameters rollout
offers four options for selecting the material to export: the Material/Map Browser, the Object
List, Pick Object in Scene, and All Objects in Scene.

The utility also offers several export options including Native XML, export to an Autodesk
Tool Catalog, and using an XSLT template. You also can select to export the material with a
thumbnail and along with its mapping modifiers.

Importing from external applications

Even if Max could import several times the current number of import formats, new formats
are being created for new products all the time, many of which Max wouldn’t support. This
situation does not mean that Max cannot use objects created in these new products. The
trick is to find a common format that both products support.

Tutorial: Importing vector drawings from lllustrator

In most companies, a professional creative team uses an advanced vector drawing tool such
as Illustrator to design the company logo. If you need to work with such a logo, learning how
to import the externally created file gives you a jumpstart on your project.

When importing vector-based files into Max, only the lines are imported. Max cannot import
o fills, blends, or other specialized vector effects. All imported lines are automatically converted
to Bézier splines in Max.

Although Max can draw and work with splines, this feature takes a backseat to the vector
functions available in Adobe Illustrator. If you have an Illustrator (Al file, you can import it
directly into Max.

To import Adobe Illustrator files into Max, follow these steps:
1. Within Illustrator, save your file as an Al file by choosing File => Save As.

Figure 3-19 shows a logo created using Illustrator.

109
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Figure 3-19: A company logo created in lllustrator and ready to save and import into Max

. Open Max, and choose File => Import.

A file dialog box opens.

. Select Adobe Illustrator (Al) as the File Type. Locate the file to import, and click OK.

The Al Import dialog box asks whether you want to merge the objects with the current
scene or replace the current scene.

4. For our purposes, select the replace the current scene option and click OK.

5. The Shape Import dialog box asks whether you want to import the shapes as single or

multiple objects. Select multiple, and click OK.

Figure 3-20 shows the logo after it has been imported into Max. Notice that all the fills are
missing.

Spline objects that are imported from Illustrator appear in Max as Editable Spline objects.
You can learn more about Editable Splines in Chapter 13, “Drawing and Editing 2D Splines
and Shapes.”
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Figure 3-20: A company logo created in lllustrator and imported into Max
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Importing human figures from Poser

Many animation projects require human figures. Modeling a human figure from scratch can
require the same patience and artistic skill that Michelangelo exercised when painting the
ceiling of the Sistine Chapel. Luckily (for those of us facing deadlines), this level of commit-
ment isn’t necessary. Curious Labs offers a tool devoted to modeling the human body. It is
named Poser, and the current version is 5. Its features include posing and animating lifelike
characters. Importing Poser models into Max can save you from some major modeling
headaches.

With Poser, you can choose from a variety of male and female human figures, both unclothed
and clothed in all sorts of attire. Even animal models are available. You can easily position
these figures to any pose. Figure 3-21 shows a model posed as if offering a handshake.

Poser can animate characters. To change the pose, simply click and drag a body part to its
desired location. Poser also includes modules for controlling basic facial expressions and
hand gestures.
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Figure 3-21: Poser by Curious Labs is an excellent tool for working with human figures.

Tutorial: Using Poser models in Max

Poser makes modeling and positioning human figures easy, but to get the figures into Max,
you need to export them from Poser and import them into Max. Poser can export several for-
mats, but only two coincide with Max: 3DS and DXF.

To use Poser models in Max, follow these steps:
1. Position your figure in Poser, and export it by choosing Poser’s File > Export command.
2. In the Export dialog box, select the 3DS file type and save the file.
3. In Max, import the file by choosing File ©> Import.
4. Select the Completely Replace Current Scene and Convert Units options, and click OK.
The figure appears in the viewports.
5. Save the scene as a Max file by choosing File > Save.

Figure 3-22 shows the imported figure.
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Figure 3-22: A Poser model imported into Max using the 3DS format

Referencing External Objects

No man is an island, and if Discreet has its way, no Max user will be an island either. XRefs
(which stands for eXternal Reference) make it easy for creative teams to collaborate on a
project without having to wait for one or another group member to finish his or her respec-
tive production task. External references are objects and scenes contained in separate Max
files and made available for reference during a Max session. This arrangement enables
several artists on a team to work on separate sections of a project without interfering with
one another or altering each other’s work.

Max includes two different types of XRefs: XRef Scenes and XRef Objects.

Using XRef Scenes

An externally referenced scene is one that appears in the current Max session, but that is
not accessible for editing or changing. The scene can be positioned and transformed when

linked to a parent object and can be set to update automatically as changes are made to the
source file.
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As an example of how XRef Scenes facilitate a project, let’s say that a design team is in the
midst of creating an environment for a project while the animator is animating a character
model. The animator can access the in-production environment as an XRef Scene in order to
help him move the character correctly about the environment. The design team members are
happy because the animator didn’t modify any of their lights, terrain models, maps, and
props. The animator is happy because he won’t have to wait for the design team members to
finish all their tweaking before he can get started. The end result is one large, happy produc-

tion team (if they can meet their deadlines).

Choose File > XRef Scenes to open the XRef Scenes dialog box (shown in Figure 3-23), which

you use to load XRef Scenes into a file.

XRef Scene options

In the XRef Scenes dialog box are several options for controlling the appearance of the scene
objects, how often the scene is updated, and to which object the scene is bound. This dialog
box is modeless, and you can open and change the options in this dialog box at any time.

The pane on the left lists all XRef Scenes in the current scene. To the right are the settings,
which can be different for each XRef Scene in the list. To view or apply a setting, you first
need to select the scene from the list. You can remove any scene by selecting it from the list

and clicking the Remove button.

XRef Scenes B[]
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Figure 3-23: The XRef Scenes dialog box lets
you specify which scenes to load as external
references.
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Caution If an XRef Scene in the list is displayed in red, then the scene could not be loaded. If the
path or name is incorrect, you can change it in the Path field at the bottom of the list.

The Convert Selected button converts any selected objects in the current scene to XRef
objects by saving them as a separate file. This button opens a dialog box to let you name and
save the new file. If no objects are selected in the current scene, then this option is disabled.

Use the Enabled option to enable or disable all XRef Scenes. Disabled scenes are displayed in
gray. The Merge button lets you insert the current XRef Scene into the current scene. This
button removes the scene from the list and acts the same way as the File ©> Merge command.

Updating an external scene

Automatic is a key option that can set any XRef Scene to be automatically updated. Enable
this option by selecting a scene from the list and checking the Automatic option box; there-
after, the scene is updated anytime the source file is updated. This option can slow the sys-
tem if the external scene is updated frequently, but the benefit is that you can work with the
latest update.

The Update Now button is for manually updating the XRef Scene. Click this button to update
the external scene to the latest saved version.

External scene appearance

Other options let you decide how the scene is displayed in the viewports. You can choose to
make the external scene invisible or to display it as a box. Making an external scene invisible
only removes it from the viewports, but the scene is still included in the rendered output. To
remove a scene from the rendered output, deselect the Enabled option.

The Ignore section lists objects such as lights, cameras, shapes, helpers, and animation;
selecting them causes them to be ignored and to have no effect in the scene. If an external
scene’s animation is ignored, then the scene appears as it does in frame 0.

Positioning an external scene

Positioning an external scene is accomplished by binding the scene to an object in the cur-
rent scene (a dummy object, for example). The XRef Scenes dialog box is modeless, so you
can select the object to bind to without closing the dialog box. After a binding object is
selected, the external scene transforms to the binding object’s pivot point. The name of the
parent object is also displayed in the XRef Scene dialog box.

Transforming the object to which the scene is bound can control how the external scene is
repositioned. To unbind an object, click the Unbind button in the XRef Scenes dialog box.
Unbound scenes are positioned at the World origin for the current scene.

Working with XRef Scenes

You can'’t edit XRef Scenes in the current scene. Their objects are not visible in the Select by
Name dialog box or in the Track and Schematic Views. You also cannot access the Modifier
Stack of external scenes’ objects. However, you can make use of external scene objects in other
ways. For example, you can change a viewport to show the view from any camera or light in the
external scene. External scene objects are included in the Summary Info dialog box.
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Tip

Another way to use XRef Scenes is to create a scene with lights and/or cameras positioned
at regular intervals around the scene. You can then use the XRef Scenes dialog box to turn
these lights on and off or to select from a number of different views without creating new
cameras.

You can also nest XRef Scenes within each other, so you can have one XRef Scene for the dis-
tant mountains that includes another XRef for a castle.

/-

—

If a Max file is loaded with XRef files that cannot be located, a warning dialog box appears,
enabling you to browse to the file’s new location. If you click OK or Cancel, the scene still
loads, but the external scenes are missing.

Tutorial: Adding an XRef Scene

As an example of a project that would benefit from XRefs, I've created a maze environment.

[ open a new Max file and animate a diamond moving through this maze that is opened as an
XRef Scene.

To set up an XRef Scene, follow these steps:

1

Tip

7.

. Create a new Max file by choosing File > New.
2.
3.

Choose File => XRef Scenes to open the XRef Scenes dialog box.

Click the Add button, locate the Maze.max file from the Chap 03 directory on the
CD-ROM, and click Open to add it to the XRef Scene dialog box list.

You can add several XRef Scenes by clicking the Add button again. You can also add a scene
to the XRef Scene dialog box by dragging a .max file from Windows Explorer or from the
Asset Manager window.

. Select Create > Helpers = Dummy, and drag in the Perspective viewport to create a new

Dummy object.

. In the XRef Scenes dialog box, click the Bind button and select the dummy object.

This enables you to reposition the XRef Scene as needed.

. Select the Automatic update option, and then click the Close button to exit the XRef

Scene dialog box.

Now animate objects moving through the maze.

Figure 3-24 shows the Maze.max scene included in the current Max file as an XRef.

Tip

e )

With the diamond animated, you can replace it at a later time with a detailed model of a
mouse using the File => Replace command.
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Figure 3-24: The maze.max file loaded into the current file as an XRef Scene

Using XRef Objects

XRef Objects are slightly different from XRef Scenes. They are objects that appear in a scene
and can be transformed and animated, but the original object’s structure and Modifier Stack

cannot be changed.

An innovative way to use this feature would be to create a library of objects that you could
load on the fly as needed. For example, if you had a furniture library, you could load several
different styles until you got just the look you wanted.

You can also use XRef Objects to load low-resolution proxies of complex models in order to
lighten the system load during a Max session. This method increases the viewport refresh rate.

Many of the options in the XRef Objects dialog box, shown in Figure 3-25, are the same as in

the XRef Scenes dialog box.
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Figure 3-25: The XRef Objects dialog box lets you
choose which files to look in for external objects.

The left side of the XRef Objects dialog box is divided into two sections. The top section dis-
plays the externally referenced files, and the lower section displays the objects selected from
that file. A file needs to be selected in order for you to see its objects.

You have several options for controlling how the XRef Objects are displayed:

4+ Use Proxy: Lets you choose between displaying the proxy and displaying the actual
object.

4+ Render Proxy: Forces the proxy object to be rendered instead of the actual referenced
object. If this option is not selected, then the referenced object is rendered regardless
of the object displayed in the viewports.

4+ Update Materials: Enables the object’s materials to update as the source gets updated.
4 Ignore Animation: Turns off any Modifier Stack animations associated with the object.

The Convert Selected button works the same as in the XRef Scenes dialog box. It enables you
to save the selected objects in the current scene to a separate file just like the File > Save
Selected command.

In the XRef Objects dialog box, you can choose to automatically update the external refer-
enced objects or use the Update Now button. You can also Enable and Disable all objects
in a file.
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The Select In Scene and Select From Scene buttons are useful for seeing which objects in the
scene are related to which items in the XRef Objects dialog box list.

Using proxies

The Add as Proxy button opens a low-resolution proxy object in place of a more complex
object. This feature saves memory by not requiring the more complex object to be kept in
memory. You can also select to render the proxy, update its materials, or ignore its animation.

If an object in the lower section of the XRefs Objects dialog box is selected, then the Add
button changes to a Set button. The Set button lets you choose a file and object to use as a
proxy. The proxy is displayed in place of the actual referenced object.

The real benefit of using proxies is to replace complex referenced objects with simpler
.,_ objects that update quickly. When creating a complex object, remember to also create a low-
4 resolution version to use as a proxy.

Tutorial: Using an XRef proxy
To set up an XRef proxy, follow these steps:
1. Open the Post box with XRef tree.max file from the Chap 03 directory on the CD-ROM.
This file includes the post box model produced by Zygote Media.
2. Open the XRef Objects dialog box by choosing File => XRef Objects.

3. Click the Add button, and locate the Park bench under a tree.max file from the Chap 03
directory on the CD-ROM.

This file includes the old tree and park bench models made by Zygote Media. The XRef
Merge dialog box, shown in Figure 3-26, automatically opens and displays a list of all
the objects in the file just added.

XRef Merge - Park bench under a ree.max [B2]%]

Sort

! @ Alphabetical
. o
TREE € By Calor

i List tupes

v Geomstry Al
¥ Shapes None
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v Space Waips

< i | (2] IV Groups/dssemblies
- ¥ Bone Objects

All ‘ Hone | Irveert ‘

¥ Display Subliee I Case Sensitive oK Cancel

[ Select Subties

Figure 3-26: The XRef Merge dialog box lets you choose
specific objects from a scene.
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4. Select the Tree object to add to the current scene, and click OK. (Hold down the Ctrl
key to select several objects.) Use the Filter and Sort options to locate specific objects.

_/Note If an object you've selected has the same name as an object that is currently in the scene, the
- Duplicate Name dialog box appears to let you rename the object, merge it anyway, skip the
new object, or delete the old version.

5. Select the Tree object in the lower pane, and click the Set button with the Set Proxy
option selected.
The Open File dialog box appears.

6. Select the Tree Lo-Res.max file from the Chap 03 directory on the CD-ROM.
The Merge dialog box opens.

7. Select the Cylinder01 object, and click OK.

Caution If the proxy object has a different offset than the original object, a warning dialog box
appears instructing you to use the Reset XForm utility to reset the transform of the objects.

8. With the Tree object selected in the lower pane, select the Use Proxy option to see the
proxy object, and deselect it to see the actual object.

XRef Objects that you add to a scene instantly appear in the current scene as you add them.
Figure 3-27 shows the Post Box with the actual tree object. The XRef Objects dialog box lets
you switch to the proxy object at any time.

XRef Objects in the Modifier Stack

XRef Objects appear and act like any other object in the scene. About the only difference
you’ll see will be if you open the Modifier Stack. The Stack displays “XRef Object” as its only
entry.

When you select the XRef Object item in the Modifier Stack, a rollout, shown in Figure 3-28,
appears. The rollout includes many of the same controls displayed in the XRef Objects dialog
box discussed earlier. These controls include the XRef File Name, Object Name, Proxy File
Name, and Proxy Object Name.

Configuring XRef paths

The Configure Paths dialog box includes an XRefs tab for setting the paths for XRef Scenes
and Objects, shown in Figure 3-29. Choose Customize => Configure Paths to open the XRefs
panel.
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Figure 3-29: The XRefs panel in the Configure Paths
dialog box lets you specify paths to be searched when
an XRef cannot be located.

Max keeps track of the path of any XRefs used in a scene, but if it cannot find them, it looks at
the paths designated in the XRefs panel of the Configure Paths dialog box. For projects that
use lots of XRefs, populating this list with potential paths is a good idea. Paths are scanned in
the order they are listed, so place the most likely paths at the top of the list.

To add a new path to the panel, click the Add button. You can also modify or delete paths in
this panel with the Modify and Delete buttons.

Using the File Utilities

With all these various files floating around, Max has included several utilities that make it eas-
ier to work with them. The Utilities panel of the Command Panel includes several useful utili-
ties for working with files. You can access these utilities by opening the Utilities panel and
clicking the More button to see a list of available utilities.

Using the Asset Browser utility

The Asset Browser utility is the first default button in the Utility panel. Clicking this button
opens the Asset Browser window. The Asset Browser resembles Windows Explorer, except
that it displays thumbnail images of all the supported formats contained within the current
directory. Using this window, shown in Figure 3-30, you can browse through directory files

and see thumbnails of images and scenes.

The supported file types include AVI, BMP, CIN, CEL, GIF, IFL, IPP, JPEG, PNG, PSD, MOV, RGB,
RLA, RPF, VST, TIF, and YUV. These types are the same ones that the File => View File command
can open. All files with these extensions are viewable within the Asset Browser. You can select
to view only a certain type of file using the Filter menu.
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Figure 3-30: The Asset Browser window displays thumbnails of the
files in the current directory.

Open and display the Asset Manager within a viewport by right-clicking the viewport title and
.. choosing Views > Extended => Asset Manager from the pop-up menu.
v
You can also drag and drop files from the Asset Browser window to Max. Drag a scene file and
drop it on Max’s title bar to open the scene file within Max. You can drop image files onto the
map buttons in the Material Editor window or drop an image file onto a viewport to make a
dialog box appear, which lets you apply the image as an Environment Map or as a Viewport

Background, respectively.

The Asset Browser window is modeless, so you can work with the Max interface while the
Asset Browser window is open. Double-clicking an image opens it full size in the Rendered
Frame Window.

The Asset Browser can also act as a Web browser to look at content online. When the Asset
Browser first opens, a dialog box reminds you that online content may be copyrighted and
cannot be used without consent from the owner.

The Display menu includes three panes that you can select. The Thumbnail pane shows the
files as thumbnails. You can change the size of these thumbnails using the Thumbnails menu.
The Explorer pane displays the files as icons the same as you would see in Windows Explorer.
The Web pane displays the Web page for the site listed in the Address field.

To view Web sites, you need to be connected to the Internet. The Asset Browser can remem-
ber your favorite Web sites using the Favorites menu. The Asset Browser window also
includes the standard Web browser navigation buttons, such as Back, Forward, Home,
Refresh, and Stop. You can also find these commands in the Browse menu.
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Max keeps thumbnails of all the images you access in its cache. The cache is a directory that
holds thumbnails of all the recently accessed images. Each thumbnail image points to the
actual directory where the image is located. Choose File => Preferences to open the Preference
dialog box, in which you can specify where you want the cache directory to be located. Its
default location is the abcache directory located where Max is installed. To view the cached
files, choose Filter => All in Cache.

Choose File = Print to print the selected image.

Finding files with the Max File Finder utility

Another useful utility for locating files is the Max File Finder utility, which you get to by using
the More button in the Utilities panel. When you select this utility, a rollout with a Start but-
ton appears in the Utility panel. Clicking this button opens the MAXFinder dialog box. Using
MAXFinder, you can search for scene files by any of the information listed in the File
Properties dialog box.

You can use the Browse button to specify the root directory to search. You can select to have
the search also examine any subfolders. Figure 3-31 shows the MAXFinder dialog box locating
all the scene files that include the word blue.

— | MAXFinder Version 1.0 =la/Ed
File Help
Search Text: File Spec: Property:

[blue [Emas | e ~|

Browse.. | IV Include Subfolders

\Current Directory: C:43dsmaxB
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C:43dsmaxEhT utonalshmental_ray\hiace_depth.max

Figure 3-31: You can use the MAXFinder utility to
search for scene files by property.

Collecting files with the Resource Collector utility

When a scene is created, image and object files can be pulled from several different locations.
The Resource Collector utility helps you consolidate all these files into one location. The set-
tings for this utility appear in the Parameters rollout in the Utility panel, as shown in Figure
3-32. The Output Path is the location where the files are collected. You can change this loca-
tion using the Browse button.

The utility includes options to Collect Bitmaps, to include the Max scene file, and to
Compress the files into a compressed WinZip file. The Copy option makes copies of the files,
and the Move option moves the actual file into the directory specified in the Output Path
field. The Update Materials option updates all material paths in the Material Editor. When
you're comfortable with the settings, click the Begin button to start the collecting.
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Using i-drop

To make accessing needed files from the Web even easier, Autodesk has created a technology
known as i-drop that lets you drag files from i-drop-supported Web pages and drop them
directly in Max. With i-drop, you can drag and drop light fixture models from a light manufac-
turer’s Web site into your scene without importing and positioning a file. This format makes it
possible to add geometry, photometric data, and materials.

Accessing File Information

As you work with files, several dialog boxes in Max supply you with extra information about
your scene. Using this information to your advantage can help you keep track of files and
record valuable statistics about a scene.

Displaying scene Information

If you like to keep statistics on your files (to see whether you've broken the company record
for the model with the greatest number of faces), you’ll find the Summary Info dialog box use-
ful. Use the File ® Summary Info menu command to open a dialog box that displays all the rel-
evant details about the current scene, such as the number of objects, lights, and cameras; the
total number of vertices and faces; and various model settings, as well as a Description field
where you can describe the scene. Figure 3-33 shows the Summary Info dialog box.

The Plug-In Info button on the Summary Info dialog box displays a list of all the plug-ins cur-
rently installed on your system. Even without any external plug-ins installed, the list is fairly
long because many of the core features in Max are implemented as plug-ins. The Summary
Info dialog box also includes a Save to File button for saving the scene summary information
as a text file.
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Figure 3-33: The Summary Info dialog box shows all the basic
information about the current scene.

Viewing file properties

As the number of files that you have on your system increases, you’'ll be wishing you had a
card catalog to keep track of them all. Max has an interface that you can use to attach key-
words and other descriptive information about the scene to the file. The File = File Properties
menu command opens the File Properties dialog box. This dialog box, shown in Figure 3-34,
includes three panels: Summary, Contents, and Custom. The Summary panel holds informa-
tion such as the Title, Subject, and Author of the Max file and can be useful for managing a
collaborative project. The Contents panel holds information about the scene such as the total
number of objects and much more. Much of this information is also found in the Summary
Info dialog box. The Custom panel, also shown in Figure 3-34, includes a way to enter a cus-
tom list of properties such as client information, language, and so on.

You can also view the Properties dialog box information while working in Windows Explorer

- by right-clicking the file and selecting Properties. Three unique tabs are visible: General,

Custom, and Summary. The Summary tab holds the file identification information, including
the Title, Subject, Author, Category, Keywords, and Comments.

Viewing files

Sometimes looking at the thumbnail of an image isn’t enough to help you decide whether you
have the right image. For these cases, you can quickly load the image in question into a
viewer to look at it closely. The File => View Image File menu command opens the View File
dialog box shown in Figure 3-35. This dialog box lets you load and view graphic and animation
files using the Rendered Frame Window or the default Media Player for your system.
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Figure 3-34: The File Properties dialog box contains workflow

information such as the scene author, comments, and revision dates.
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Figure 3-35: The View File dialog box can open
an assortment of image and animation formats.

The Rendered Frame Window is discussed in more detail in Chapter 41, “Rendering Basics.”
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The View File dialog box includes several controls for viewing files. The Devices and Setup
buttons let you set up and view a file using external devices such as Video Recorders. The
Info button lets you view detailed information about the selected file. The View button opens
the file for viewing while leaving the View File dialog box open. The Open button closes the
dialog box. At the bottom of the View File dialog box, the statistics and path of the current file
are displayed.

_./Note The View File dialog box can open many types of files, including Microsoft videos (AVI),
s Bitmap images (BMP), Kodak Cineon (CIN), Combustion (CWS), Autodesk Flic images (FLC,
FLI, CEL), Graphics Image Format (GIF), Radiance HDRI Image Files (HDR), Image File List
(IFL), JPEG images (JPG), Portable Network Graphics (PNG), Adobe Photoshop images
(PSD), QuickTime movies (MOV), SGI images (RGB), RLA images, RPF images, Targa images
(TGA, VST), Tagged image file format images (TIF), Abekas Digital Disk (YUV), and DirectDraw
Surface (DDS) images.

You use the Gamma area on the View File dialog box to specify whether an image uses its own
gamma settings or the system’s default setting, or whether an override value should be used.

Summary

Working with files lets you save your work, share it with others, and collaborate across
teams. This chapter covered these basics, including these topics:

4 Creating, saving, opening, merging, and archiving files
4 Understanding the various import and export types
4 Importing models from other programs, such as Illustrator and Poser

4+ Using externally referenced scenes and objects to work on the same project at the
same time as your fellow team members without interfering with their work (or they
with yours)

4+ Configuring XRef paths to help Max track your XRef Scenes and Objects
4+ Working with the file utilities, such as the Asset Browser
4 Using the Summary Info and File Properties dialog box to keep track of scene files

By now, you should be becoming more comfortable with the user interface, but if you're not,
the next chapter covers how to customize the user interface.

+ 0+ 0+



Customizing the
Max Interface and
Setting Preferences

When you get into a new car, one of the first things you do is to
rearrange the seat and mirrors. You do this to make yourself
comfortable. The same principle can apply to software packages —

arranging or customizing an interface makes it more comfortable to
work with.

Early versions of Max allowed only minimal changes to the interface,
but later versions enable significant customization. The Max interface
can be customized to show only the icons and tools that you want to
see. Max also has a rather bulky set of preferences that you can use
to set almost every aspect of the program. This chapter covers vari-
ous ways to make the Max interface more comfortable for you (now if
we could only get cars that could save a custom setup).

Using the Customize User
Interface Window

The key to customizing the interface is the Customize => Customize
User Interface menu command. This command opens the Customize
User Interface dialog box. This dialog box includes five panels includ-
ing Keyboard, Toolbars, Quads, Menus, and Colors. You can also
access this dialog box by right-clicking any toolbar away from the
buttons and selecting Customize from the pop-up menu.

Customizing keyboard shortcuts

If used properly, keyboard shortcuts can increase your efficiency dra-
matically. Figure 4-1 shows the Keyboard panel of the Customize User
Interface dialog box. In this panel, you can assign shortcuts to any
command and define sets of shortcuts. You can assign keyboard
shortcuts for any of the interfaces listed in the Group drop-down list.
When an interface is selected from the Group drop-down list, all its
commands are listed below along with their current keyboard short-
cut. You can disable the keyboard shortcuts for any of these inter-
faces using the Active option located next to the drop-down list.

CHAPTER

¢+ s+
In This Chapter

Using the Customize
User Interface
dialog box

Creating custom
keyboard shortcuts,
toolbars, quadmenus,
menus, and colors

Customizing the
Command Panel buttons

Loading and saving
custom interfaces

Configuring paths
Setting system units
Setting preferences

+ ¢+
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Figure 4-1: The Keyboard panel enables you to create
keyboard shortcuts for any command.

Groups that have a large number of commands are split into categories. You can use the
Category drop-down list to filter only select types of commands. This helps you to quickly
locate a specific type of command such as controllers, modifiers, or Space Warps. Entering
a keyboard shortcut into the Hotkey field shows in the Assigned to field whether that key is
currently assigned to a command. You can Assign the hotkey to the selected command or
Remove the hotkey from its current assignment.

You can use the Write Keyboard Chart button to output all the keyboard commands to a text
file. Using this feature, you can print and post a chart of keyboard shortcuts next to your
computer monitor. You can also Load, Save, and Reset selected keyboard shortcut sets.
Keyboard shortcut sets are saved as .kbd files in the Ul directory where Max is installed.

You can find a reference of the available default keyboard shortcuts in Appendix C, “Max
e Keyboard Shortcuts.”

—

Tutorial: Assigning keyboard shortcuts

Do you use both hands to control the mouse? If not, then you have one hand that is idle most
of the time. If you can train this hand to control features using the keyboard, then you can be
much more efficient.

To assign a new keyboard shortcut to create a Sphere object, follow these steps:

1. Open the Customize User Interface dialog box by choosing Customize > Customize
User Interface.

2. Open the Keyboard panel and select Main Ul in the Group drop-down list. Scroll
through the list, and select the Sphere Object command.
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With a list of objects available, you can quickly jump close to a desired item by typing the first

letter of the item. For example, pressing the S key jumps to the first item that begins with an S.

3. Place the cursor in the Hotkey field, and press Alt+Shift+Ctrl+S keys together. This
enters the hotkey into the field. In the default interface, this key isn’t assigned to any
command. Click the Assign button to assign the hotkey to the command.

4. Click the Save button to save the keyboard shortcut set as myShortcuts.kbd. You can
load the resulting set from the Chap 04 directory on the CD-ROM.

5. The final step is to try out the shortcut. Close the Customize User Interface dialog box,
press the new keyboard shortcut, Alt+Shift+Ctrl+S, and drag in a viewport to create a

sphere.

Customizing toolbars

bars. Figure 4-2 shows this panel.

You can use the Customize User Interface dialog box’s Toolbar panel to create custom tool-

Customize User Interface

8]

Keyboard ‘ Taoolbars ‘ Quads ‘ Menus ‘ Calars

Group WA | s Camstaints

Delete...

Category IA\I Commands | Mew.

| Rename. |

=
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%l Create Camera From View

%) Create CarWhesl Constraint

& Create Cloth Collection

Create Command Mode

% Create Constraint Solver
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Create Faces [Mesh)]
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14 Cieate Hings Constraint
Create Key
Create Line [Spling)

&, Create Linear Dashpot
Create Mode
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& Create New Laver

% Create Plane

“as Create Point-Path Constiaint

&® Create Point-Point Constraint
Create Falygon [Paly]
Create Polygons (Mesh)
Create Position Lock Key

1+~ Create Prismatic Constraint 'v‘ Load... ‘ Save.

Reset

Figure 4-2: The Customize User Interface dialog box enables

you to create new toolbars.

The Toolbars panel of the Customize User Interface dialog box includes the same Group and
Category drop-down lists and command list as the Keyboard panel. Clicking the New button
opens a simple dialog box where you can name the new toolbar. The Delete button lets you
delete toolbars. You can delete only toolbars that you've created. The Rename button lets
you rename the current toolbar. The Hide option makes the selected toolbar hidden.
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Use the Load and Save buttons to load and save your newly created interface, including the
new toolbar, to a custom interface file. Saved toolbars have the .cui extension.

After you create a new toolbar, you can drag the commands in the Action list to either a new
blank toolbar created with the New button or to an existing toolbar. By holding down the Alt
key, you can drag a button from another toolbar and move it to your new toolbar. Holding
down the Ctrl key and dragging a button retains a copy of the button on the first toolbar.

If you drag a command that has an icon associated with it, the icon appears on the new tool-
bar. If the command doesn’t have an icon, then the text for the commands appears on the
new toolbar.

Tutorial: Creating a custom toolbar

If you've been using Max for a while, you probably have several favorite commands that you
use extensively. You can create a custom toolbar of all your favorite commands. To show you
how to do this, we create a custom toolbar for the compound objects.

To create a custom toolbar for creating compound objects, follow these steps:

1. Open the Customize User Interface dialog box by choosing Customize => Custom User
Interface.

2. Open the Toolbars panel and click the New button. In the New Toolbar dialog box that
appears, name the toolbar Compound Objects. After you click OK, a new blank toolbar
appears.

3. Select the Main Ul group and the Objects Compound category from the drop-down lists
on the left. Then drag each command in the Action list to the new blank toolbar.

4. Click the Save button to save the changes to the customized interface file.

I named my file Compound Objects toolbar.cui.

Don't be alarmed if the toolbar icons show up gray. Gray icons are simply disabled. When the

s tool is enabled, they are shown in color.

Figure 4-3 shows the new toolbar. With the new toolbar created, you can float, dock, or add
this toolbar to the Tab panel just like the other toolbars. Notice that some of the tools have
icons and others have text names.

Compound Objects 3,
‘ Blobtdesh @ ;:r % g’;) Mesher % @a @ ®

Figure 4-3: A new toolbar of compound
objects created using the Customize User
Interface dialog box

You can right-click any of the buttons on the new custom toolbar (which is outside the
Customize User Interface dialog box) to access a pop-up menu. This menu enables you to
change the button’s appearance, delete the button, edit the button’s macro script, or open
the Customize User Interface dialog box.
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\ To learn more about editing macro scripts, see Chapter 48, “Automating with MAXScript.”
ce

—

/ Note

Changing a button’s appearance

Selecting the Edit Button Appearance command from the pop-up menu opens the Edit Macro
Button dialog box, shown in Figure 4-4. This dialog box enables you to quickly change the
button’s icon, tooltip, or text label. Each icon group shows both the standard icon and the
grayed-out disabled version of the icon. Default buttons can also be changed. The Odd Only
check box shows only the standard icons.

Edit Macro Button

Toaltip: IB oolean Compound Object

 Text Button [ite IBnn\ean

Group: | Compound ~| [T OddOnly 1
Ao veosame
=

# Image Buttan

5

ok Cancel

Figure 4-4: The Edit Macro Button dialog box provides
a quick way to change an icon, tooltip, or text label.

If a text label doesn't fit within the toolbar button, you can increase the button width using
o the Fixed Width Text Buttons spinner in the General tab of the Preference Settings dialog box.

Tutorial: Adding custom icons

The Max interface uses two different sizes of icons. Large icons are 24x24 pixels, and small
icons are 16x15 pixels. Large icons can be 24-bit color, and small ones must be only 16-bit.
The easiest way to create some custom toolbars is to copy an existing set of icons into an
image-editing program, make the modifications, and save them under a different name. You
can find all the icons saved as BMPs and used by Max in the 3dsmax\UI\Icons directory.

To create a new group of icons, follow these steps:

1. Select a group of current icons to edit from the Ul directory and open them in
Photoshop. [ selected the Patches group, which includes all the files that start with the
word Patches. This group includes only two icons. To edit icons used for both large and
small icon settings and both active and inactive states, open the following four files:
Patches_16a.bmp, Patches_16i.bmp, Patches_24a.bmp, and Patches_24i.bmp.

2. In each file, the icons are all included side by side in the same file, so the first two files
are 32x15 and the second two are 48x24. Edit the files, being sure to keep each icon
within its required dimensions.
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3. When you finish editing or creating the icons, save each file with the name of the icon
group in front of the underscore character. My files were saved as Kels_16a.bmp,
Kels_16i.bmp, Kels_24a.bmp, and Kels_24i.bmp, so they show up in Kels group in the
Edit Macro Button dialog box. Copy these four edited files from the Chap 04 directory
on the CD-ROM to the 3dsmax\UI\Icons directory.

4. After the files are saved, you need to restart Max. The icon group is then available
within the Customize User Interface dialog box when assigned to a command.

Figure 4-5 shows the Edit Macro Button dialog box with my custom icon group named
Kels open.

Edit Macro Button
Taalip: 1Mmph Compound Object
£ Test Buttan Label: IMnrph
Group: |Ke\s ~| [ DddOnly 1
# Image Button .
o0 | oo
-
T —
0K Cancel

Figure 4-5: The Edit Macro Button dialog box with a
custom icon group selected

Customizing quadmenus

The third panel in the Customize User Interface dialog box allows you to customize the quad-
menus. You can open quadmenus by right-clicking on the active viewport or in certain inter-
faces. Figure 4-6 shows this panel.

To the left of the panel are the Group and Category drop-down lists and a list of actions that
are the same as the Keyboard and Toolbars panels, but the Quads panel also includes a
Separator and a list of Menu commands. Quadmenus can include separators to divide the
commands into different sections and menus that appear at the top of the standard interface.

The drop-down list at the top right of the Quads panel includes many different Quadmenu
sets. These quadmenus appear in different locations, such as with the ActiveShade window.
Not only can you customize the default viewport quadmenus, but you can also create your
own named custom quadmenus with the New button or Rename an existing quadmenu. The
Quad Shortcut field lets you assign a keyboard shortcut to a custom quadmenu.

Several quadmenus have keyboard shortcuts applied to them. Right-clicking with the Shift
.,_ key held down opens the Snap quadmenu. Other shortcuts include Alt+right-click for the
/ Animation quadmenu, Ctrl+right-click for the Modeling quadmenu, and Ctrl+Alt+right-click
for the Lighting/Rendering quadmenu.
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Figure 4-6: The Quads panel of the Customize User Interface
dialog box lets you modify pop-up quadmenus.

If the Show All Quads option is disabled, it causes only a single quadmenu to be shown at a
time when unchecked. Although only one quadmenu is shown at a time, the corner of each
menu is shown, and you can switch between the different menus by moving the mouse over
the corner of the menu.

The four quadrants of the current quadmenu are shown as four boxes. The currently selected
quadmenu is highlighted yellow, and its label and commands are shown in the adjacent fields.
Click the gray boxes to select one of the different quadmenus.

To add a command to the selected quadmenu, drag an action, separator, or menu from the
panes on the left to the quadmenu commands pane on the right. You can reorder the com-
mands in the quadmenu commands pane by dragging the commands and dropping them in
their new location. To delete a command, just select it and press the Delete key or select
Delete Menu Item from the right-click pop-up menu.

The right-click pop-up menu also lets you edit the command name or flatten a submenu,
which displays all submenu commands on the top level with the other commands.

Custom quadmenus can be loaded and saved as menu files (with the .mnu extension).

The Quads panel also includes an Advanced Options button. Clicking this button opens the
Advanced Quad Menu Options dialog box, shown in Figure 4-7. Using this dialog box, you can
set options such as the colors used in the quadmenus.
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Figure 4-7: The Advanced Quad Menu Options dialog box lets
you change quadmenu fonts and colors.

Changes to the Advanced Quad Menu Options dialog box affect all quadmenus. You can load
and save these settings to files (with the .qop extension). The Starting Quadrant determines
which quadrant is first to appear when the quadmenu is accessed. You can select to change
the colors for each quadmenu independent of the others. The column with the L locks the
colors so they are consistent for all quadmenus if enabled.

The remainder of the Advanced Quad Menu Options dialog box includes settings for control-
ling how the quadmenus are displayed and positioned, as well as the fonts that are used.

The Animation section lets you define the animation style that is used when the quadmenus
appear. The animation types include None, Stretch, and Fade. The Stretch style slowly stretches
the quadmenus until they are full size over the designated number of steps, and the Fade style
slowly makes the quadmenus appear.

I personally don't like to wait for the quadmenus to appear, so | keep the Animation setting
set to None.

s
Customizing menus

The Menus panel of the Customize User Interface dialog box allows you to customize the
menus used at the top of the Max window. Figure 4-8 shows this panel.

This panel includes the same Group and Category drop-down lists and the Action, Separator,
and Menus panes found in the Quads panel. You can drag and drop these commands on the
menu pane to the right. Menus can be saved as files (with the .mnu extension). In the menu
pane on the right, you can delete menu items with the Delete key or by right-clicking and
selecting Delete Item from the pop-up menu.

If you place an ampersand (&) character in front of a custom menu name letter, that letter is
underlined and can be accessed using the Alt key; for example, Alt+F opens the File menu.
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Figure 4-8: You can use the Menus panel of the Customize
User Interface dialog box to modify menus.

Tutorial: Adding a new menu

Adding a new menu is easy to do with the Customize User Interface dialog box. For this exam-
ple, you tack another menu for the Collapse utility on the end of the Tools menu.

To add another menu item to the Tools menu, follow these steps:

1. Choose Customize > Customize User Interface to open the Customize User Interface
dialog box.

2. Click the Menus tab to open the Menus panel.
3. In the top-right drop-down list, select Tools.
The current Tools menu opens in the right pane.

4. Locate the Collapse Stack menu item in the Action list, drag it to the right, and drop it
right after the Channel Info Editor menu item.

As you drag, a blue line indicates where the menu will be located.

5. Click the Save button to save the menu as a file. You can find the customized menu
from this example in the Chap 04 directory on the CD-ROM.

After you save the new menu file, you need to restart Max before you can see the changes.
You can reset the default Ul by choosing Customize > Revert to Startup Layout.
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Customizing colors

Within Max, the colors often indicate the mode in which you’re working. For example, red
marks animation mode. Using the Colors panel of the Customize User Interface dialog box,
you can set custom colors for all Max interface elements. This panel, shown in Figure 4-9,
includes two panes. The upper pane displays the available items for the interface selected in
the Elements drop-down list. Selecting an item in the list displays its color in the color swatch

to the right.
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Figure 4-9: You can use the Colors panel of the Customize
User Interface dialog box to set the colors used in the interface.

The lower pane displays a list of the custom colors that can be changed to affect the appear-
ance of the interface. For example, Highlight Text isn’t an element; it’s an interface appear-
ance. The Scheme drop-down list can alter the color scheme between custom colors and the
Windows Default Colors.

You can save custom color settings as files with the .clr extension. You can use the Apply
Colors Now button to immediately update the interface colors.

Customizing Modify and Utility Panel Buttons

The Modify and the Utilities panels in the Command Panel both include a button called
E Configure Button Sets that allows you to configure how the modifiers are grouped and
which utility buttons appear in the Utilities panel.
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In the Modify panel, the Configure Modifier Sets button is the right-most button directly
under the Modifier Stack. This button opens a pop-up menu that lists all the modifier cate-
gories. The top pop-up menu command is Configure Modifier Sets, which opens a dialog box,
shown in Figure 4-10, when selected. Using this dialog box, you can control which modifiers
are grouped with which sets.
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Figure 4-10: The Configure Modifier Sets dialog
box lets you group the modifiers as you want.

To add a modifier to a set, select the set from the Sets drop-down list and drag the modifier
from the list of Modifiers on the left to the button set on the right. To create a new set, simply
type a new name into the Sets field. After a set has changed, you need to save it with the Save
button.

You can find the same Configure Button Sets button on the Utilities panel. Clicking this button
opens a similar dialog box where you can drag from a list of Utilities onto a list of buttons on
the right. These buttons are then displayed in the Utilities panel.

Working with Custom Interfaces

If you've changed your interface, you'll be happy to know that the Customize menu includes a
way for you to save and then reload your custom setup. This feature is especially helpful for
users who share a copy of Max.

Tip Any custom .ui file can be loaded as the default interface from the command line by
_adding a —c and the .ui filename after the 3dsmax.exe file (for example, 3dsmax.exe
4 —cmy_interface.ui).
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Saving and loading a custom interface

Custom interface schemes are saved with the .ui extension using the Customize => Save
Custom Ul Scheme menu command. When you save a custom scheme, Max opens a Custom
Scheme dialog box, shown in Figure 4-11. This dialog box lets you choose which customiza-
tions to include in the custom scheme. It also lets you select the icon type to use. The options
are Classic and 2D Black and White.

&l Custom Scheme Figure 4-11: The Custom Scheme dialog box appears when
you're saving a custom interface and lets you select which
items to include.

IV Interface Layout [, cuil Al
¥ Keyboard Shortcuts [ kbd) MNone
v Merus [ mnu)

¥ Quad Options [.qop]

v Colors [ ci]

# Classic
" 2D Black and White

Ok Cancel

leon Type:

You can load saved user interface schemes with Customize = Load Custom Ul. The default
Max install includes several predefined interface setups that are located in the Ul directory.
The standard available interfaces include

4 DefaultUI: Default interface that opens when Max is first installed.

4+ Discreet-dark: Displays the standard interface with black windows, backgrounds, and
viewports. All the icons and menus are light gray and many of the icons are different.

4+ Discreet-light: Same as the Discreet-dark layout, except the icons and menus are black
and the backgrounds are all light gray. Many icons are different here, too.

4 ModularToolbarsUI: An interface that breaks the main toolbar into many different
smaller toolbars that are easier to move and arrange.

Figure 4-12 shows the Discreet-dark custom interface. If you’re one who likes to wear sun-
glasses, this interface might feel just right to you.

You can use both the load and save menu commands to save and load any of the custom user
interface files types including these:

4 Interface Scheme files (.ui)

4+ Ul files (.cui)

4 Menu files (mnu)

4+ Color files (.clr)

4+ Keyboard Shortcut files ((kbd)
4 Quadmenu Options files (.qop)
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Figure 4-12: The Discreet-dark interface is one of the preset custom interfaces that you
can load.

Tutorial: Saving a custom interface

You can save personalized interfaces for later recall in the 3dsmax\UI directory where Max is
installed. To do so, choose Customize > Save Custom Ul

To have Max start with your custom interface, follow these steps:
1. Customize your interface by making any desired changes.
2. Choose Customize > Save Custom Ul Scheme.
The Save Custom Ul Scheme dialog box opens.

3. Open the Ul subdirectory (if you are not already there), select the MaxStart.ui file, and
click OK.

4. Click OK to replace the existing file.

/ Note You can set Max to automatically save your interface changes when exiting. Select the Save
o Ul Configuration on Exit option in the General tab of the Preference Settings dialog box.
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Locking the interface

After you're comfortable with your interface changes, locking the interface to prevent acci-
dental changes is a good idea. To lock the current interface, choose Customize => Lock Ul
Layout (or press the Alt+0 keyboard shortcut).

Reverting to the startup interface

When you're first playing around with Max’s customization features, really messing things up
can be easy. If you get in a bind, you can reload the default startup interface (MaxStart.ui)
with the Customize = Revert to Startup Ul Layout command. Using the File => Reset menu
command does not reset changes to the layout.

/Note If your MaxStart.ui file gets messed up, you can reinstate the original default interface setup
el by deleting the MaxStart.ui file before starting Max.

Switching between default and custom interfaces

The Customize > Custom Ul and Defaults Switcher menu command opens an interactive win-
dow that presents several options for selecting initial settings and interface schemes, as
shown in Figure 4-13. At the top of the window, you can select an option and details about the
selected option is displayed.

?ew \ The Settings and Scheme chooser window is new to 3ds max 6.
eature

Choose initial settings for tool options and Ul layout.

Irifial settings for tool options Ul schermes:

M Defauil]
Mamentaliay ModulaiTaolbarsUl
Design¥IZ divcrestight
DesigriviZmentaliay discrestdark

Configure 3ds max 6's options to match the type of work you will be
doin

<€ Set Cancel

Figure 4-13: This window explains the benefits of the different
initial settings and scheme choices.
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The initial settings for the tool options list include Max, Max.mentalray, DesignVIZ, and
DesignVIZ.mentalray. These different selections cause the default settings for the various con-
trols to change. For example, the default renderer for Max is the Scanline renderer, but for the
Max.mentalray option, mental ray is the default renderer.

The schemes list includes the same custom interfaces listed earlier.

After selecting the initial settings and scheme to use, click the Set button to commit the selec-
tions to the interface. The button with arrows on it in the lower left displays the initial infor-
mation page again.

Configuring Paths

When strolling through a park, chances are good that you'll see several different paths. One
might take you to the lake and another to the playground. Knowing where the various paths
lead can help you as you navigate around the park. Paths in Max lead, or point to, various
resources, either locally or across the network.

All paths can be configured using the Configure Paths dialog box, shown in Figure 4-14.
Choose Customize > Configure Paths to open this dialog box. The dialog box includes four
panels: General, Plug-Ins, External Files, and XRefs.

When Max is installed, all the paths are set to point to the default subdirectories where Max
was installed. To modify a path, select the path and click the Modify button. A file dialog box
lets you locate the new directory.
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Figure 4-14: The Configure Paths dialog box specifies
where to look for various resources.

The General tab includes paths for the following:
4 AutoBackup: Directory where backups are saved
4 Defaults: Directory where the various default settings are saved
4+ Export: Directory where exported files are saved

4+ Expressions: Directory containing expression files



144

Part | + Learning the Max Interface

4+ Fonts: Directory containing fonts
4 Heidi Drivers: Directory containing the Heidi Drivers
4 Help: Directory containing help files
4 Images: Directory to open when loading images
4+ Import: Directory to open when importing geometry
4 Materials: Directory containing material files
4+ MaxStart: Directory containing programs to execute when Max is started
4 PlugCFG: Directory containing plug-in configuration files
4+ Previews: Directory where previews are saved
4+ Render Presets: Directory where render presets are stored
4 Scenes: Directory where saved scene files are stored
4 Scripts: Directory where scripts are stored
4 Sounds: Directory to open when sound files are loaded
4 Startup Scripts: Directory containing scripts that load when Max is started
4 VideoPost: Directory where Video Post output is saved
Tip Personally, | like to keep all my content in a separate directory from where the application is
ﬂ_ installed. That way, new installs or upgrades won't risk overwriting my files. To do this, I typi-

4 cally change the paths to AutoBackup, Export, Images, Import, Materials, Previews, Scenes,
Scripts, Sounds, and Video Post.

Under the Plug-Ins, Eternal Files, and XRefs tabs, you can add and delete additional paths that
specify where Max looks to find plug-ins and so on. The XRefs and External Files panels spec-
ify where to look for external resources and files. All paths are searched when you're looking
for resources such as plug-ins, but file dialog boxes open only to the first path. Use the Move
Up and Move Down buttons to realign path entries.

Caution Using the Customize = Revert to Startup Ul Layout command does not reset path configura-
tion changes.

Selecting System Units

One of the first tasks you need to complete before you can begin modeling is to set the sys-
tem units. The system units have a direct impact on modeling and define the units that are
represented by the coordinate values. Units directly relate to parameters entered with the
keyboard. For example, with the units set to meters, a sphere created with the radius
parameter of 2 would be 4 meters across.

Max supports several different measurement systems, including Metric and U.S. Standard
units. You can also define a Custom units system (I suggest parsecs if you're working on a
space scene). Working with a units system enables you to work with precision and accuracy
using realistic values.
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To specify a units system, choose Customize = Units Setup to display the Units Setup dialog
box, shown in Figure 4-15. For the Metric system, options include Millimeters, Centimeters,
Meters, and Kilometers. The U.S. Standard units system can be set to the default units of Feet
or Inches. You can also select to work with fractional inches or decimal inches from the drop-
down list. Fractional values can be divided from 1/1 to 1/100 increments.

[Units Setup [2JEJ| | System Unit Setup &

: [~ System Unit Scale ———
System Unit Setup 1 Unit= |1 0 Inches :J

[v Respect System Units in Files

i~ Display Uit Scal
1 Metric Oirigir 16777215.0
l—;] ----------- {j tonuen oo ot Gon
# 1S Standard Distance from origin lw—

J Resulting Accuracy: [0.0000001132
i Cancel

IFeet w/Decimal Inches j I
Default Units: ® Feet Inches

" Custom

JFL - [Fe00 | o~
" Generic Units
Lighting Unit:

Ok Cancel

Figure 4-15: The Units Setup dialog box lets you choose which
units system to use. Options include Metric, U.S. Standard,
Custom, and Generic.

Using Custom and Generic units

To define a Custom units system, modify the fields under the Custom option, including a units
label and its equivalence to known units. The final option is to use the default Generic units.
Generic units relate distances to each other, but the numbers themselves are irrelevant. You
can also set lighting units to use American or International standards.

At the top of the Units Setup dialog box is the System Unit Setup button. This button opens
the System Unit Scale dialog box, also shown in Figure 4-15. This dialog box enables you to
define the measurement system used by Max. Options include Inches, Feet, Miles,
Millimeters, Centimeters, Meters, and Kilometers.

A multiplier field allows you to alter the value of each unit. The Respect System Units in Files
toggle presents a dialog box whenever a file with a different system units setting is encoun-
tered. If this option is disabled, all new objects are automatically converted to the current
units system.

The Origin control helps you determine the accuracy of an object as it is moved away from
the scene origin. If you know how far objects will be located from the origin, then entering
that value tells you the Resulting Accuracy. You can use this feature to determine the accu-
racy of your parameters. Objects farther from the origin have a lower accuracy.
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Rescaling world units

If you discover halfway through your scene that you're working with the wrong units, you can
use the Rescale World Units utility to scale up the entire scene or just selected objects. To

access this utility, click the Utilities panel and then the More button. In the utilities list, select
the Rescale World Units utility and click OK.

The Rescale World Units dialog box has a Scale Factor value, which is the value by which the
scene or objects is increased or decreased. If your world was created using millimeter units
and you need to work in meters, then increasing by a Scale Factor of 1000 would set the

world right.

Setting Preferences

The Preference Settings dialog box lets you configure Max so it works in a way that is most
comfortable for you. You open it by choosing Customize = Preferences. The dialog box
includes eleven panels: General, Files, Viewports, Gamma, Rendering, Animation, Inverse
Kinematics, Gizmos, MAXScript, Radiosity, and mental ray.

\ The Preference Settings dialog box includes a new panel in 3ds max 6: mental ray. The
Advanced Lighting panel has also been renamed as the Radiosity panel.

General preferences

The first panel in the Preference Settings dialog box is for General settings, as shown in

Figure 4-16.

Preference Settings

Irwerse Kinematics | Gizmos |

General | Files |
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’V Levels: |20 ﬂ ’V [~ Constant —‘
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¢ Left->Right => Crossing

Viewparts |

r~ Spinner

Precision: [3 g Decimals
Snap: [T0 2/ I~ UseSnap

I~ Wrap Cursor Near Spinner

Rollout Thresholdt: [0 %]

Vertex Momal Style
’V ™ Use Legacy R4 Verter Normals

"Eummand Fanel ‘

2% ]
M5 cript ‘ Radiosity ‘ mental ray ‘
Gamma | Rendering ‘ Animation ‘

r Ul Digplay
[V Enable Viewport Tooltips

¥ AutoPlay Preview File

™ Displap Cross Hair Cursar

¥ Display Topology-Dependence Warming
[V Display Stack Collapse Waining

v Save Ul Configuration on Evit

¥ Use Large Toolbar Buttons

[¥ Horizontal Text in Yertical Toolbars

¥ Fixed Width Text Buttons: Wﬂp\xals
Flpout Time: |3UU ﬂ mSec
Color Selector: | Default Color Picker '1

r Laver Defaul
[~ Default to By Layer for New Modes
I New Lights Penderable By Layer

Propagate Unhide/Unfreeze Commands
to Layers?

¢ Propagate ¢ DoMNot Propagate ® Ask

: Cancel

Figure 4-16: The General panel enables you to change the
unit scale, among other options.
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The General panel includes many global settings that affect the entire interface.

The quickest way I've found to open the Preference Settings dialog box is to right-click the
.. Spinner Snap Toggle button.

%

y

Undo Levels and the Reference Coordinate System

The Scene Undo spinner sets the number of commands that can be kept in a buffer for undo-
ing. A smaller number frees up memory, but does not let you backtrack through your work.
The default Undo Levels is 20.

The Reference Coordinate System setting makes all transform tools use the same coordinate
system when the Constant option is enabled. If disabled, each transform uses the coordinate
system last selected.

Loading Plug-Ins and Sub-Material settings

The Load Plug-Ins When Used option keeps plug-ins out of memory until they are accessed.
This saves valuable memory and still makes the plug-ins accessible.

The Automatic Sub-Material Assignment option, when checked, enables materials to be
dragged and dropped directly onto a subobject selection.

Scene Selection settings

The Auto Window/Crossing by Direction option lets you select scene objects using the win-
dowing method (the entire object must be within the selected windowed area to be selected)
and the crossing method (which selects objects if their borders are crossed with the mouse)
at the same time depending on the direction that the mouse is dragged. If you select the first
option, then the Crossing method is used when the mouse is dragged from right to left and
the Window method is used when the mouse is dragged from left to right.

Spinner, Rollup, and Vertex Normal settings

Spinners are interface controls that enable you to enter values or interactively increase or
decrease the value by clicking the arrows on the right. The Preference Settings dialog box
includes settings for changing the number of decimals displayed in spinners and the incre-
ment or decrement value for clicking an arrow. The Use Spinner Snap option enables the
snap mode.

@5 You can also enable the snap mode using the Spinner Snap button on the main toolbar.

You can also change the values in the spinner by clicking the spinner and dragging up to
increase the value or down to decrease it. The Wrap Cursor Near Spinner option keeps the
cursor close to the spinner when you change values by dragging with the mouse, so you can
drag the mouse continuously without worrying about hitting the top or bottom of the screen.

The Rollup Threshold value sets how many pixels can be scrolled before the rollup shifts to
another column. This is used only if you've made the Command Panel wider or floating.

The Use Legacy R5 Vertex Normals option computes vertex normals based on the Max ver-
sion 4 instead of the new method used in Max 6. The newer method is more accurate but may
impact smoothing groups.
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New
Feature

- Cross-
| Referen

Interface Display settings

The options in the Ul Display section control additional aspects of the interface. The Enable
Viewport Tooltips option can toggle tooltips on or off. Tooltips are helpful when you're first
learning the Max interface, but they quickly become annoying and you’ll want to turn them off.

The AutoPlay Preview File setting automatically plays Preview Files in the default media
player when they are finished rendering. If this option is disabled, you need to play the pre-
views with the Animation => View Preview menu command. The Display Cross Hair Cursor
option changes the cursor from the Windows default arrow to a crosshair cursor similar to
the one used in AutoCAD.

For some actions, such as non-uniform scaling, Max displays a warning dialog box asking
whether you are sure of the action. To disable these warnings, uncheck this option (or you
could check the Disable this Warning box in the dialog box). Actions with warnings include
topology-dependence and collapsing the Modifier Stack.

The Save Ul Configuration on Exit switch automatically saves any interface configuration
changes when you exit Max. You can deselect Use Large Toolbar Buttons option, enabling the
use of smaller toolbar buttons and icons that reclaims valuable screen real estate.

The Horizontal Text in Vertical Toolbars options fix the problem of text buttons that take up
too much space, especially when printed horizontally on a vertical toolbar. You can also spec-
ify a width for text buttons. Any text larger than this value is clipped off at the edges of the
button.

The Flyout Time spinner adjusts the time the system waits before displaying flyout buttons.
The Color Selection drop-down list lets you choose which color selector interface Max uses.

Layer settings

If you select an object and open its Properties dialog box, the Display Properties, Rendering
Control, and Motion Blur sections each have a button that can toggle between ByLayer and
ByObiject. If ByObject is selected, then the options are enabled and you can set them for the
object in the Properties dialog box, but if the ByLayer option is selected, then the settings are
determined by the setting defined for all objects in the layer in the Layer Manager.

\ The New Lights Renderable By Layer and Propagate Unhide/Unfreeze Commands to Layers
options are new to 3ds max 6.

The settings in the Preference Settings dialog box set the ByLayer option as the default for
new objects and new lights. You also have an option to propagate all unhide and unfreeze
commands to the layer. You can select Propagate, Do Not Propagate, or Ask.

Files panel preferences

The Files panel holds the controls for backing up, archiving, and logging Max files. You can
set files to be backed up, saved incrementally, or compressed when saved.

\ The Files panel is covered in Chapter 3, “Working with Files and XRefs."
ce

—
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Viewport preferences

The viewports are your window into the scene. The Viewports panel, shown in Figure 4-17,
contains many options for controlling these viewports.

Preference Settings @]
Irwerse Kinematics | Gizmos | MaScript ‘ Radiosity ‘ mental rap ‘
General | Files | Wiewparts | Gamma | Rendering ‘ Lnimation ‘
—Wiewport P, i Ghosting
¥ Use Dual Planes Ghosting Frames: |5 =
¥ Shaow Vertices as Dots Size: [2 ﬂ Display Mth Frame: |1— ﬂ
Handie Size: [3— 2 & Ghos! Befors Curent Frams
[™ Diaw Links as Lines € Ghaost After Currert Frame
I¥ Backfacs Cull on Obiject Creation £ Ghast Before and After
v dttenuate Liohts v Ghast in Wireframe
¥ Mask Viewport to S afe Region ™ Show Frame Numbers

™ Update Background While Playing
™ Fiker Envitanment Backgrounds
¥ Low-Res Envionment Background

~ Mouse Control
Middle Button: @ Pan/Zoom  Stroke

v Display world Axis [¥ Zoom About Mouse Point [Orthographic)
Giid Nudge Distance:  [1.0 ﬂ v Zoom About Mouse Paint (Perspective]
Ne b e hﬂ_ ﬂ [~ Right Click Meru Over Selectzd Only

[~ Display Driver

Choose Driver. Currently Installed Driver:
Configure Driver... | OpenGL ATl Technologies Inc. version 1.3.3565 Win<F Release]

| Cancel

Figure 4-17: The Viewports panel contains several viewport
parameter settings.

Although the viewports were the major topic in Chapter 2, “Seeing It All —Working with the
& Viewports,” the viewport preference settings are covered here.

—

Viewport Parameter options

The Use Dual Planes option enables a method designed to speed up viewport redraws.
Objects close to the scene are included in a front plane and objects farther back are included
in a back plane. When this option is enabled, only the objects on the front plane are redrawn.

In subobject mode, the default is to display vertices as small plus signs. The Show Vertices as
Dots option displays vertices as either Small or Large dots. The Draw Links as Lines option
shows all displayed links as lines that connect the two linked objects.

Caution I've found that keeping the Draw Links as Lines option can make it confusing to clearly see

objects and tend to keep it turned off.
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When the Backface Cull on Object Creation option is enabled, the backside of objects in wire-
frame mode are not displayed. If disabled, you can see the wireframe lines that make up the
backside of the object. The Backface Cull option setting is determined when the object is
created, so some objects in your scene might be backface culled and others might not be.
Figure 4-18 includes a sphere and a cube on the left that are backface culled and a sphere
and cube on the right that are not.

/Note The Object Properties dialog box also contains a Backface Cull option.
/

-

B[]

Figure 4-18: Backface culling simplifies objects
by hiding their backsides.

The Attenuate Lights option causes objects farther back in a viewport to appear darker.
Attenuation is the property that causes lights to diminish over distance.

In the Viewport Configuration dialog box, you can set Safe Regions, which are borders that
the renderer includes. The Mask Viewport to Safe Region option causes the objects beyond
the Safe Region border to be invisible.

The Update Background While Playing option causes viewport background bitmaps to be
updated while an animation sequence plays. Viewport backgrounds can be filtered if the
Filter Environment Background option is enabled, but this slows the update time. If this
option is disabled, the background image appears aliased and pixelated. For quicker refresh
times, enable the Low-Res Environment Background option. This reduces the resolution of
the background image by half and resizes it to fill the viewport. Enabling this option results
in a blocky appearance, but the viewport updates much more quickly. Figure 4-19 shows a
background of San Francisco at normal resolution (left) and low-res (right).

The Display World Axis option displays the axes in the lower-left corner of each viewport.
The Grid Nudge Distance is the distance that an object moves when Grid Nudge (+ and - on
the numeric keypad) keys are used. Objects without scale, such as lights and cameras,
appear in the scene according to the Non-Scaling Object Size value. Making this value large
makes lights and camera objects very obvious.
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Figure 4-19: Background images can be set to be low-res to enable the
viewports to update more quickly.

Enabling ghosting

Ghosting is similar to the use of “onion-skins” in traditional animation, making an object’s
prior position and next position to be displayed. When producing animation, knowing where
you're going and where you've come from is helpful. Enabling ghosting helps you to produce
better animations.

Max offers several ghosting options. You can set whether a ghost appears before the current
frame, after the current frame, or both before and after the current frame. You can set the
total number of ghosting frames and how often they should appear. You can also set an
option to show the frame numbers.

- Cross- For a more detailed discussion of ghosting, see Chapter 30, “Animation Basics.”
Reference

Using the middle mouse button

If you're using a mouse that includes a middle button (this includes a mouse with a scrolling
wheel), then you can define how the middle button is used. The two options are Pan/Zoom
and Stroke.

Panning, rotating, and zooming with the middle mouse button

The Pan/Zoom option pans the active viewport if the middle button is held down, zooms in
and out by steps if you move the scrolling wheel, rotates the view if you hold down the Alt key
while dragging, and zooms smoothly if you drag the middle mouse button with the Ctrl and Alt
keys held down. You can select options to zoom about the mouse point in the orthographic
and perspective viewports. If disabled, you’ll zoom about the center of the viewport. The Right
Click Menu Over Selected Only option causes the quadmenus to appear only if you right-click
on top of the selected object. This is a bad idea if you use the quadmenus frequently.

Using Strokes

The Stroke option enables another interface that lets you execute commands by dragging a
pre-defined stroke in a viewport. With the Stroke option selected, close the Preference
Settings dialog box and drag with the middle mouse button held down in one of the view-
ports. A simple dialog box identifies the stroke and executes the command associated with it.
If no command is associated, then a simple dialog box appears that lets you Continue (do
nothing) or Define the stroke.
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Another way to work with strokes is to enable the Strokes Utility. This is done by selecting
the Utility panel, clicking the More button, and selecting Strokes from the pop-up list of utili-
ties. This utility makes a Draw Strokes button active. When the button is enabled, it turns yel-
low and you can draw strokes with the left or middle mouse buttons.

If you select to define the stroke, the Define Stroke dialog box, shown in Figure 4-20, is
opened. You can also open this dialog box directly by holding down the Ctrl key while drag-
ging a stroke with the middle mouse button. In the upper-left corner of this dialog box is a
grid. Strokes are identified by the lines they cross on this grid as they are drawn. For exam-
ple, an “HK” stroke would be a vertical line that is dragged from the top of the viewport
straight down to the bottom.

Define Stroke

rStroke to Defing: ——————————————— - Command to Execute

| ] ‘ Abzolute/Relstive Snap Toagle Mode  |a |
2 B Aclivate Grid Dbject =
Activate Home Grid
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Align Maormals
Angle Snap Toggle
[ i , Animation Maode Toggle
. L2 Apply Inverse Kinematics
Arc Ratate
£ F Array o
| X ‘ Backface Cull Toggle |
MHEM Curently assigned o stroke:
None

~ Command Should Operate Onn——————————————————————— ~ Cunent Stroke Set——
G e e (eEr e e e e axSir
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¢ Al Objects in the Selection Set

£ Al Objects in Rectangular Exterits & ifindaw L

Multiple Dbjects based on the Stroke Boundary
’7 " All Objects in Circular Extents £~ Crossing Cancel |

Figure 4-20: The Define Stroke dialog box can associate
strokes dragged with the middle mouse button with
a command.

With a stroke identified, you can select a command in the upper-right pane. This is the com-
mand that executes when you drag the stroke with the middle mouse button in the viewport.
For each command, you can set the options found below the stroke grid. These options
define what the command is executed on.

All defined strokes are saved in a set, and you can review the current set of defined strokes
with the Review button. Clicking this button opens the Review Strokes dialog box where all
defined strokes and their commands are displayed. The only stroke defined by default opens
this dialog box, as shown in Figure 4-21.

One of the commands available in the list of commands is Stroke Preferences. Using this com-
mand opens the Stroke Preferences dialog box, also shown in Figure 4-21, where you can save
and delete different stroke sets, specify to list commands or strokes in the Review Strokes
dialog, set the time that the stroke grid and extents appear, and set the Stroke Point Size.
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Figure 4-21: The Review Strokes and Stroke Preferences dialog boxes list
all defined strokes and their respective commands.

Tutorial: Defining a stroke

As you get some experience with the Max interface, you’ll find that for some commands you
always use keyboard shortcuts, for others you use the main toolbar, and for others you use
the menus. Strokes offer another way to quickly execute commands without the pain of
searching the menus for a given command.

To assign a stroke to a command, follow these steps:

1. Open the Preference Settings dialog box with the Customize ©> Preferences menu
command.

2. Select the Viewports panel, and in the Mouse Control section, select the Stroke option.
Then close the Preference Settings dialog box.

3. With the middle mouse button, drag a “U”-shaped stroke in the active viewport. A dia-
log box identifies the stroke as not found. Click the Define button to open the Define
Stroke dialog box.

4. The stroke (as you drew it) is displayed in the upper-left grid, and if you drew it cor-
rectly, it should be identified as ‘GJEFLIL.’ In the Command list, select the Unhide All
command and click the OK button to close the dialog box.

5. Use the Tools = Display Floater to hide some objects in the current scene, and then
drag a “U”-shaped stroke with the middle mouse button.

All the hidden objects become visible.

Choosing and configuring display drivers

When Max was first launched, a simple dialog box asked you which display driver to use (see
Figure 4-22). If you were anxious to get a look at Max, you probably didn’t pay much attention
to this dialog box. However, weeks later when you happen to be looking through your video

card information, you realize that your card supports other drivers like OpenGL and Direct 3D.
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Caution The Graphics Driver Setup dialog box displays the options only for the drivers that it finds on
your system, but just because an option exists doesn't mean it works correctly. If a driver
hangs your system, you can restart it from a command line with the —h flag after 3dsmax.exe
to force Max to present the Graphics Driver Setup dialog box again.

Graphics Driver Setup Figure 4-22: You use the Graphics Driver Setup dialog box to
@ Sofware select the display drivers.

 OperGL

€ Diect3D  Advanced Direct3
£ Custom v
oK Cancel

If you want to try out or configure the different display drivers, you can use the Viewports
panel of the Preference Settings dialog box. The Viewports panel includes a field that displays
the currently installed driver along with two buttons to Choose Driver and Configure Driver.
The Choose Driver button opens the Graphics Driver Setup dialog box again. If you change
the display driver, you need to restart Max.

__/Note The driver that you use really depends on the video card in your system. Check with the doc-
- umentation that came with your video card to see what drivers it supports. If you're unsure,
use the default software driver.

The Configure Driver option opens a dialog box of configurations for the driver that is cur-
rently installed. The various configuration dialog boxes include options such as specifying
the Texture Size, which is the size of the bitmap used to texture map object. Larger maps
have better image quality, but can slow down your display.

All the display driver configuration settings present trade-offs between image quality and
speed of display. By tweaking the configuration settings, you can optimize these settings to
suite your needs. In general, the more memory available on your video card, the better the
results.

[grt;ss- \ You can learn more about the various display drivers in Appendix B, “Configuring and
GIOIBTICE Installing 3ds max 6."

Gamma preferences

The Gamma panel, shown in Figure 4-23, controls the gamma correction for the display and
for bitmap files.
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Figure 4-23: Enabling gamma correction makes colors
consistent regardless of the monitor.

Setting screen gamma

Have you ever noticed in an electronics store that television screen displays vary in color?
Colors on monitor screens may be fairly consistent for related models, but may vary across
brands. Gamma settings are a means by which colors can be consistently represented regard-
less of the monitor that is being used.

Gamma value regulates the contrast of an image. It is a numerical offset required by an indi-
vidual monitor in order to be consistent with a standard. To enable gamma correction for
Max, open the Gamma panel in the Preference Settings dialog box and click the Enable
Gamma Correction option. To determine the gamma value, use the spinner or adjust the
Gamma value until the gray square blends in unnoticeably with the background.

Setting bitmap gamma

Many bitmap formats, such as TGA, contain their own gamma settings. The Input Gamma set-
ting for Bitmap files sets the gamma for bitmaps that don’t have a gamma setting. The Output
Gamma setting is the value set for bitmaps being output from Max.

Match the Input Gamma value to the Display Gamma value so that bitmaps loaded for textures
o are displayed correctly.
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Rendering preferences

The Rendering panel includes controls for setting the Video Color Check, Output Dithering,
and Field Order. In addition, you can set the Super Black Threshold, Hotspot Falloff,
Background Anti-Aliasing, Default Ambient Light Color, and Output File Sequencing in this
panel. Max also offers controls for playing an alert sound when a rendering is finished and
settings you can use to determine the number of GBuffers. Other settings enable multithread-
ing and a way to break up bitmaps into pages.

\ The details of the Rendering Preferences panel are covered in Chapter 41, “Rendering
S Basics!”

Animation preferences

The Animation panel, shown in Figure 4-24, contains options dealing with animations. When
a specific frame is selected, all objects with keys for that frame are surrounded with white
brackets. The Animation panel offers options that specify which objects get these brackets.
Options include All Objects, Selected Objects, and None. You can also limit the brackets to
only those objects with certain transform keys.

Preference Settings =&
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General Files | Viewparts | Gamma | Rendering ‘ Animation ‘
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i Sound Plug-n
Default Sound Azeign...

i~ Controller Default

Set Defaults. .. Restore Ta Factory Seftings. ‘

ok Cancel

Figure 4-24: The Animation panel includes settings for
displaying Key Brackets.

The Local Center During Animate option causes all objects to be animated about their local
centers. Turning this option off enables animations about other centers (such as screen and
world).

The MIDI Time Slider Controls include an On option and a Setup button. The Setup button
opens the MIDI Time Slider Control Setup dialog box shown in Figure 4-25. When this control
is set up, you can control an animation using a MIDI device.
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Figure 4-25: The MIDI Time Slider
Control Setup dialog box lets you set up
specific notes to start, stop, and step
through an animation.

You can use the Animation panel to assign a new Sound Plug-In to use, as well as to set the
default values of all animation controllers. Clicking the Set Defaults button opens the Set
Controller Defaults dialog box. This dialog box includes a list of all the controllers and a Set
button. When you select a controller and click the Set button, another dialog box appears
with all the values for that controller.

- Cross- You can learn more about specific controllers in Chapter 31, “Animating with Constraints and
| Reference Controllers”

Inverse Kinematics preferences

The Inverse Kinematics panel includes Positional, Rotational, and Iteration thresholds for
both Applied IK and Interactive IK.

|, grt;ss- \ To learn more about Applied IK and Interactive IK, see Chapter 37, “Using Inverse Kinematics.”
eference

Gizmos preferences

Gizmos are controllers that show up in the viewports and provide an interactive way to trans-
form objects. The Gizmos panel of the Preference Settings dialog box includes settings for
turning the Transform Gizmos on and off. You can also set the size of the Move, Rotate, and
Scale gizmos.

- Cross- See Chapter 10, “Transforming Objects —Translate, Rotate, and Scale” for more detail on
| Reference Transform Gizmo preferences.

MAXScript preferences

Settings for working with MAXScript are included in the MAXScript panel. These commands
include options for loading Startup scripts, controlling the Macro Recorder, selecting the font
used in the MAXScript window, and setting the amount of memory to use.
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- Cross- Check out Chapter 48, “Automating with MAXScript” for more on MAXScript commands and
| Reference preferences.

Radiosity preferences

The Radiosity panel includes settings that determine how radiosity is processed, whether
advanced lighting options are saved with the scene file, and whether Reflectance and
Transmittance are displayed in the Material Editor. You can also specify whether radiosity
is displayed in the viewports. You can also disable advanced lighting warnings.

- Cross- Check out Chapter 29, “Advanced Lighting and Radiosity,” for greater detail on Radiosity
| Reference preferences.

mental ray preferences

The mental ray panel includes settings that determine how the mental ray rendering engine
acts. Using this panel, you can enable mental ray extensions, cause brackets to be shown as
the renderer progresses, and clear the frame before rendering. Additional settings are avail-
able for handling errors and logs.

|, grt;ss- \ Check out Chapter 44, “Raytracing and mental ray,” for more detail on the mental ray renderer.
eference

Summary

You can customize the Max interface in many ways. Most of these customization options are
included under the Customize menu. In this chapter, you learned how to use this menu and
its commands to customize many aspects of the interface. Customizing makes the Max inter-
face more efficient and comfortable for you.

Specifically, this chapter covered the following topics:

4 Using the Customize User Interface dialog box to customize keyboard shortcuts,
toolbars, quadmenus, menus, and colors

4 Customizing buttons on the Modify and Utility panels
4+ Saving and loading custom interfaces

4+ Configuring paths

4 Setting system units

4+ Setting preferences

The next part is Part II, “Working with Objects.” The first chapter covers the primitive objects
and gets some objects into a scene for you to work with.

+ o+ 0+
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Creating and
Editing Primitive
Objects

So what exactly did the Romans use to build their civilization? The
answer is lots and lots of basic blocks. The basic building blocks
in Max are called primitives. You can use these basic primitives to
start any modeling job. After you create a primitive, you can then
bend it, stretch it, smash it, or cut it to create new objects, but for
now, we focus on using primitives in their default shape.

This chapter covers the basics of primitive object types and intro-
duces the various primitive objects, including how to accurately cre-
ate and control them. You also use these base objects in the coming
chapters to learn about selecting, cloning, grouping, and transforming.

Modeling is covered in depth in Part III, but first you need to learn
how to create some basic blocks and move them around. Later, you
can work on building a civilization. I'm sure Rome would be jealous.

Creating Primitive Objects

Max is all about creating objects and scenes, so it’s appropriate that
one of the first things to learn is how to create objects. Although you
can create complex models and objects, Max includes many simple,
default geometric objects called primitives that you can use as a
starting point. Creating these primitive objects can be as easy as
clicking and dragging in a viewport.

Using the Create panel

The creation of all default Max objects, such as primitive spheres,
shapes, lights, and cameras, starts with the Create panel (or the
Create menu, which leads to the Create panel). This panel is the first
panel in the Command Panel, indicated by an icon of an arrow point-
ing to a star.

Of all the panels in the Command Panel, only the Create panel (see
Figure 5-1) includes both categories and subcategories. After you
click the Create tab in the Command Panel, seven category icons are
displayed. From left to right, they are Geometry, Shapes, Lights,
Cameras, Helpers, Space Warps, and Systems.

CHAPTER

¢+ 0+ o+
In This Chapter

Creating primitive
objects

Naming objects and
setting object colors

Using creation methods

Setting object
parameters

Exploring the various
primitive types

+ + + +
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When you select the Geometry button (which has an icon of a sphere on it), a drop-
D down list with several subcategories appears directly below the category icons. The
first available subcategory is Standard Primitives. When you select this subcategory, several
text buttons appear that enable you to create some simple primitive objects.

/ Note The second subcategory is called Extended Primitives. It also includes primitive objects.
. 5

Create panel

Command Panel 1
| @ 5 @@ T
|0 & ¥ & o+ %l+— Category icons

- Object Type
Autolrid [T Schategory

Box Cone drop'dOWn ||St
Sphere GeoSphere
Cylinder Tube
Torus Pyramid
Teapot Plane

= N s

{

Figure 5-1: The Create panel includes
categories and subcategories.

I

l

As an example, click the button labeled Sphere (not to be confused with the Geometry
category, which has a sphere icon). Several rollouts appear at the bottom of the Command
Panel — these rollouts for the Sphere primitive object include Name and Color, Creation
Method, Keyboard Entry, and Parameters. The rollouts for each primitive are slightly differ-
ent, as well as the parameters within each rollout.

If you want to ignore these rollouts and just create a sphere, simply click and drag within one
of the viewports, and a sphere object appears. Figure 5-2 shows the new sphere and its
parameters.

When an object button, such as the Sphere button, is selected, it turns dark yellow. This color
change reminds you that you are in creation mode. Clicking and dragging within any viewport
creates an additional sphere. While in creation mode, you can create many spheres by click-
ing and dragging several times in one of the viewports. To get out of creation mode, right-
click in the active viewport and click the Select Object button or one of the transform buttons
on the main toolbar.
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Figure 5-2: You can create primitive spheres easily by dragging in a viewport.

%@s@@;mw,;&awmmm;-@a}&l

Using the Create menu

The Create menu offers quick access to the buttons in the Create panel. All the objects that
you can create using the Create panel you can access using the Create menu. Selecting an
object from the Create menu opens the Create panel and automatically selects the corre-
sponding button. You still need to click and drag in the viewport to create the object.

\ New to 3ds max 6 is the fact that almost all Create panel objects have a corresponding menu
command found in the Create menu.

Naming and renaming objects

Every object in the scene can have both a name and color assigned to it. Each object is given
a default name and random color when first created. The default name is the type of object
followed by a number. For example, when you create a sphere object, Max labels it “Sphere(1.”
These default names aren’t very exciting and can be confusing if you have many objects. You
can change the object’s name at any time by modifying the Name field in the Name and Color
rollout of the Command Panel.
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- Cross-

g Names and colors are useful for locating and selecting objects, as you find out in Chapter 6,
eference

“Selecting Objects and Setting Object Properties.”

The Tools => Rename menu command opens a dialog box that lets you change the object
name of several objects at once. The Rename Objects dialog box, shown in Figure 5-3, lets
you set the Base Name along with a Prefix, a Suffix, or a number. These new names can be
applied to the selected objects or to the specific objects that you pick from the Select Objects

dialog box.
[& Rename Objects Figure 5-3: The Rename Objects dialog box can rename
& Selected £~ Pick several objects at once.

[V Base Mame: [structure

¥ Piefic e
¥ Remove First: [0 ﬂ Digits

[ Suffis: [5fter
¥ Remove Last [0 g Digits

¥ Numbered
Base Number. [2 =l
Step: 1 g

Rename |

Assigning colors

The object color is shown in the color swatch to the right of the object name. This color is
the color that is used to display the object within the viewports and to render the object if a
material isn’t applied. To change an object’s color, just click the color swatch next to the
Name field to make the Object Color dialog box appear. This dialog box, shown in Figure 5-4,
lets you select a different color or pick a custom color.

‘Object Color 18]

Basic Colars; #® 3ds max palette € AutoCAD ACI palette

Custom Colors:

ANEEEEEEEEE e | serect

Add Cugtom Colors. . | By Object E— e by Col or
7 s . button
sign R andam Colars Current Color: - Ok Cancel

Figure 5-4: You use the Object Color dialog
box to define the color of objects displayed
in the viewports.
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The Object Color dialog box includes the standard 3ds max palette and the AutoCAD ACI
palette. The AutoCAD palette has many more colors than the Max palette, but the Max palette
allows a row of custom colors. Above the Cancel button is the Select by Color button. Click
this button to open the Select Objects dialog box where you can select all the objects that
have a certain color.

With the Object Color dialog box, if the Assign Random Colors option is selected, then a ran-
dom color from the palette is chosen every time a new object is created. If this option is not
selected, the color of all new objects is the same until you choose a different object color.

Making objects different colors allows you to more easily distinguish between two objects for
selection and transformation.

The Object Color dialog box also includes a button that toggles between By Layer and By
Objects. Using this button, you can cause objects to accept color according to their object
definition or based on the layer of which they are a part.

You can select custom colors by clicking the Add Custom Colors button. This button opens a
Color Selector dialog box, shown in Figure 5-5. Selecting a color and clicking the Add Color
button adds the selected color to the row of Custom Colors in the Object Color palette. You
can also open the Color Selector by clicking on the Current Color swatch. The current color
can then be dragged to the row of Custom Colors.

You can fill the entire row of Custom Colors by clicking repeatedly on the Add Color button.

e
g

y

Color Selector: Add Color
Hue Whiteness

( pec S ]
creer: I |

Blue:

e T [~ :|
| —
vate: I |77 2|

Add Calor Beset

Figure 5-5: The Color Selector dialog box lets you
choose new custom colors.
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The Color Selector dialog box defines colors using the RGB (red, green, and blue) and HSV
(hue, saturation, and value) color systems. Another way to select colors is to drag the cursor
around the rainbow palette to the left. After you find the perfect custom color to add to the
Object Color dialog box, click the Add Color button. This custom color is then available wher-
ever the Object Color dialog box is opened.

Object colors are also important because you can use them to select and filter objects. For
example, the Selection Floater (open by choosing Tools = Selection Floater) includes a Sort
by Color setting. You can also choose Edit = Select by => Color menu (or click the Select by

Color button) to select only objects that match a selected color.
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You can set objects to display an object’s default color or its Material Color. These options are

o in the Display Color rollout under the Display panel (the fifth tab from the left in the
Command Panel with an icon of a monitor). You can set them differently for Wireframe and
Shaded views.

Using the Color Clipboard

The object color is one of the first places where colors are encountered, but it certainly won’t
be the last. If you find a specific color that you like and want to use elsewhere, you can use
the Color Clipboard utility to carry colors to other interfaces. You can access this utility using
the Tools => Color Clipboard menu command, which opens the Utilities panel, as shown in
Figure 5-6.

| Command Panel X,

w| P &) @@ T|
[Huliile Selected J = Color Clipboard

= o - -

Mare. Sets E

Aizset Browser | ’—‘ -
Color Clipboard
L Meaus |

Figure 5-6: The Color Clipboard utility
offers a way to transport colors.

When selected, the Color Clipboard appears as a rollout in the Utilities panel and includes
four color swatches. These color swatches can be dragged to other interfaces like the
Material Editor. Clicking on any of these swatches launches the Color Selector. The New
Floater button opens a floatable Color Clipboard that holds 12 colors, shown in Figure 5-7.
Using this clipboard, you can open and save color configurations. The files are saved as
Color Clipboard Files with the .ccb extension.

Color Clipboard =) 1 Figure 5-7: The Color Clipboard floating palette can

[ _| | hold12colors.
_ /e
C e |

Open | Save ‘SaveAs
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Using different creation methods

You actually have a couple of ways to create primitive objects by dragging in a viewport. With
the first method, the first place you click sets the object’s initial position. You then need to
drag the mouse to define the object’s first dimension and then click again to set each addi-
tional dimension, if needed. Primitive objects with a different number of dimensions require a
different number of clicks and drags.

For example, a sphere is one of the simplest objects to create. To create a sphere, click in a
viewport to set the location of the sphere’s center, drag the mouse to the desired radius, and
release the mouse button to complete. A Box object, on the other hand, requires a click and
drag move to define the base (width and depth), and another drag and click again to set the
height. If you ever get lost when defining these dimensions, check the Prompt Line to see
what dimension the interface expects next.

When you click a primitive object button, the Creation Method rollout appears and offers
different methods for creating the primitives. For example, click the Sphere button, and the
Creation Method rollout displays two options: Edge and Center. When you choose the Edge
method, the first viewport click sets one edge of the sphere, and dragging and clicking again
sets the diameter of the sphere. The default Center creation method defines the sphere’s cen-
ter location; dragging sets the sphere’s radius. The creation method for each primitive can be
different. For example, the Box primitive object has a creation method for creating perfect
cubes. Table 5-1 shows the number of clicks required to create an object and the creation
methods for each primitive object.

If you're dragging to create a primitive object and halfway through its creation you change
.. your mind, you can right-click to eliminate the creation of the object.

4
Table 5-1: Primitive Object Creation Methods
Number of Viewport  Default Creation Other Creation

Primitive Object Clicks to Create Method Method

ﬁ Box 2 Box Cube

‘ Cone 3 Center Edge

0 Sphere 1 Center Edge

0 GeoSphere 1 Center Diameter

ﬁ Cylinder 2 Center Edge

ﬁ Tube 3 Center Edge

Continued
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Table 5-1 (continued)

Number of Viewport  Default Creation Other Creation

Primitive Object Clicks to Create Method Method
e Torus 2 Center Edge
0 Pyramid 2 Base/Apex Center
L4 Teapot 1 Center Edge
E Plane 1 Rectangular Square
# Hedra 1 - -

@ Torus Knot 2 Radius Diameter
g ChamferBox 3 Box Cube
g ChamferCyl 3 Center Edge
6 OilTank 3 Center Edge

6 Capsule 2 Center Edge

G Spindle 3 Center Edge
ﬁ L-Ext 3 Corners Center
@ Gengon 3 Center Edge
@‘ C-Ext 3 Corners Center
g RingWave 2 - -

Hose 2 - -
ﬁ Prism 3 Base/Apex Isosceles
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Some primitive objects, such as the Hedra, RingWave, and Hose, don't have any creation
s methods.

Using the Keyboard Entry rollout for precise dimensions

When creating a primitive object, you can define its location and dimensions by clicking in a
viewport and dragging, or you can enter precise values in the Keyboard Entry rollout, located
in the Create panel. Within this rollout, you can enter the offset XYZ values for positioning the
origin of the primitive and the dimensions of the object. The offset values are defined relative
to the active construction plane that is usually the Home Grid.

When all the dimension fields are set, click the Create button to create the actual primitive.
You can create multiple objects by clicking the Create button several times. After a primitive
is created, altering the fields in the Keyboard Entry rollout has no effect on the current
object, but you can always use the Undo feature to try again.

Altering object parameters

The final rollout for all primitive objects is the Parameters rollout. This rollout holds all the
various settings for the object. Compared to the Keyboard Entry rollout, which you can use
only when creating the primitive, you can use the Parameters rollout to alter the primitive’s
parameters before or after the creation of the object. For example, increasing the Radius
value after creating an object makes an existing sphere larger.

The parameters are different for each primitive object, but you can generally use them to
control the dimensions, the number of segments that make up the object, and whether the
object is sliced into sections. You can also select the Generate Mapping Coordinates option
(which automatically creates material mapping coordinates that are used to position maps).

After you deselect an object, the Parameters rollout disappears from the Create tab and
- moves to the Modify tab. You can make future parameter adjustments by selecting an object
and clicking the Modify tab.

Recovering from mistakes and deleting objects

Before going any further, you need to be reminded how to undo the last action with the Undo
menu command. The Undo (Ctrl+Z) menu command will undo the last action, whether it’s
creating an object or changing a parameter. The Redo (Ctrl+Y) menu command lets you redo
an action that was undone.

You can set the levels of undo in the Preference Settings dialog box. If you right-click on either
the Undo or Redo buttons on the main toolbar, a list of recent actions is displayed. You can
select any action from this list to be undone.

The Edit => Delete menu command removes the selected object (or objects) from the scene.
(The keyboard shortcut for this command is, luckily, the Delete key, because anything else
would be confusing.)
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Tutorial: Exploring the Platonic solids

Among the many discoveries of Plato, an ancient Greek mathematician and philosopher, were
the mathematical formulas that defined perfect geometric solids. A perfect geometric solid is
one that is made up of polygon faces that are consistent throughout the object. The five
solids that meet these criteria have come to be known as the Platonic solids.

Using Max, you can create and explore these interesting geometric shapes. Each of these
shapes is available as a primitive object using the Hedra primitive object. The Hedra primi-
tive object is one of the Extended Primitives.

To create the five Platonic solids as primitive objects, follow these steps:

1.

Open the Create panel, click the Geometry category button, and select Extended
Primitives from the subcategory drop-down list. Click the Hedra button to enter Hedra
creation mode, or select the Create = Extended Primitives = Hedra menu command.

. Click in the Top viewport, and drag to the left to create a simple Tetrahedron object.

After the object is created, you can adjust its settings by altering the settings in the
Parameters rollout.

. Select the Tetra option in the Parameters rollout, set the P value in the Family Parameters

section to 1.0, and enter a value of 50 for the Radius. Be sure to press the Enter key after
entering a value to update the object. Enter the name Tetrahedron in the Object Name
field.

. Click and drag again in the Top viewport to create another hedra object. In the

Parameters rollout, select the Cube/Octa option, and enter a value of 1.0 in the Family
Parameter’s P field and a value of 50 in the Radius field. Name this object Octagon.

. Drag in the Top viewport to create another object. The Cube/Octa option is still

selected. Enter a value of 1.0 in the Family Parameter’s Q field this time, and set the
Radius to 50. Name this object Cube.

. Drag in the Top viewport again to create the fourth hedra object. In the Parameters

rollout, select the Dodec/Icos option, enter a value of 1.0 in the P field, and set the
Radius value to 50. Name the object Icosahedron.

. Drag in the Top viewport to create the final object. With the Dodec/Icos option set,

enter 1.0 for the Q value, and set the Radius to 50. Name this object Dodecahedron.

. To get a good look at the objects, click the Perspective viewport, press the Zoom

Extents button, and maximize the viewport by clicking the Min/Max Toggle (or press
Alt+W) in the lower-right corner of the window.

Figure 5-8 shows the five perfect solid primitive objects. Using the Modify panel, you can
return to these objects and change their parameters to learn the relationships between them.
Later in this chapter, you can read about the Hedra primitive in greater detail.
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Figure 5-8: The octagon, cube, tetrahedron, icosahedron, and dodecahedron objects;
Plato would be amazed.

Exploring the Primitive Object Types

In the Create panel are actually two different subcategories of primitives: Standard Primitives
and Extended Primitives. These primitives include a diverse range of objects from simple
boxes and spheres to complex torus knots. You can create all these primitives from the
Create panel.

Standard Primitives

The Standard Primitives include many of the most basic and most used objects, including
boxes, spheres, and cylinders. Figure 5-9 shows all the Standard Primitives.

Box

You can use the Box primitive to create regular cubes and boxes of any width, length, and
height. Holding down the Ctrl key while dragging the box base creates a perfect square for
the base. To create a cube, select the Cube option in the Creation Method rollout. A single
click and drag completes the cube.

The Length, Width, and Height Segment values indicate how many polygons make up each
dimension. The default is only one segment.
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Figure 5-9: The Standard Primitives: Box, Sphere, Cylinder, Torus,
Teapot, Cone, GeoSphere, Tube, Pyramid, and Plane

Sphere
Spheres appear everywhere from sports balls to planets in space. Spheres are also among
the easiest primitives to create. After clicking the Sphere button, simply click and drag in a
viewport.

In the Parameters rollout, the Segments value specifies the number of polygons that make
up the sphere. The higher the number of segments, the smoother the sphere is. The default
value of 32 produces a smooth sphere, and a value of 4 actually produces a diamond-shaped
object. The Smooth option lets you make the sphere smooth or faceted. Faceted spheres are
useful for identifying faces for modifications. Figure 5-10 shows five spheres. The one on the
left has 32 Segments and the Smooth option turned on. The remaining spheres have the
Smooth option disabled with Segment values of 32, 16, 8, and 4.

(L

Figure 5-10: Sphere primitives of various Segment values with the
Smooth option turned on and off

The Parameters rollout also lets you create hemispheres. The hemisphere shape is set by the
Hemisphere value, which can range from 0.0 to 1.0, with 0 being a full sphere and 1 being
nothing at all. (A value of 0.5 would be a perfect hemisphere.) With the Hemisphere value
specified, you now have two options with which to deal with the unused polygons that make
up the originating sphere: the Chop option, which removes the unused polygons, and the
Squash option, which retains the polygons but “squashes” them to fit in the hemisphere
shape.

Figure 5-11 shows two hemispheres with Hemisphere values of 0.5. The Edged Faces option
was enabled in the Viewport Configuration dialog box so you could see the polygon faces.
The left hemisphere was created using the Chop option, and the right hemisphere was cre-
ated with the Squash option. Notice how many extra polygons are included in the right
hemisphere.
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Figure 5-11: Creating hemispheres
with the Chop and Squash options

The Slice option enables you to dissect the sphere into slices (like segmenting an orange).
The Slice From and Slice To fields accept values ranging from 0 to 360 degrees. Figure 5-12
shows three spheres that have been sliced. Notice that, because the Segments value hasn’t
changed, all slices have the same number of faces.

/Note You can use the Slice feature on several primitives, including the sphere, cylinder, torus,
’.-"

Tip

- cone, tube, oiltank, spindle, chamfercyl, and capsule.

Figure 5-12: Using the Slice option to create sphere slices

The Base to Pivot parameter determines whether the position of the pivot point is at the bot-
tom of the sphere or at the center. The default (with the Base to Pivot setting not enabled)
sets the pivot point for the sphere at the center of the sphere.

Cylinder

You can use a cylinder in many places —for example, as a pillar in front of a home or as a car
driveshaft. To create one, first specify a base circle and then a height. The default number of
sides is 18, which produces a smooth cylinder. Height and Cap Segments values define the
number of polygons that make up the cylinder sides and caps. The Smooth and Slice options
work the same as they do with a sphere (see the preceding section).

If you don’t plan on modifying the ends of the cylinder, make the Cap Segments equal to 1 to
s keep the model complexity down.
& ,/
Torus

A Torus (which is the mathematical name for a “doughnut”) is a ring with a circular cross sec-
tion. To create a Torus, you need to specify two radii values. The first is the value from the
center of the Torus to the center of the ring; the second is the radius of the circular cross
section. The default settings create a Torus with 24 segments and 12 sides. The Rotation and
Twist options cause the sides to twist a specified value as the ring is circumnavigated.
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Figure 5-13 shows some sample Toruses with a Smooth setting of None. The first three have
Segments values of 24, 12, and 6. The last two have Twist values of 90 and 360. The higher the
number of segments, the rounder the Torus looks when viewed from above. The default of 24
is sufficient to create a smooth Torus. The number of sides defines the circular smoothness
of the cross section.

Figure 5-13: Using the Segments and Twist options on a Torus

The Parameters rollout includes settings for four different Smooth options. The All option
smoothes all edges, and the None option displays all polygons as faceted. The Sides
option smoothes edges between sides, resulting in a Torus with banded sides. The
Segment option smoothes between segment edges, resulting in separate smooth sections
around the Torus.

The Slice options work with a Torus the same way as they do with the sphere and cylinder
objects (see the section “Sphere” earlier in this chapter).

Teapot

Okay, let’s all sing together, “I'm a little teapot, short and stout. . . .” The teapot is another
object that, like the sphere, is easy to create. Within the Parameters rollout, you can specify
the number of Segments, whether the surface is smooth or faceted, and which parts to dis-
play, including Body, Handle, Spout, and Lid.

/ Note You may recognize most of these primitives as standard shapes, with the exception of the
—

teapot. The teapot has a special place in computer graphics. In early computer graphics
development labs, the teapot was chosen as the test model for many early algorithms. It is
still included as a valuable benchmark for computer graphics programmers.

Cone

The Cone object, whether used to create ice cream cones or megaphones, is created exactly
like the cylinder object except that the second cap can have a radius different from that of the
first. You create it by clicking and dragging to specify the base circle, dragging to specify the
cone’s height, and then dragging again for the second cap to create a Cone.

In addition to the two cap radii and the Height, parameter options include the number of
Height and Cap Segments, the number of Sides, and the Smooth and Slice options.

GeoSphere

The GeoSphere object is a sphere that is created using fewer polygon faces than the standard
Sphere object. This type of sphere spreads the polygon faces, which are all equal in size,
around the object, instead of concentrating them on either end like the normal Sphere
object. This makes the GeoSphere object easier to model while using less memory. One
reason for this is that a GeoSphere uses triangle faces instead of square faces.
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In the Parameters rollout are several Geodesic Base Type options, including Tetra, Octa, and
Icosa. The Tetra type is based on a four-sided tetrahedron, the Octa type is based on an
eight-sided Octahedron, and the Icosa type is based on the 20-sided Icosahedron. Setting the
Segment value to 1 produces each of these Hedron shapes. Each type aligns the triangle faces
differently.

GeoSpheres also have the same Smooth, Hemisphere, and Base to Pivot options as the Sphere
primitive. Selecting the Hemisphere option changes the GeoSphere into a hemisphere, but
you have no additional options like Chop and Squash. GeoSphere primitives do not include
an option to be sliced.

Tutorial: Comparing Spheres and GeoSpheres

To prove that GeoSpheres are more efficient than Sphere objects, follow these steps:
1. Create a normal Sphere, and set its Segment value to 4.

2. Next to the Sphere object, create a GeoSphere object with a Tetra Base Type and the
number of Segments set to 4.

3. Create another GeoSphere object with the Octa Base Type and 4 Segments.
4. Finally, create a GeoSphere with the Icosa Base Type and 4 Segments.

Figure 5-14 shows these spheres as a comparison. The normal sphere, shown to the left,
looks like a diamond, but the GeoSpheres still resemble spheres. Notice that the Icosa type
GeoSphere, shown in the lower right, produces the smoothest sphere.

Figure 5-14: Even with a similar number of segments, GeoSpheres
are much more spherical.

Tube

The Tube primitive is useful for any time you need a pipe object. You can also use it to create
ring-shaped objects that have rectangular cross sections. Creating a Tube object is very simi-
lar to the Cylinder and Cone objects. Tube parameters include two radii for the inner and
outer tube wall. Tubes also have the Smooth and Slice options.

Pyramid

Pyramid primitives are constructed with a rectangular base and triangles at each edge that
rise to meet at the top, just like they made in Egypt, only easier. Two different creation meth-
ods are used to create the base rectangle. With the Base/Apex method, you create the base
by dragging corner to corner, and with the Center method, you drag from the base center to
a corner.
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The Width and Depth parameters define the base dimensions, and the Height value deter-
mines how tall the pyramid is. You can also specify the number of segments for each
dimension.

Plane

The Plane object enables you to model the Great Plains (good pun, eh?). The Plane primitive
creates a simple plane that looks like a rectangle, but it includes Multiplier parameters that
let you specify the size of the plane at render time. This feature makes working in a viewport
convenient because you don’t have to worry about its actual dimensions.

The Plane primitive includes two creation methods: Rectangle and Square. The Square
method creates a perfect square in the viewport when dragged. You can also define the
Length and Width Segments, but the real benefits of the Plane object are derived from the
use of the Render Multipliers.

The Scale Multiplier value determines how many times larger the plane should be at render
time. Both Length and Width are multiplied by equal values. The Density Multiplier specifies
the number of segments to produce at render time.

Extended Primitives

Access the Extended Primitives by selecting Extended Primitives in the subcategory drop-
down list in the Create panel. These primitives aren’t as generic as the Standard Primitives
but are equally useful (see Figure 5-15).

Figure 5-15: The Extended Primitives: Hedra, ChamferBox, OilTank,
Spindle, Gengon, RingWave, Hose, Torus Knot, ChamferCyl, Capsule,
L-Ext, C-Ext, and Prism

Hedra

Hedras, or Polyhedra, form the basis for a class of geometry defined by fundamental mathe-
matical principles. In addition to Plato, Johannes Kepler used these Polyhedra as the basis
for his famous “Harmony of the Spheres” theory. The Hedra primitives (shown in the first
tutorial of this chapter) available in Max are Tetrahedron, Cube/Octahedron,
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Dodecahedron/Icosahedron, and two Star types called Starl and Star2. From these basic
Polyhedra, you can create many different variations.

The Family section options determine the shape of the Hedra. Each member of a Hedra pair is
mathematically related to the other member. The Family Parameters include P and Q values.
These values change the Hedra between the two shapes that make up the pair. For example, if
the family option is set to Cube/Octa, then a P value of 1 displays an Octagon, and a Q value
of 1 displays a Cube. When both P and Q values are set to 0, the shape becomes an intermedi-
ate shape somewhere between a Cube and an Octagon. Because the values are interrelated,
only one shape of the pair can have a value of 1 at any given time. Both P and Q cannot be set
to 1 at the same time.

Figure 5-16 shows each of the basic Hedra Families in columns from left to right: Tetra,
Cube/Octa, Dodec/Icos, Starl, and Star2. The top row has a P value of 1 and a Q value of 0, the
middle row has both P and Q set to 0, and the bottom row sets P to 0 and Q to 1. Notice that
the middle row shapes are a combination of the top and bottom rows.
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Figure 5-16: The Hedra Families with the standard shapes in the top
and bottom rows and the intermediate shapes in the middle row

The relationship between P and Q can be described in this manner: When the P value is set
to 1 and the Q value is set to 0, one shape of the pair is displayed. As the P value decreases,
each vertex becomes a separate face. The edges of these new faces increase as the value is
decreased down to 0.The same holds true for the Q value.

Altering the P and Q parameters can create many unique shapes. For each Hedra, try the fol-
lowing combinations: P=0,Q=0;P=1,Q=0;P=0,Q=1;P=05,Q=05;P=0.5,Q=0;
P =0, Q =0.5. These represent the main intermediate objects.

As the geometry of the objects changes, the Hedra can have as many as three different types
of polygons comprising the faces. These polygons are represented by the P, Q, and R Axis
Scaling values. Each type of face can be scaled, creating sharp points extending from each
face. If only one unique polygon is used for the faces, then only one Axis Scaling parameter is
active. The Reset button simply returns the Axis Scaling value back to its default at 100. For



178

Part Il + Working with Objects

example, using the R Axis Scaling value, pyramid shapes can be extended from each face
of a cube.

Figure 5-17 shows some results of using the Axis Scaling options. One of each family type has
been created and displayed in the top row for reference. The bottom row has had an axis
scaled to a value of 170. This setting causes one type of polygon face to be extended, thereby
producing a new shape.

<4

Figure 5-17: Hedras with extended faces, compliments of the Axis
Scaling option

The Vertices parameter options add more vertices and edges to the center of each extended
polygon. The three options are Basic, which is the default and doesn’t add any new informa-
tion to the Hedra; Center, which adds vertices to the center of each extended polygon; and
Center and Sides, which add both center vertices and connecting edges for each face that is
extended using the Axis Scaling options. With these options set, you can extend the polygon
faces at your own discretion.

Way at the bottom of the Parameters rollout is the Radius value.

ChamferBox

A chamfered object is an object whose edges have been smoothed out, so a ChamferBox
primitive is a box with beveled edges. The parameter that determines the amount of round-
ness applied to an edge is Fillet. In many ways, this object is just a simple extension of the
Box primitive.

The only additions in the Parameters rollout are two fields for controlling the Fillet dimension
and the Fillet Segments. Figure 5-18 shows a ChamferBox with Fillet values of 0, 5, 10, 20, and
30 and the Smooth option turned on.

Figure 5-18: A ChamferBox with progressively increasing Fillet values
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Cylindrical extended primitives

The Extended Primitives include several objects based on the Cylinder primitive that are very
similar. The only real differences are the shape of the caps at either end. These four similar
objects include the OilTank, Spindle, ChamferCyl, and Capsule. Figure 5-19 shows these simi-
lar objects side by side.

Figure 5-19: Several different cylindrical extended primitive objects exist, including: Oil Tank,
Spindle, ChamferCyl, and Capsule.

OilTank

OilTank seems like a strange name for a primitive. This object is essentially the Cylinder prim-
itive with dome caps like you would see on a diesel truck transporting oil. The Parameters
rollout includes an additional option for specifying the Cap Height. The Height value can be
set to indicate the entire height of the object with the Overall option or the height to the edge
of the domes using the Centers option. The only other new option is Blend, which smoothes
the edges between the cylinder and the caps. All cylindrical primitives can also be sliced just
like the sphere object.

Spindle

The Spindle primitive is the same as the OilTank primitive, except that the dome caps are
replaced with conical caps. All other options in the Parameters rollout are identical to the
OilTank primitive.

ChamferCyl

The ChamferCyl primitive is very similar to the ChamferBox primitive, only applied to a cylin-
der instead of a box. The Parameters rollout includes some additional fields for handling the
Fillet values.

Capsule

The Capsule primitive is a yet another primitive based on the cylinder, only this time with
hemispherical caps. This object resembles the OilTank primitive very closely. The only real
noticeable difference is in the border between the cylinder and caps.

Gengon

The Gengon primitive creates and extrudes regular polygons such as triangles, squares, and
pentagons. There is even an option to Fillet (or smooth) the edges. To specify which polygon
to use, enter a value in the Sides field.

/Note The Gengon menu command is missing from the Create > Extended Primitives menu, but
~~  you can still access it from the Create panel.
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Figure 5-20 shows five simple Gengons with different numbers of edges.

Figure 5-20: Gengon primitives are actually just extruded regular
polygons.

RingWave

The RingWave primitive is a specialized primitive that you can use to create a simple gear or
a sparkling sun. It consists of two circles that make up a ring. You can set the circle edges to
be wavy and even fluctuate over time. You can also use RingWaves to simulate rapidly
expanding gases that would result from a planetary explosion. If you're considering a
Shockwave effect, then you should look into using a RingWave primitive.

The Radius setting and the inner edge define the outer edge by the Ring Width. This ring can
also have a Height. The Radial and Height Segments and the number of Sides determine the
complexity of the object.

The RingWave Timing controls set the expansion values. The Start Time is the frame where
the ring begins at zero, the Grow Time is the number of frames required to reach its full size,
and the End Time is the frame where the RingWave object stops expanding. The No Growth
option prevents the object from expanding, and it remains the same size from the Start frame
to the End frame. The Grow and Stay option causes the RingWave to expand from the Start
Time until the Grow Time frame is reached, and then remain full-grown until the End Time.
The Cyclic Growth begins expanding the objects until the Grow Time is reached. It then starts
again from zero and expands repeatedly until the End Time is reached.

The last two sections of the Parameters rollout define how the inner and outer edges look
and are animated. If the Edge Breakup option is on, then the rest of the settings are enabled.
These additional settings control the number of Major and Minor Cycles, the Width Flux for
these cycles, and the Crawl Time, which is the number of frames to animate.

The Surface Parameters section includes an option for creating Texture Coordinates, which
are the same as mapping coordinates for applying textures. There is also an option to Smooth
the surface of the object.

Figure 5-21 shows five animated frames of a RingWave object with both Inner and Outer Edge
Breakup settings. Notice that the edges change over the different frames.

Figure 5-21: Five frames of a rapidly expanding and turbulent
Ring\Wave object
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Tutorial: Creating a pie
This tutorial provides a very different recipe for creating a pie using a RingWave object.

Although the RingWave object can be animated, you also can use it to create static objects
such as this pie, or a set of gears.

To create a pie using the RingWave object, follow these steps:

1. Select Create = Extended Primitives = RingWave and drag in the Top viewport to create
a RingWave object.

2. In the Parameters rollout, set the Radius to 115, the Ring Width to 90, and the Height
to 30.

3. In the RingWave Timing section, select the No Growth option. Then enable the Outer
Edge Breakup option, set the Major Cycles to 25, the Width Flux to 4.0, and the Minor
Cycles to 0.

4. Enable the Inner Edge Breakup option. Set the Major Cycles to 6, the Width Flux to 15,
and the Minor Cycles to 25 with a Width Flux of 10.

Figure 5-22 shows a nice pie object as good as Grandmother made. You can take this pie one
step further by selecting Modifiers &> Parametric Deformers => Taper to apply the Taper
modifier and set the Amount to 0.1.
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Figure 5-22: This pie object was created using the RingWave object.
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Torus Knot

A Torus Knot is similar to the Torus covered earlier, except that the circular cross-section fol-
lows a 3D curve instead of a simple circle. The method for creating the Torus Knot primitive
is the same as that for creating the Torus. The Parameters rollout even lets you specify the
base curve to be a circle instead of a knot. A knot is a standard, mathematically defined 3D
curve.

Below the Radius and Segment parameters are the P and Q values. These values can be used
to create wildly variant Torus Knots. The P value is a mathematical factor for computing how
the knot winds about its vertical axis. The maximum value is 25, which makes the knot resem-
ble a tightly wound spool. The Q value causes the knot to wind horizontally. It also has a max-
imum value of 25. Setting both values to the same number results in a simple circular ring.

Figure 5-23 shows some of the beautiful shapes that are possible by altering the P and Q val-
ues of a Torus Knot. These Torus Knots have these values: P = 3, Q = 2; the second has P = 1,
Q = 3; the third has P = 10, Q = 15; the fourth has P = 15, Q = 20; and the fifth has P = 25, Q = 25.

Figure 5-23: Various Torus Knots display the beauty of mathematics.

When the Base Curve is set to Circle, like those in Figure 5-23, the P and Q values become dis-
abled, and the Warp Count and Warp Height fields become active. These fields control the
number of ripples in the ring and their height. Figure 5-24 shows several possibilities. From
left to right, the settings are Warp Count = 5, Warp Height = 0.5; Warp Count = 10, Warp Height
= 0.5; Warp Count = 20, Warp Height = 0.5; Warp Count = 50, Warp Height = 0.5; and Warp
Count = 100, Warp Height = 0.75.

Figure 5-24: Torus Knots with a Circle Base Curve are useful for
creating impressive rings.

In addition to the Base Curve settings, you can also control several settings for the Cross
Section. The Radius and Sides values determine the size of the circular cross section and the
number of segments used to create the cross section. The Eccentricity value makes the circu-
lar cross section elliptical by stretching it along one of its axes. The Twist value rotates each
successive cross section relative to the previous one creating a twisting look along the object.
The Lumps value sets the number of lumps that appear in the Torus Knot, and the Lump
Height and Offset values set the height and starting point of these lumps.
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The Smooth options work just like those for the Torus object by smoothing the entire object,
just the sides, or none. You can also set the U and V axis Offset and Tiling values for the map-
ping coordinates.

L-Ext

The L-Ext primitive stands for L-Extension. You can think of it as two rectangular boxes that
are connected at right angles to each other. To create an L-Ext object, you need to first drag
to create a rectangle that defines the overall area of the object. Next you drag to define the
Height of the object, and, finally, you drag to define the width of each leg.

The Parameters rollout includes dimensions for Side and Front Lengths, Side and Front
Widths, and the Height. You can also define the number of Segments for each dimension.

C-Ext

The C-Ext primitive is the same as the L-Ext primitive with an extra rectangular box. The C
shape connects three rectangular boxes at right angles to each other.

The Parameters rollout includes dimensions for Side, Front, and Back Lengths and Widths,
and the Height. You can also define the number of Segments for each dimension. These
primitives are great if your name is Clive Logan or Carrie Lincoln.

Prism

The Prism primitive is essentially an extruded triangle. If you select the Base/Apex creation
method, then each of the sides of the base triangle can have a different length. With this cre-
ation method, the first click in the viewport sets one edge of the base triangle, the second click
sets the opposite corner of the triangle that affects the other two edges, and the final click sets
the height of the object.

The other creation method is Isosceles, which doesn’t let you skew the triangle before setting
the height.

Hose

The Hose primitive is a flexible connector that can be positioned between two other objects.
It acts much like a spring but has no dynamic properties. In the Hose Parameters rollout, you
can specify the Hose as a Free Hose or Bound to Object Pivots. If the Free Hose option is
selected, you can set the Hose Height. If the Bound to Object Pivots option is selected, then
two Pick Object buttons appear for the Top and Bottom objects. Once bound to two objects,
the hose stretches between the two objects when either is moved. You can also set the
Tension for each bound object.

For either the Bound Hose or Free Hose, you can set the number of Segments that make up
the hose; whether the flexible section is enabled; to smooth along the Sides, Segments, nei-
ther, or all; whether the hose is Renderable; and to Generate Mapping Coordinates for apply-
ing texture maps. If the flexible section is enabled, then you can set where the flexible section
Starts and Ends, the number of Cycles, and its Diameter.

You can also set the Hose Shape to Round, Rectangular, or D-Section. Figure 5-25 shows a flex-
ible hose object bound to two sphere objects.
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Figure 5-25: The Hose object flexes between its two bound objects.

Tutorial: Creating a bendable straw

If you've ever found yourself modeling a juice box (or drinking from a juice box and wonder-
ing, “How would I model this bendable straw?”), then this tutorial is for you. The nice part
about the Hose primitive it that once you've created the model, you can reposition the straw
and the bend changes as needed, just like a real straw.

To create a bendable straw, follow these steps:
1. Open the Bendable straw.max file from the Chap 05 directory on the CD-ROM.

This file includes two Tube primitives to represent the top and bottom portions of a
straw. I've oriented their pivot points so the Z-axis points toward where the Hose primi-
tive will go.

2. Select Create = Extended Primitives => Hose and drag in the Top viewport close to
where the two straws meet. Select the Bound to Object Pivots option, click on the Pick
Top Object button, and select the top Tube object. Then click on the Pick Bottom
Object button and select the bottom Tube object. This step positions the Hose object
between the two Tube pieces.

3. In the Hose Parameters rollout, set the Tension for both Tubes to 10.0. Set the
Segments to 40, the Starts value to 0, the Ends value to 100, the Cycles to 10, and the
Diameter to 40. Make sure the Renderable option is enabled and enable the Round
Hose option with a Diameter of 15.0.

Figure 5-26 shows the completed bendable straw created using a Hose primitive.
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Figure 5-26: Use the Hose primitive to connect two objects.

Modifying object parameters

Primitive objects provide a good starting point for many of the other modeling types. They
also provide a good way to show off parameter-based modeling.

All objects have parameters. These parameters help define how the object looks. For exam-
ple, consider the primitive objects. The primitive objects contained in Max are parametric.
Parametric objects are mathematically defined, and you can change them by modifying their
parameters. The easiest object modifications to make are simply changing these parameters.
For example, a sphere with a radius of 4 can be made into a sphere with a radius of 10 by sim-
ply typing a 10 in the Radius field. The viewports display these changes automatically when
you press the Enter key.

/ Note When an object is first created, its parameters are displayed in the Parameters rollout of the
.~ Create panel. As long as the object remains the current object, you can modify its parameters
using this rollout. After you select a different tool or object, the Parameters rollout is no longer

accessible from the Create panel. It can be found from then on under the Modify panel.

Tutorial: Filling a treasure chest with gems

I haven’t found many treasure chests lately, but if I remember correctly, they are normally filled
with bright, sparkling gems. In this tutorial, we fill the chest with a number of Hedra primitives
and alter the object properties in the Modify panel to create a diverse offering of gems.
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To create a treasure chest with many unique gems, follow these steps:

1.

G e W

Open the Treasure chest of gems.max file from the Chap 05 directory on the CD-ROM.

This file includes a simple treasure chest model.

. Select Create > Extended Primitives => Hedra to open the Extended Primitives subcategory

in the Create panel and select the Hedra button.

. Create several Hedra objects. The size of the objects doesn’t matter at this time.
. Open the Modify panel, and select one of the Hedra objects.

. Alter the values in the Parameters rollout to produce a nice gem.
6.

Repeat Step 5 for all Hedra objects in the chest.

Figure 5-27 shows the resulting chest with a variety of gems.

Every modeling type, whether it is an Editable Spline, a Compound Conform object, or a
NURBS Point curve, has parameters. These parameters, which you can modify, appear in
rollouts using the Modify panel.
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Figure 5-27: A treasure chest full of gems quickly created by altering object parameters
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Summary

Primitives are the most basic shapes and often provide a starting point for more ambitious
modeling projects. The two classes of primitives — Standard and Extended — provide a host
of possible objects. This chapter covered the following topics:

4+ The basics of creating primitives by both dragging and entering keyboard values
4+ How to name objects and set and change the object color

4 The various creation methods for all the primitive objects

4 The various primitives in both the Standard and Extended subcategories

4 The possible parameters for each of the primitive objects

Now that you know how to create objects, you can focus on selecting them after they’re cre-
ated, which is what the next chapter covers. You can select objects in numerous ways.

+ o+ ¢






Selecting Objects
and Setting Object
Properties

N ow that you've learned how to create objects and had some
practice, you’'ve probably created more than you really need. To
eliminate, move, or change the look of any objects, you first have to
know how to select the object. Doing so can be tricky if the viewports
are all full of objects lying on top of one another. Luckily, Max offers
several selection features that make looking for a needle in a
haystack easier.

Max offers many different ways to select objects. You can select by
name, color, type, and even material. You can also use selection fil-
ters to make only certain types of objects selectable. And after you've
found all the objects you need, you can make a selection set, which
will allow you to quickly select a set of objects by name. Now where
is that needle?

All objects have properties that define their physical characteristics,
such as shape, radius, and smoothness, but objects also have proper-
ties that control where they are located in the scene, how they are
displayed and rendered, and what their parent objects are. These
properties have a major impact on how you work with objects; under-
standing them can make objects in a scene easier to work with.

Selecting Objects

Max includes several methods for selecting objects —the easiest being
simply clicking on the object in one of the viewports. Selected objects
turn white and are enclosed in brackets called selection brackets.

In addition to turning white and displaying selection brackets, several
options allow you to mark selected objects. You can find these
options in the Viewport Configuration dialog box (which you access
with the Customize > Viewport Configuration menu command); they
include selection brackets (keyboard shortcut, J) and edged faces
(F4). Either or both of these options can be enabled, as shown in
Figure 6-1. Another way to detect the selected object is that the
object’s axes appear at the object’s pivot point.
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Caution The Viewport Configuration dialog box also includes an option to Shade Selected Faces (F2),

Tip

but this option shades only selected subobject faces.

Figure 6-1: Selected objects can be highlighted with selection
brackets (left), edged faces (middle), or both (right).

With many objects in a scene, clicking directly on a single object, free from the others, can
be difficult, but persistence can pay off. If you continue to click an object that is already
selected, then the object directly behind the object you clicked on is selected. For example,
if you have a row of spheres lined up, you can select the third sphere by clicking three times
on the first object.

In complicated scenes, finding an object is often much easier if it has a relevant name. Be
sure to name your new objects using the Name and Color rollout.

Selection filters

Before examining the selection commands in the Edit menu, [ need to tell you about
Selection Filters. With a complex scene that includes geometry, lights, cameras, shapes, and
so on, selecting the exact object that you want can be difficult. Selection filters can simplify
this task.

A selection filter specifies which types of objects can be selected. The Selection Filter drop-
down list is located on the main toolbar. Selecting Shapes, for example, makes only shape
objects available for selection. Clicking a geometry object with the Shape Selection Filter
enabled does nothing.

The available filters include All, Geometry, Shapes, Lights, Cameras, Helpers, and Space
Warps. If you're using Inverse Kinematics, you can also filter by Bone, IK Chain Object, and
Point.

The Combos option opens the Filter Combinations dialog box, shown in Figure 6-2. From this
dialog box, you can select combinations of objects to filter. These new filter combinations are
added to the drop-down list. For example, to create a filter combination for lights and cam-
eras, open the Filter Combinations dialog box, select Lights and Cameras, and click Add. The
combination is listed as LC in the Current Combinations section, and the LC option is added
to the drop-down list.
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Filter Combinations Figure 6-2: The Filter Combinations dialog box enables
~Create Conbinafon—  — Cunent Conbinations— | YOU tO create a custom selection filter.

[ Geometm LC

[ Shapes

Iv Lights

IV Cameras

™ Helpers

[ Space Warps

Add Delete

&l Class 1D

i~ Curent Class |D Filter

BlobMesh el

Add Delete

ok Cancel

The Filter Combinations dialog box also includes a list of additional objects. Using this list,
you can filter very specific object types, such as a Boolean object or a Box primitive. In fact,
the Bone, IK Chain Object, and Point filters that appear in the default main toolbar drop-down
list all come from this additional list.

Select buttons

On the main toolbar are several buttons used to select objects, shown in Table 6-1. The Select
Object button looks like the arrow cursor. The other three buttons select and transform
objects. They are Select and Move (W), Select and Rotate (E), and Select and Scale (R). The
final selection button is the Select and Manipulate button. With this button, you can select
and use special helpers such as sliders.

Table 6-1: Select Buttons

Description

Select Object (Q)

Select and Move (W)

Select and Rotate (E)

Select and Scale (R)

Select and Manipulate

SRR



192  Partil 4+ Working with Objects

- Cross- See Chapter 10, “Transforming Objects — Translate, Rotate, and Scale” for more details on the
| Reference Select and Transform buttons.

Selecting with the Edit menu

The Edit menu includes several convenient selection commands. The Edit => Select All
(Ctrl+A) menu command does just what you would think it does: It selects all objects in the
current scene of the type defined by the selection filter. The Edit => Select None (Ctrl+D) menu
command deselects all objects. You can also simulate this command by clicking in any view-
port away from all objects. The Edit = Select Invert (Ctrl+]) menu command selects all objects
defined by the selection filter that are currently not selected and deselects all currently
selected objects.

Choosing Edit = Select by = Color lets you click a single object in any of the viewports. All
objects with the same color as the one you selected are selected. Even if you already have an
object of that color selected, you still must select an object of the desired color. Be aware
that this is the object color and not the applied material color.

This command, of course, does not work on any objects without an associated color, such as
Space Warps.

Select by Name

Choosing Edit = Select by => Name opens the Select Objects dialog box, as shown in Figure 6-3.
Clicking the Select by Name button on the main toolbar, positioned to the right of the Select
Object button, or pressing the keyboard shortcut, H, can also open this dialog box.

Select Ohjects (2]
I ~Sort
& #lphabstical
E:DEI By Type
|_eve By Color
liah  BySize
mane
Lt - List Types
:‘D;; ¥ Geometry All
langue ¥ Shapes MHone
[v Lights Inwert
v Cameras
v Helpers
[V Space Warps
v Groupsdbssemblies
v xRefs
[v Bone Dbjects

~ Selection Sets

All ‘ Nane | Invert | -

[ Display Subtree [ Case Sensitive

[~ Select Subtres [ Select Dependants Select Cancel

Figure 6-3: The Select Objects dialog box displays all
objects in the current scene by name.
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You select objects by clicking their names in the list and then clicking the Select button. To
pick and choose several objects, hold down the Ctrl key while selecting. Holding down the
Shift key selects a range of objects.

An identical version of the Select Objects dialog box works in a modeless state and enables
o you to interact with the viewports behind the dialog box. This dialog box is called the
Selection Floater, and you can access it by choosing Tools <> Selection Floater.

You can also type an object name in the field above the name list. All objects that match the
typed characters are selected. The Sort options affect how the list is displayed. Selecting the
Sort by Size option sorts the objects by the number of faces. This is an easy way to find the
most complicated object in the scene.

Within the Select by Name text field, you can use wildcards to locate objects. Acceptable
.,_ wildcards include an asterisk (*) for multiple characters in a row and a question mark (?) for
4 single characters. For example, an entry of hedra* selects all objects beginning with “hedra,”
regardless of the ending.

The Display Subtree option includes all child objects in the list. By enabling the Select Subtree
option, you select all child objects along with their parent objects. The Select Dependents
option automatically selects all instances and references. The Case Sensitive option checks
the case of the letters typed in the name search field. If this option is not selected, then capital
letters are the same as their lowercase counterparts.

The Select Object dialog box isn’t subject to the selection filter because the object types
can be selected in the dialog box. Selection sets are also accessible from the Select Objects
dialog box.

Select by Region

The Edit => Region command lets you select from one of two different methods for selecting
objects in the viewport using the mouse. First, make sure that you're in select mode, and then
click away from any of the objects and drag over the objects to select. The first method for
selecting objects is Window Selection. This method selects all objects that are contained
completely within the dragged outline. The Crossing Selection method selects any objects
that are inside or overlapping the dragged outline. You can also access these two selection
methods via the Window Selection buttons on the main toolbar — Window and Crossing,
shown in Table 6-2.

If you can’t decide whether to use the Crossing or Window selection method, you can select
to use both. The General panel of the Preference Settings dialog box provides an option to
enable Auto Window/Crossing by Direction. When this option is enabled, you can select a
direction and the Crossing selection method is used for all selections that move from that
direction. The Window selection method is used for all selections that move from the oppo-
site direction. For example, if you select Left to Right for the Crossing selection method, then
moving from Left to Right uses the Crossing selection method and selecting from Right to
Left uses the Window selection method.

o
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Table 6-2: Window Selection Buttons

Description

Window

[:3 Crossing

You can also change the shape of the selection outline. The Selection Region button on the
main toolbar to the left of the Selection Filter drop-down list includes flyout buttons for
Rectangular, Circular, Fence, and Lasso Selection Regions, shown in Table 6-3.

Table 6-3: Shape-Shifting Selection Region Buttons

Button Description

;E:j; Rectangular

Circular

freess Fence
£
t Lasso

The Rectangular selection method lets you select objects by dragging a rectangular section
(from corner to corner) over a viewport. The Circular selection method selects objects within
a circle that grows from the center outward. The Fence method lets you draw a polygon-
shaped selection area by clicking at each corner. Simply double-click to finish the fenced
selection. The Lasso method lets you draw by freehand the selection area.

Pressing the Q keyboard shortcut selects the Select Object mode in the main toolbar, but
repeated pressing of the Q keyboard shortcut cycles through the selection methods.
Figure 6-4 shows each of the selection methods.

Figure 6-4: The drill's front is selected using the Rectangular, Circular, Fence, and Lasso
selection methods.



Chapter 6 4 Selecting Objects and Setting Object Properties

Selecting multiple objects

As you work with objects in Max, you’ll sometimes want to apply a modification or transform
to several objects at once. You can select multiple objects in several ways. With the Select by
Name dialog box open, you can choose several objects from the list using the standard Ctrl
and Shift keys. Holding down the Ctrl key selects or deselects multiple list items, but holding
down the Shift key selects all consecutive list items between the first selected and the second
selected items.

The Ctrl key also works when selecting objects in the viewport using one of the main toolbar
Select buttons. You can tell whether you're in select mode by looking for a button that’s high-
lighted yellow. If you hold down the Ctrl key and click an object, then the object is added to
the current selection set. If you click an item that is already selected, then it is deselected. If
you drag over multiple objects while holding down the Ctrl key, then all items in the dragged
selection are added to the current selection set.

The Alt key deselects objects from the current selection set, which is opposite of what the
Ctrl key does.

If you drag over several objects while holding down the Shift key, then the selection set is
inverted. Each item that was selected is deselected and vice versa.

Object hierarchies are established using the Link button on the main toolbar. You can select
an entire hierarchy of objects by double-clicking on its parent object. You can also select
multiple objects within the hierarchy. When you double-click an object, any children of that
object are also selected. When an object with a hierarchy is selected, the Page Up and Page
Down keys select the next object up or down the hierarchy.

Another way to select multiple objects is by dragging within the viewport using the Window
and Crossing Selection methods discussed previously in the “Select by Region” section.

Tutorial: Selecting objects

To practice selecting objects, we work with a simple model of the lion toy. When you're
finished, you can throw this model to your dog for a chew toy.

To select objects, follow these steps:
1. Open the Lion toy.max scene. You can find it in the Chap 06 directory on the CD-ROM.

2. Click the Select Object button (or press the Q key), and click the lion’s body in one of
the viewports.

In the Command Panel, the name for this object, lion, is displayed in the Name and
Color rollout.

3. Click the Select and Move button (or press the W key), click the lion’s body, and drag in
the Perspective viewport to the right.

As you can see, the lion’s head and body form an object independent of the other parts
of the lion object. Moving it separates it from the rest of the model’s parts.

4. Choose Edit = Undo Move (or press Ctrl+Z) to piece the lion back together again.

5. With the Select and Move tool still selected, drag an outline around the entire lion in
the Top view to select all the lion parts, and then click and drag the entire lion again.

This time, the entire lion moves as one entity, and the name field displays Multiple
Selected.
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6. Open the Select Objects dialog box by clicking the Select by Name button on the main

toolbar (or by pressing the H key).
All the individual parts that make up this model are listed.
7. Double-click the nose object listed in the dialog box.

The Select Objects dialog box automatically closes, and the nose object becomes
selected in the viewports.

Figure 6-5 shows our lion friend with just its nose object selected. Notice that the name of the

selected object in the Name and Color rollout says “nose.”
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Figure 6-5: A lion cartoon character with its white selected nose.

Locking selection sets

If you've finally selected the exact objects that you want to work with, you can disable any

other selections using the Selection Lock Toggle button on the Status Bar (it looks like a

lock). When this button is enabled, it is colored yellow, and clicking objects in the viewports

won'’t have any effect on the current selection. The keyboard shortcut toggle for this
command is the spacebar.
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Using named selection sets

With a group of selected objects, you can establish a selection set. Once established as a
selection set, you can recall this group of selected objects at any time by selecting its name
from the Named Selection Set drop-down list on the main toolbar, or by opening the Named
Selection Sets dialog box, shown in Figure 6-6.

O You can access this dialog box using the Named Selection Sets button on the main tool-
| m[} bar or by selecting the Edit => Named Selection Sets menu command. To establish a
selection set, type a name in the Named Selection Set drop-down list toward the right end of
the main toolbar or use the dialog box.
Subtract Selected Objects
Add Selected Objects | Select Objects in Set

Remove Select by Name

Create New Set Highlight Selected Objects

lamed|Selkctign Jets | %

0] x| || B | ) 2|

Named Selection Sets
= {} face
i) ears
B facial
&) Leye
B0 mouth
B nose
) r_eve
B tongue
= {} head

{face} - Selected: §

Figure 6-6: The Edit Named Selections dialog
box lets you view and manage selection sets.

You can also create named selection sets for subobject selections. Be aware that these subob-
ject selection sets are available only when you're in subobject edit mode and only for the cur-
rently selected object.

Editing named selections

After you've created several named selection sets, you can use the Named Selections Sets dia-
log box to manage the selection sets. The buttons at the top let you create and delete sets,
add or remove objects from a set, and select and highlight set objects. You can also move an
object between sets by dragging its name to the set name to which you want to add it.
Dragging one set name onto another set name combines all the objects from both sets under
the second set name. Double-clicking on a set name selects all the objects in the set.
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Isolating the current selection

The Tools = Isolate Selection (Alt+Q) menu command hides all objects except for the selected
object. It also zooms to extents on the object in the active viewport. It also opens a simple
dialog box with an Exit Isolation button in it. Clicking this button or selecting the Isolate
command again exits isolation mode and displays all the objects again.

Isolate Selection mode is very convenient for working on a certain area. Figure 6-7 shows
the Isolate Selection mode for a selection set that includes all elements of the lion toy’s face.
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Figure 6-7: Isolated Selection mode lets you focus on the details of the selected object.

Selecting objects in other interfaces

In addition to selecting objects in the viewports, you can use many of the other interfaces
and dialog boxes to select objects. For example, the Material Editor includes a button that
selects all objects in a scene with the same material applied.

=z The Select by Material button opens the Select Object dialog box with all objects that
'?\ use the selected material highlighted.

Another way to select objects is in the Track View, which can be opened using the Graph
Editors = New Track View menu command. To view all the objects, click the + sign that pre-
cedes the Objects track. You can identify the Objects track by a small yellow cube. A hierar-
chy of all the objects in a scene is displayed. At the bottom left of the Track View window is
the Select by Name text field. Typing an object name in this field automatically selects the
object’s track in the editor’s window, but not in the viewport. Clicking the yellow cube icon
selects the object in the viewport.
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A third interface that you can use to select objects is the Schematic View, which is opened
using the Graph Editors &> New Schematic View menu command. It offers a hierarchical look
at your scene and displays all links and relationships between objects. Each object in the
Schematic View is displayed as a rectangular node.

To select an object in the viewport, find its rectangular representation in the Schematic View
and simply double-click it. To select multiple objects in the Schematic View, you need to
enable Sync Selection mode with the Select => Sync Selection command in the Schematic View
menu and then drag an outline over all the rectangular nodes that you want to select.

The Schematic View also includes the Select by Name text field, just like the Curve Editor, for
selecting an object by typing its name.

- Cross-
| Reference

The Material Editor is covered in detail in Chapter 19, “Exploring the Material Editor,” the
Track View is covered in Chapter 33, “Working with the Track View,” and the Schematic View

=" interface is covered in Chapter 9, “Working with the Schematic View."

Setting Object Properties

After you select an object or multiple objects, you can view their object properties by choos-
ing Edit = Object Properties. Alternatively, you can right-click the object and select Properties
from the pop-up menu. Figure 6-8 shows the Object Properties dialog box. This dialog box
includes four panels — General, Advanced Lighting, mental ray, and User Defined.

Figure 6-8: The Object Properties dialog
box displays valuable information about a
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Viewing object information

For a single object, the General panel of the Object Properties dialog box lists details about
the object in the Object Information section. These details include the object’s name; color;
extent distances from the origin along the X, Y and Z axes; number of vertices and faces; who
the object’s parent is; the object’s Material Name; the number of children attached to the
object; the object’s group name if it’s part of a group; and the layer on which the object can
be found. All this information (except for its name and color) is for display only and cannot
be changed.

The two fields under the Vertices and Faces are used only when the properties for a Shape

o are being displayed. These fields show the number of Shape Vertices and Shape Curves.

- Cross-
| Referen

e

If the properties for multiple objects are to be displayed, the Object Properties dialog box
places the text “Multiple Selected” in the Name field. The properties that are in common
between all these objects are displayed. With multiple objects selected, you can set their
display and rendering properties all at once.

The Object Properties dialog box can be displayed for all geometric objects and shapes, as
well as for lights, cameras, helpers, and Space Warps. Not all properties are available for all
objects.

\ The Hide and Freeze options included in the Interactivity section are covered later in the
ce

chapter in the “Hiding and Freezing Objects” section.

Setting display properties

Display properties don’t affect how an object is rendered, only how it is displayed in the view-
ports. In this section, along with the Rendering Control and Motion Blur sections, are three
By Object/By Layer toggle buttons. If the By Object button is displayed, then options can be
set for the selected object, but if the By Layer option is enabled, then all options become dis-
abled and the object gets its display properties from the layer settings found in the Layer
Manager.

You can also find and set the same Display Properties that are listed in the Object Properties

o dialog box in the Display Properties rollout of the Display panel in the Command Panel and

in the Display Floater.

The See-Through option causes shaded objects to appear transparent. This option is similar
to the Visibility setting in the Rendering Control section, except that it doesn’t affect the ren-
dered image. It is only for displaying objects in the viewports. This option really doesn’t help
in wireframe viewports. Figure 6-9 shows a deer model with spheres behind it with and with-
out this option selected.

Many of these display properties can speed up or slow down the viewport refresh rates. For
example, Display as Box increases the viewport update rate dramatically for complex scenes,
but at the expense of any detail. This setting can be useful to see how the objects generally
fit in comparison to one another. This option can also be accessed from the Viewport
Configuration dialog box or from the Viewport name right-click pop-up menu, but the Object
Properties dialog box lets you set this option for a single object instead of for the entire
viewport.
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Figure 6-9: The See-Through display property can make objects
transparent in the viewports.

The Backface Cull option causes the faces on the backside of the object to not be displayed
when turned on. Max considers the direction that each normal is pointing and doesn’t display
a face if its normal points away from the view. A normal is a vector that extends perpendicu-
lar to the face and is used to determine the orientation of individual faces. This option pro-
duces the same result of the Force 2-Sided option in the Viewport Configuration dialog box,
except that it can be applied to a single object and not the entire viewport. This display
option works only in wireframe viewports.

The Edges Only option displays only the edges of each face when the viewport is set to
Wireframe mode. When Edges Only is not selected, a dashed line indicates polygon faces.

When the Vertex subobject mode is selected for an object, all vertices for the selected object
appear as blue plus signs. The Vertex Ticks option displays all object vertices in this same
way without requiring the Vertex subobject mode. Figure 6-10 shows the deer mesh with this
option enabled.

Figure 6-10: The Vertex Ticks option displays all
vertices as small blue tick marks.

The Trajectory option displays any animated motions as a spline path.

To learn more about using animated motion paths, see Chapter 30, “Animation Basics.”
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The Ignore Extents option causes an object to be ignored when you are using the Zoom
Extents button in the Viewport Navigation controls. For example, if you have a camera or
light positioned at a distance from the objects in the scene, then anytime you use the Zoom
Extents All button, the center objects are so small that you cannot see them because the
Zoom Extents needs to include the distance light. If you set the Ignore Extent option for the
camera or light, then the Zoom Extents All button zooms in on just the geometry objects.

When objects are frozen, they appear dark gray, but if the Show Frozen in Gray option is
disabled, then the object appears as it normally does in the viewport.

The Vertex Color option displays the colors of any Editable Mesh vertices that have been
assigned colors. You can select to use Vertex Color, Vertex Illumination, Vertex Alpha, Map
Channel Color, or Soft Selection Color. The Shaded button causes the meshes to be shaded
by the vertex colors. If the Shaded button is disabled, the object is unshaded. You can assign
vertex colors only to editable meshes, editable polys, and editable patches. If the Map
Channel Color option is selected, you can specify the Map Channel.

For more information about vertex colors, check out Chapter 20, “Creating and Applying
g8 Simple Materials.”

Setting rendering controls

In the Object Properties dialog box, the Rendering Controls section includes options that
affect how an object is rendered.

The Visibility spinner defines a value for how opaque (non-transparent) an object is. A value
of 1 makes the object completely visible. A setting of 0.1 makes the object almost transparent.
The Inherit Visibility option causes an object to adopt the same visibility setting as its parent.

The Visibility option can also be animated for making objects slowly disappear.

e
%

4

The Renderable option determines whether or not the object is rendered. If this option isn’t
selected, then the rest of the options are disabled because they don’t have any effect if the
object isn’t rendered. The Renderable option is useful if you have a complex object that takes
a while to render. You can disable the renderability of the single object to quickly render the
other objects in the scene.

You can use the Visible to Camera and Visible to Reflection/Refraction options to make
objects invisible to the camera or to any reflections or refractions. This feature can be useful
when you are test-rendering scene elements and raytraced objects.

If an object has the Visible to Camera option disabled and the Cast Shadows option enabled,
.. then the object isn't rendered, but its shadows are.

%

y

The Receive Shadows and Cast Shadows options control how shadows are rendered for the
selected object. The Apply Atmospherics options enable or disable rendering atmospherics.
Atmospheric effects can increase the rendering time by a factor of 10, in some cases.

\ Atmospheric effects are covered in Chapter 42, “Using Atmospheric Effects.”
ce
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The Render Occluded Objects option causes the rendering engine to render all objects that
are hidden behind the selected object. The hidden or occluded objects can have glows or
other effects applied to them that would show up if rendered.

You use the G-Buffer Object Channel value to apply Render or Video Post effects to an object.
By matching the Object Channel value to an effect ID, you can make an object receive an effect.

- Cross- Render effects are covered in Chapter 43, “Using Render Elements and Effects,” and the
| Reference Video Post interface is covered in Chapter 47, “Using the Video Post Interface”

Enabling Motion Blur

You can also set Motion Blur from within the Object Properties dialog box. The Motion Blur
effect causes objects that move fast (such as the Road Runner) to be blurred (which is useful
in portraying speed). The render engine accomplishes this effect by rendering multiple
copies of the object or image.

[gr?ss- \ More information on these blur options is in Chapter 41, “Rendering Basics.”
eference

The Object Properties dialog box can set two different types of Motion Blur: Object and
Image. Object motion blur affects only the object and is not affected by the camera move-
ment. Image motion blur applies the effect to the entire image and is applied after rendering.

- Cross- A third type of Motion Blur is called Scene Motion Blur and is available in the Video Post
| Reference interface. See Chapter 47, “Using the Video Post Interface,” for information on using Scene
Motion Blur.

You can turn the Enabled option on and off as an animation progresses, allowing you to
motion blur select sections of your animation sequence. The Multiplier value is enabled only
for the Image Motion Blur type. It is used to set the length of the blur effect. The higher the
Multiplier value, the longer the blurring streaks. The Motion Blur settings found in the Object
Properties dialog box can be overridden by the settings in the Render Scene dialog box.

Caution If the Motion Blur option in the Object Properties dialog box is enabled but the Motion Blur
option in the Renderer panel of the Render Scene dialog box is disabled, then motion
blur will not be included in the final rendered image.

Using the Advanced Lighting and mental ray panels

The second and third panels in the Object Properties dialog box contain object settings for
working with Advanced Lighting and the mental ray renderer. Using the settings in the
Advanced Lighting panel, you can exclude an object from any Advanced Lighting calculations,
set an object to cast shadows and receive illumination, and set the number of refine itera-
tions to complete.

The mental ray panel includes options for making an object generate and/or receive caustics
and global illumination.
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Advanced Lighting is covered in Chapter 28, “Advanced Lighting and Light Tracing,” and the
Gt mental ray renderer is covered in Chapter 44, “Raytracing and mental ray.”

Using the User-Defined panel

The User-Defined panel contains a simple text window. In this window, you can type any sort
of information. This information is saved with the scene and can be referred to as notes about
an object.

Hiding and Freezing Objects

Tip

/ Note

Hidden and frozen objects cannot be selected, and as such they cannot be moved from their
existing positions. This becomes convenient when you move objects around in the scene. If
you have an object in a correct position, you can freeze it to prevent it from being moved
accidentally or you can hide it from the viewports completely. A key difference between these
modes is that frozen objects are still rendered, but hidden objects are not.

You can hide and freeze objects in several ways. You can hide or freeze objects in a scene by
selecting the Hide or Freeze options in the Object Properties dialog box. You can also hide
and freeze objects using the Display Floater dialog box, which you access by choosing

Tools => Display Floater.

Several keyboard shortcuts can be used to hide specific objects. These shortcuts are toggles,
ﬂ_ so one press makes the objects disappear and another press makes them reappear. Object
4 types that can be hidden with these shortcuts include cameras (Shift+C), geometry
(Shift+G), grids (G), helpers (Shift+H), lights (Shift+L), particle systems (Shift+P), shapes
(Shift+S), and Space Warps (Shift+W).

The Hide option makes the selected object in the scene invisible, and the Freeze option turns
the selected object dark gray (if the Show Frozen in Gray option in the Object Properties dia-
log box is enabled) and doesn’t enable it to be transformed or selected. You cannot select
hidden objects by clicking in the viewport.

When you use the Zoom Extents button to resize the viewports around the current objects,
o hidden objects aren't included.

Using the Display Floater dialog box

The Display Floater dialog box includes two tabs: Hide/Freeze and Object Level. The Hide/
Freeze tab splits the dialog box into two columns, one for Hide and one for Freeze. Both
columns have similar buttons that let you hide or freeze Selected or Unselected objects, By
Name or By Hit. The By Name button opens the Select Objects dialog box (which is labeled
Hide or Freeze Objects). The By Hit option lets you click in one of the viewports to select

an object to hide or freeze. Each column also has additional buttons to unhide or unfreeze All
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objects, By Name, or in the case of Freeze, By Hit. You can also select an option to Hide
Frozen Objects.

__/Note Other places to find the same buttons found in the Display Floater are the Hide and Freeze
-y rollouts of the Display panel of the Command Panel and in the right-click quadmenu.

The Object Level panel of the Display Floater lets you hide objects by category such as All
Lights or Cameras. You can also view and change many of the Display Properties that are
listed in the Object Properties dialog box.

Figure 6-11 shows the Hide/Freeze and Object Level panels of the Display Floater dialog box.
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Using the Display panel

If you were to take many of the features of the Display Floater and the Object Properties dia-
log box and mix them together with some new features, the result would be the Display panel.
You access this panel by clicking the fifth icon from the left in the Command Panel (the icon
that looks like monitor screen).

The first rollout in the Display panel, shown in Figure 6-12, is the Display Color rollout. This
rollout includes options for setting whether Wireframe and Shaded objects in the viewports
are displayed using the Object Color or the Material Color.

The panel also includes a Hide by Category rollout. Using this rollout, you can add new cate-
gories that will appear in the Object Level panel of the Display Floater. To add a new category,
click the Add button of the Hide by Category rollout. The Add Display Filter list appears, as
shown in Figure 6-13. From this list, you can choose specific object categories to add to the
Hide by Category list.
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The Display panel also includes Hide and Freeze rollouts that include the same buttons and
features as the Hide/Freeze panel of the Display Floater. You also find a Display Properties
rollout that is the same as the list found in the Display Floater’s Object Level panel and the

Object Properties dialog box.

The Link Display rollout at the bottom of the Display panel includes options for displaying
links in the viewports. Links are displayed as lines that extend from the child to its parent
object. Using the Link Replaces Object option, you can hide the objects in the viewport and

see only the links.

features of the Display Floater and Object Properties dialog box.

&) Figure 6-13: From this dialog box, you can add new
categories to the Hide by Category list.
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Tutorial: Hidden toothbrushes

In this example, I've hidden several toothbrushes in the scene and your task is to find them.
To find the hidden objects, follow these steps:

1.

Open the Toothbrushes.max scene file.

This file appears to only contain a single toothbrush, but there are more. See if you can
find them. The toothbrush model was created by Viewpoint Datalabs. You can find it in
the Chap 06 directory on the CD-ROM.

. Locate the hidden object in the scene by opening the Display Floater (choose Tools =

Display Floater).

. In the Display Floater, select the Hide/Freeze tab. In the Unhide section, click the Name

button.

The Unhide Objects dialog box appears, which lists all the hidden objects in the scene.

. Select the green toothbrush object from the list, and click the Unhide button.

The Unhide Objects dialog box closes, and the hidden objects become visible again.

Notice that the Display Floater is still open. That's because it's modeless. You don't need to
close it in order to keep working.

5. To see all the remaining objects, click the Unhide All button in the Display Floater.

Figure 6-14 shows the finished scene with all toothbrushes visible.

S=E¥ 4+ BPIOB|RE Dy B[S

@ Toothbrushes - final.max - 3ds max 6 DEE
File Edit Tools Group Views Create Modifiers Character reactor Animation Graph Editors Rendering Customize MAXScript Help
M R EEF L ELIS G0 Al i) e’ & ol =it &

s 8 @|E T
|

Display Floater [x]

HiderFreeze | Obiect Level |

i B -
setciod || S el e
Unselecter | | Unselasted —

By Mame... By Name...
By Hit

~LUnheeze
All
||| ByHame|

By Hit

I~ Hide Frozen Objects

% <] 0/100 |2]

8 = HHHH\p\l\\HIHQH\HHHHHHIHIHHHHHHDH\HHHHHHHH#HHHHHHHIHHHHHHH&D

[ None Selected 3 [« ke z] [ Gid - 10,0 Auta Key[Selected =] | [ e e | BT
[ Click and crag to select and mawe objects [Add Tine Tag SetKep KeyFiters.. | 4 [0 [ [3> 47 b By
Figure 6-14: Toothbrushes for the whole family; just remember which color is yours.
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Using Layers

New
Feature

So what does 3ds max have in common with a wedding cake? The answer is layers. Layers
provide a way to separate scene objects into easy-to-select and easy-to-work-with groupings.
These individual layers have properties that can then be turned on and off.

\ The Layer Manager has been redesigned for 3ds max 6.

Using the Layer Manager

You create, access, and manage layers through the Layer Manager dialog box, shown in
Figure 6-15. This dialog box is a floater that can remain open as you work with objects in the
viewports. You can access the Layer Manager using the Tools => Layer Manager menu com-
mand, by clicking the Layer Manager button on the main toolbar, or by clicking on the same
button in the Layers toolbar.

Layer: Character layer 3%
Syl S e b B
Layers | | Hide] Freeze! F!ender] Culor‘ Had\osﬁy_]
2 [ [default) - - )
=] %= Backaround laper - - & O
& River - - & m]
& Tower - - & m]
£ Smoke - - & | |
@ Tiess - - & | |
£ Clouds - - & |
7 Sun = - & m
£ Mountains - - & m|
£ Birds - - > |
%2 Character layer V- - & ]
=2 Foreground layer - - b ] ]
2 Buildings layer - - & [ ]
£ Street layer - - e ) =

Figure 6-15: The Layer Manager lists all the
layers and the objects contained within
each layer.

After you've set up your layers, you can control them using the Layer toolbar, shown in
Figure 6-16, rather than having the Layer Manager open. You can access the Layer toolbar by
right-clicking the main toolbar away from the buttons and selecting Layers toolbar from the
pop-up menu or by selecting the Customize => Show Ul = Floating Toolbars menu command.

Layer Select Objects
Manager Create New Layer in Current Layer

\\.Layers X
{'%J@ L DBachlloumd layer _:JI‘%U' 4.}-' %B %+—‘

Layer Selection Add Selection  Set Current Layer
drop-down list ~ to Current Layer to Selection's Layer

Figure 6-16: Use the Layers toolbar to set the active layer.
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Table 6-4 lists the buttons found in the Layer Manger and in the Layers toolbar.

Table 6-4: Layer Manager Buttons

Button Icon Name Description
Al Create New Layer Creates a new layer that includes the
%— selected objects.
x Delete Highlighted Empty Layers Deletes a layer if the layer is highlighted
and empty.
Add Selected Objects to Adds any selected objects to the current
I:II]:I Highlighted Layer highlighted layer.
Select Highlighted Objects Selects in the viewports any highlighted
I:E and Layers layers or objects.
1%] Highlight Selected Object's Layers Highlights the layer of the viewport's
o selected object in the Layer Manager.
s u) Hide/Unhide All Layers Toggles between hiding and unhiding all
— layers.
ift Freeze/Unfreeze All Layers Toggles between freezing and unfreezing
= all layers.

With the Layer Manager open, you can create new layers by clicking the Create New Layer
button. This adds a new layer to the manager, names it “Layer01,” and includes any selected
objects as part of the layer. If you click the layer’s name, you can rename it. Layer 0 is the
default layer to which all objects are added, if other layers don’t exist. Layer 0 cannot be
renamed.

Although you can rename layers in the Layer Manager, you cannot use the Layer Manager to
o rename objects.

Creating a new layer automatically makes the new layer the current layer as denoted by the
check mark in the first column of the Layer Manager. All new objects that are created are
automatically added to the current layer. Only one layer can be current at a time, but several
layers or objects can be highlighted. To highlight a layer, click it in the Layer Manager.
Highlighted layers are highlighted in yellow.

A highlighted layer can be deleted with the Delete Empty Layer button, but only if it is not the
current layer and if it doesn’t contain any objects.

Newly created objects are added to the current layer (the one marked with a check mark in
the first column of the Layer Manager). If you forget to select the correct layer for the new
objects, you can select the objects in the viewports, highlight the correct layer, and use the
Add Selected Objects to Highlighted Layer button to add the objects to the correct layer.

Every object can be added only to a single layer. You cannot add the same object to multiple
o layers.
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The Select Highlighted Objects and Layers button selects the highlighted layers (and objects)
in the viewports. This provides a way to select all the objects on a given layer. If an object in
the viewports is selected, you can quickly see which layer it belongs to with the Highlight
Selected Object’s Layers button.

If you expand the layer name in the Layer Manager, you see a list of all the objects contained
within the layer. If you click the Layer icon (to the left of the layer’s name), the Layer
Properties dialog box, shown in Figure 6-17, opens. Clicking the Object icon opens the Object
Properties dialog box.
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Figure 6-17: The Layer Properties dialog
box is similar to the Object Properties dialog
box, but it applies to the entire layer.

Using the Layer List

The main section of the Layer Manager (and repeated in the Layers toolbar) is the layer lists
and its columns, which allow you to turn certain properties on and off. The properties in the
columns include Hide, Freeze, Render, Color, and Radiosity. If a property is enabled, a simple
icon is displayed; if disabled, a dash is displayed. If an object is set to get its property from
the layer (by clicking the ByLayer button in the Object Properties dialog box), then a dot icon
is displayed. Individual objects within a layer can have different properties. You can sort the
column properties by clicking on the column head.

You can toggle these properties on and off by clicking on them. You can also set these proper-
ties in the Layers toolbar. The Hide toggle determines whether the layer’s objects are visible
in the viewports. The Freeze toggle makes objects on a layer unselectable. The Render toggle
enables the layer’s objects to be rendered. The Color toggle sets the layer color. Layer 0 is set
to assign random colors and cannot be changed. The Radiosity toggle includes the layer’s
objects in the radiosity calculations.
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The Layer Manager also includes a right-click pop-up menu that includes many of the same
commands found as buttons, but a unique set of commands found in the right-click pop-up
menu are the Cut and Paste commands. With these commands, you can select objects in one
layer to cut and paste into another layer.

Tutorial: Dividing a scene into layers

As a scene begins to come together, you’ll start to find that it is difficult to keep track of all
the different pieces. This is where the layers interface can really help. In this example, we
take a simple scene and divide it into several layers.

To divide a scene into layers, follow these steps:
1. Open the Elk on hill layers.max scene file.

You can find it in the Chap 06 directory on the CD-ROM. This file includes an Elk model
created by Viewpoint Datalabs.

2. Select Tools > Layer Manager to open the Layer Manager.

3. With no objects selected, click the Create New Layer button and name the layer Hill
and trees. Click the Create New Layer button again, and name this layer Elk. Click the
Create New Layer button again, and create a layer named Background and light. The
Layer Manager now includes four layers, including layer 0.

4. In the Layer Manager, click on the first column for the Elk layer to make it the current
layer. With the Edit = Select All (Ctrl+A) menu command, select all objects in the scene
and click the Add Selected Objects to Highlighted Layer button in the Layer Manager.

5. Expand the Elk layer by clicking the plus icon to the left of its name.
This displays all the objects within this layer.

6. Select all the trees and the hill objects by holding down the Ctrl key and clicking each
object’s name in the Layer Manager. Then right-click away from the names, and select
Cut from the pop-up menu. Then select the Hill and trees layer, and select Paste from
the right-click pop-up menu.

7. Select the background and light objects from within the Elk layer, and click the Select
Highlighted Objects and Layers button. Then select the Background and light layer, and
click the Add Selected Objects to Highlighted Layer button to move the background
and light objects to the correct layer.

You can now switch between the layers, depending on which one you want to add objects to
or work on, and you can change properties as needed. For example, to focus on the deer
object, you can quickly hide the other layers using the Layer Manager. Figure 6-18 shows the
various layers and the objects in each layer.
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(& Elk on hill layers - final.max - 3ds max 6
File Edit Tools Group Views Create Modifiers Character reactor Animation Graph Editors Rendering™ Customize MAXScript Help
||€“'& %% AP jﬁxjtltmé’ufv‘ew ﬂmwm@&ﬁm =T

|| 2| m| T\
Modifier List -

=T

= e e

-me Elk R/
@ X 4 oh oo &

Layers || Hide [ Fleezel Render | Color | Radiostt
£ 0 {defaull] i
1 & Background and light
& backgiound
© Dmnidl
o8 Ek
@ keyd2
& antlers
& eves
& hoofs
& hide
& Elk
& Hill and tiee:
£ tieels
@ tieel4
& free03
& treel?2
& teedi
& hills

<
LI T I I R A R I N |

666666046600 664046¢
OODODDEEOEEOEEOO0n

CLe=s s Mi&@?wmmz:fﬁ-@@ Ezl_‘

ﬁ 00 >
I HH\HHHHHH\HHHHHHHIHHHHHHHH\HHHHIHHIHHI\HIH\HIHHHHHHHH
i = 40 5!“ # $‘3 ]
\'zznuiimaa\a:ted & [HH 3]*«:| z] \and =100 Authey saemad | b | o] we (ee |G G A
Cick and drag 1o select and scale abiects (uifaml] [Add Time Tag Seikey|  Keyfites. | w40 [B |38 & B

Figure 6-18: All objects assigned to a layer can be viewed in the Layer Properties dialog box.

Summary

Selecting objects enables you to work with them, and Max includes many different ways to
select objects. In this chapter, you've done the following:

4+ Learned how to use selection filters

4 Selected objects with the Edit menu by Name, Color, and Region

4 Selected multiple objects and used a named selection set to find the set easily
4 Selected objects using other interfaces

4 Accessed the Object Properties dialog box to set Display and Rendering settings for an
object

4+ Learned how to hide and freeze objects
4 Separated objects using layers

In the next chapter, you work more with multiple objects by learning how to clone objects.
Using these techniques, you could very quickly have too many objects (and you were worried
that there weren’t enough objects).

+ o+ 0+



Cloning Objects
and Creating
Object Arrays

The only thing better than one perfect object is two perfect
objects. Cloning objects is the process of creating copies of
objects. These copies can maintain an internal connection (called an
instance or a reference) to the original object that allows them to be
modified along with the original object. For example, if you create a
school desk from a Box primitive and modify its parameters, the
same resulting effect is applied to all instances of the original.

An array is a discrete set of objects that are regularly ordered. So cre-
ating an array of objects involves cloning several copies of an object
in a pattern, such as in rows and columns or in a circle.

I'm sure you have the concept for that perfect object in your little
bag of tricks, and this chapter lets you copy it over and over after
you get it out.

Cloning Objects

You can clone objects in Max in a couple of ways (and cloning luckily
has nothing to do with DNA or gene splices). One method is to use
the Edit = Clone (Ctrl+V) menu command, and another method is to
transform an object while holding down the Shift key. You won’t need
to worry about these clones attacking anyone (unlike Star Wars:
Episode II).

Using the Clone command

You can create a duplicate object by choosing the Edit => Clone
(Ctrl+V) menu command. You must select an object before the Clone
command becomes active, and you must not be in a Create mode.
Selecting this command opens the Clone Options dialog box, shown
in Figure 7-1, where you can give the clone a name and specify it as a
Copy, Instance, or Reference. You can also copy any controllers asso-
ciated with the object as a Copy or an Instance.

Caution The Edit menu doesn't include the common cut, copy, and paste
commands because many objects and subobjects cannot be eas-
ily pasted into a different place. However, you will find a Clone
(Ctrl+V) command, which can duplicate a selected object.

CHAPTER

¢+ s+
In This Chapter

Cloning obijects

Understanding copies,
instances, and
references

Using the Mirror and
Snapshot tools

Spacing clones along a
path with the Spacing
tool

Creating object arrays

Using the Ring Array
system

+ + o+
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Clone Options @i Figure 7-1: The Clone Options dialog box defines the new

Object Bontoler object as a Copy, Instance, or Reference.
 Copy # Copy
® Instance  Instance

" Relerence

Mame: |Sphere02

0K | Cancel |

The difference between Copy, Instance, and Reference is discussed in the “Understanding
ce Cloning Options” section in this chapter.

When a clone is created with the Clone menu, it is positioned directly on top of the original,
which makes distinguishing it from the original difficult. To verify that a clone has been
created, open the Select by Name dialog box by pressing H and look for the cloned object

(it has the same name, but an incremented number has been added). To see both objects,
click the Select and Move button on the main toolbar and move one of the objects away from
the other.

Using the Shift-clone method

An easier way to create clones is with the Shift key. You can use the Shift key when objects
are transformed using the Select and Move, Select and Rotate, and Select and Scale com-
mands. Holding down the Shift key while you use any of these commands on an object clones
the object and opens the Clone Options dialog box. This Clone Options dialog box is identical
to the dialog box previously shown, except it includes a spinner to specify the number of
copies.

Performing a transformation with the Shift key held down defines an offset that is applied
repeatedly to each copy. For example, holding down the Shift key while moving an object five
units to the left (with the Number of Copies set to 5) places the first cloned object five units
away from the original, the second cloned object ten units away from the original object, and
so on.

Tutorial: Cloning dinosaurs

The story behind Jurassic Park is pretty exciting, but in Max we can clone dinosaurs without
their DNA.

To investigate cloning objects, follow these steps:
1. Open the Cloning dinosaurs.max file found in the Chap 07 directory of the CD-ROM.
2. Select the dinosaur object by clicking it in one of the viewports.
3. With the dinosaur model selected, choose Edit => Clone (or press Ctrl+V).

The Clone Options dialog box appears.
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4. Name the clone First clone, select the Copy option, and click OK.

5. Click the Select and Move button (or press the W key) on the main toolbar. Then in the
Top viewport, click and drag the dinosaur model to the right.

As you move the model, the original model beneath it is revealed.

6. Select each model in turn, and notice the name change in the Create panel’s Name field.
Notice that the clone is even the same object color as the original.

7. With the Select and Move button still active, hold down the Shift key, click the cloned
dinosaur in the Top viewport, and move it to the right again. In the Clone Options

dialog box that appears, select the Copy option, set the Number of Copies to 3, and
click OK.

. Click the Zoom Extents All button (or press Shift+Ctrl+Z) in the lower-right corner to
view all the new dinosaurs.

Three additional dinosaurs have appeared, equally spaced from each other. The spac-
ing was determined by the distance that you moved the second clone before releasing
the mouse. Figure 7-2 shows the results of our dinosaur cloning experiment. (Now
you’ll need to build a really strong fence.)

(@ Cloning dinosaurs - final.max - 3ds max 6 BEIE]
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Figure 7-2: Cloning multiple objects is easy with the Shift-clone feature.
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Understanding Cloning Options

/ Note

When cloning in Max, you're offered the option to create the copy as a copy, an instance, or a
reference. This is true not only for objects, but for materials, modifiers, and controllers as well.

Working with copies, instances, and references

When an object is cloned, the Clone Options dialog box appears. This dialog box enables you
to select to make a copy, an instance, or a reference of the original object. Each of these clone
types is unique and offers different capabilities.

A copy is just what it sounds like —an exact replica of the original object. The new copy
maintains no ties to the original object and is a unique object in its own right. Any changes
to the copy do not affect the original object, and vice versa.

Instances are different from copies in that they maintain strong ties to the original object. All
instances of an object are interconnected, so that any geometry modifications (done with
modifiers or object parameters) to any single instance changes all instances. For example,

if you create several instances of a mailbox and then use a modifier on one of them, all
instances are also modified.

Instances and references can have different object colors, materials, transformations (moving,

o rotating, or scaling), and object properties.

References are objects that inherit modifier changes from their parent objects, but do not
affect the parent when modified. Referenced objects get all the modifiers applied to the par-
ent and can have their own modifiers as well. For example, suppose that you have an apple
object and a whole bunch of references to that apple. Applying a modifier to the base apple
changes all the remaining apples, but you can also apply a modifier to any of the references
without affecting the rest of the bunch.

.7 At any time, you can break the tie between objects with the Make Unique button in the
Modifier Stack.

When an object is selected, all its instances and references are surrounded with an orange
bounding box.

Tutorial: Creating instanced doughnuts

Learning how the different clone options work will save you lots of future modifications. To
investigate these options, let’s take a quick trip to the local doughnut shop.

To clone some doughnuts, follow these steps:

1. Create a doughnut using the Torus primitive by selecting Create => Standard Primitives
o> Torus and dragging and clicking twice in the Top viewport to create a torus object.

2. Click the torus object in the Top viewport to select it.

3. With the doughnut model selected, click the Select and Move button (or press the W
key). Hold down the Shift key, and in the Top viewport, move the doughnut upward. In
the Clone Options dialog box, select the Instance option, set the Number of Copies to 5,
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and click OK. Click the Zoom Extents All (or press the Shift+Ctrl+Z key) button to widen
your view.

4. Select all objects with the Edit = Select All (Ctrl+A) command, and then Shift+drag the
doughnuts in the Top viewport to the right. In the Clone Options dialog box, select the
Instance option again and 3 for the Number of Copies and click OK. This creates a nice
array of two dozen doughnuts. Click the Zoom Extents All (or press the Z key) button

to see all the doughnuts.

5. Select a single doughnut, and in the Parameters rollout of the Modify panel, set Radius1
to 20 and Radius2 to 10.

This makes a nice doughnut and changes all doughnuts at once.

6. Select the Modifiers = Parametric Deformers = Twist command. Then in the Parameters
rollout of the Command Panel, enter 25 in the Angle field and select the Y Twist Axis.

This adds a slight bend to the doughnuts.

You can use modifiers to alter geometry. You can learn about using modifiers in Chapter 11,
“Introducing Modifiers for Basic Object Deformation.”

Figure 7-3 shows the doughnuts all changed exactly the same. You can imagine the amount
of time it would take to change each doughnut individually. Using instances made these

changes easy.
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Tutorial: Working with referenced apples

Now that we have filled our bellies with doughnuts, we need some healthy food for
balance. What better way to add balance than to have an apple or two to keep the doctor

away?

To create a bunch of apples using referenced clones, follow these steps.

1.
2.

Open the Referenced Apples.max file from the Chap 07 directory on the CD-ROM.

Select the apple, and Shift+drag with the Select and Move (W) tool in the Top view-
port to create a cloned reference. Select the Reference option in the Clone Options
dialog box.

. Select the original apple again, and repeat Step 2 until several referenced apples

surround the original apple.

. Select the original apple in the middle again, and choose the Modifiers => Subdivision

Surfaces ©> MeshSmooth command. In the Subdivision Amount rollout, set the number
of Iterations to 2.

This smoothes all the apples.

. Select one of the surrounding apples, and apply the Modifiers > Parametric

Deformers = Taper command. Set the Amount value to 1.0 about the Z-axis.

. Select another of the surrounding apples, and apply the Modifiers => Parametric

Deformers > Squeeze command. Set the Axial Bulge Amount value to 0.3.

. Select another of the surrounding apples, and apply the Modifiers => Parametric

Deformers > Squeeze command. Set the Radial Squeeze Amount value to 0.2.

As you apply modifiers to a referenced object, notice the thick gray bar in the Modifier Stack.
This bar, called the Derived Object Line, separates which modifiers get applied to all refer-
enced objects (below the line) and which modifiers get applied to only the selected object
(above the line). If you drag a modifier from above the gray bar to below the gray bar, then
that modifier is applied to all references.

Using referenced objects, you can apply the major changes to similar objects, but still make
minor changes to objects to make them a little different. Figure 7-4 shows the apples. Notice
that they are not all exactly the same.
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Mirroring Objects

Have you ever held the edge of a mirror up to your face to see half your head in the mirror?
Many objects have a natural symmetry that you can exploit to require that only half an object
be modeled. The human face is a good example. You can clone symmetrical parts using the
Mirror command.

Using the Mirror command

’I% The Mirror command creates a clone (or No Clone if you so choose) of the selected

object about the current coordinate system. To open the Mirror dialog box, shown in
Figure 7-5, choose Tools => Mirror, or click the Mirror button located on the main toolbar. You
can access the Mirror dialog box only if an object is selected.

Within the Mirror dialog box, you can specify an axis or plane about which to mirror the
selected object. You can also define an offset value. As with the other clone commands, you
can specify whether the clone is to be a Copy, an Instance, or a Reference, or you can choose
No Clone, which flips the object around the axis you specify. The dialog box also lets you mir-
ror Inverse Kinematics Limits, which reduces the number of IK parameters that need to be set.
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Mirror: World Coordinates @& Figure 7-5: The Mirror dialog box can create an inverted

e clone of an object.
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Tutorial: Mirroring a robot’s leg

Many characters have symmetry that you can use to your advantage, but to use symmetry,
you can’t just clone one half. Consider the position of the right character’s ear relative to its
right eye. If you clone the ear, then the position of each ear will be identical, with the ear to
the right of the eye, which would make for a strange looking creature. What you need to use
is the Mirror command, which rotate the object about a selected axis.

/ Note

Learn more about inverse kinematics in Chapter 37, “Using Inverse Kinematics.”

In this example, we have a complex mechanical robot with one of its legs created. Using
Mirror, you can quickly clone and position its second leg.

To mirror a robot’s leg, follow these steps:

1.

—

Open the Robot mech.max file from the Chap 07 directory on the CD-ROM.

This file includes a robot with one of its legs deleted.

. Select all objects that make up the robot’s leg in the Left viewport and open the Mirror

dialog box with the Tools = Mirror menu command.

. In the Mirror dialog box, select X as the Mirror Axis and Instance as the Clone

Selection. Change the Offset value until the cloned leg is in position, which should be
at around -2.55.

Any changes made to the dialog box are immediately shown in the viewports.

. Click OK to close the dialog box.

By making the clone selection an instance, you can ensure that any future modifications to
the right half of the figure are automatically applied to the left half.

Figure 7-6 shows the resulting robot —who won'’t be falling over now.
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Figure 7-6: A perfectly symmetrical robot, compliments of the Mirror tool

Cloning over Time

Another useful way to create multiple copies of an object is to have them appear at different
times in an animation. This cloning over time is accomplished with the Snapshot feature.

Using the Snapshot command

The Snapshot command creates copies, instances, references, or even meshes of a selected
object as it follows an animation path. For example, you could create a series of stairs by
positioning the bottom stair at frame 1 and the top stair at frame 100, and then choose
Tools = Snapshot and enter the number of steps to appear between these two in the
Snapshot dialog box. Be aware that the Snapshot command works only with objects

that have an animation path defined.

51 You can open the Snapshot dialog box by choosing Tools => Snapshot or by clicking the

Snapshot button (under the Array flyout on the Extras toolbar). Snapshot is the second
button in the flyout. In the Snapshot dialog box, shown in Figure 7-7, you can choose to
produce a single clone or a range of clones over a given number of frames. Selecting Single
creates a single clone at the current frame.
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/ Note

Tip

When entering the number of Copies in the Snapshot dialog box, a copy is placed at both the

o beginning and end of the specified range, so if your animation path is a closed path, two
objects are stacked on top of each other. For example, if you have a square animation path
and you want to place a copy at each corner, you need to enter a value of 5.
Snapshot Figure 7-7: The Snapshot dialog box lets you clone a
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The Snapshot tool can also be used with particle systems.

Tutorial: Creating a tower of cubes

The Snapshot tool can be used to create some interesting models. In this example, we create
a tower of cubes quickly using a simple Cube primitive and a Helix spline.

To create a tower of cubes with the Snapshot tool, follow these steps:

1. Click on the Box button in the Create panel, select the Cube option in the Creation

Method rollout, and drag in the Top viewport. In the Parameters rollout, set the cube’s
dimensions to 30.

2. Select Create=> Shapes = Helix, and click and drag in the Top viewport three times to

create a helix spline. Set its Radius 1 value to 115, its Radius 2 to 0, its Height to 125,
and the number of Turns to 5.

3. Select the cube object, open the Motion panel (it looks like a moving wheel) in the

Command Panel, and click the Trajectories button. Set the Start Time to 0, the End
Time to 100, and the Samples to 100. Then click the Convert From button, and select
the helix spline in the viewports.

This animates the cube moving along the helix spline.

4. Select Tools = Snapshot to open the Snapshot dialog box. Select the Range option, set

the number of Copies to 100, and select the Instance option. Then click the OK button.

Figure 7-8 shows the tower of cubes after the Snapshot tool cloned the first one.
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Figure 7-8: The Snapshot tool helps to build a tower of cubes in the shape of a helix.

Spacing Cloned Objects

The Snapshot tool offers a convenient way to clone objects along an animation path, but
what if you want to clone objects along a path that isn’t animated? The answer is the Spacing
tool. The Spacing tool can position clones at regular intervals along a path by either selecting
a path and the number of cloned objects or by picking two points in the viewport.

Using the Spacing tool

- You access the Spacing tool by clicking the last button in the flyout under the Array but-
223, ton on the Extras toolbar (the Extras toolbar can be made visible by right-clicking on
the main toolbar away from the buttons). You can also access it using the Tools => Spacing
Tool (Shift+]) menu command. When accessed, it opens the Spacing Tool dialog box, shown in
Figure 7-9. At the top of this dialog box are two buttons: Pick Path and Pick Points. If a path is
selected, its name appears on the Pick Path button.
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Tip

[El Spacing Tool = Figure 7-9: The Spacing Tool dialog box lets you select how
Lbredlf Pick Points to position clones along a path.

o
F

v Countf 35
[T Spacing[53135
[™ Start Offset]

8
I~ Erd Offset] = ﬂ

IDivida Ewenly, Objects at Ends ﬂ

v lan o,

4

[~ Context

Type of Object—
& Edges < Copy
" Centers # Instance
¥ Follow " Reference

Apply Cancel

35 objects (3 54.136 in between edges

You can also specify Count, Spacing, Start Offset, and End Offset values. The drop-down list
offers several preset options, including Divide Evenly, Free Center, End Offset, and more.
These values and preset options are used to define the number and spacing of the objects.
The spacing and position of the objects depend on the values that are included. For example,
if you include only a Count value, then the objects are evenly spaced along the path including
an object at each end. If an offset value is included, then the first or last item is moved away
from the end by the offset value. If a Spacing value is included, then the number of objects
required to meet this value is included automatically.

The Lock icons next to the Start and End Offset values force the Start or End Offset values to
be the same as the Spacing value. This has the effect of pushing the objects away from their
end points.

Before you can use either the Pick Path or Pick Points buttons, you must select the object to
be cloned. Using the Pick Path button, you can select a spline path in the scene, and cloned
objects are regularly spaced according to the values you selected. The Pick Points method
lets you click to select the Start point and click again to select an end point. The cloned
objects are spaced in a straight line between the two points.

The two options for determining the spacing width are Edges and Centers. The Edges option
spaces objects from the edge of its bounding box to the edge of the adjacent bounding box,
and the Centers option spaces objects based on their centers. The Follow option aligns the
object with the path if the path is selected. Each object can be a copy, instance, or reference
of the original. The text field at the bottom of the dialog box displays for your information the
number of objects and the spacing value between each.

Lining up objects to correctly follow the path can be tricky. If the objects are misaligned, you
A can change the object’s pivot point so it matches the viewport coordinates. This makes the
4 object follow the path with correct position.

You can continue to modify the Spacing Tool dialog box’s values while the dialog box is open,
but the objects are not added to the scene until you click the Apply button. The Close button
closes the dialog box.
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Tutorial: Stacking a row of dominoes

A good example of using the Spacing tool to accomplish something that is difficult in real life
is to stack a row of dominoes. It is really a snap in Max regardless of the path.

To stack a row of dominoes using the Spacing tool, follow these steps:
1. Open the Row of dominoes.max file from the Chap 07 directory on the CD-ROM.
This file includes a single domino and a wavy spline path.

2. Select the domino object, and open the Spacing tool by selecting the flyout button
under the Array button on the Extras toolbar (or by pressing Shift+I).

3. In the Spacing Tool dialog box, click the Pick Path button and select the wavy path.
The path name appears on the Pick Path button.

4. From the drop-down list in the Parameters section of the Spacing Tool dialog box,
select the Count option with a value of 35.

This is the same as the Divide Evenly, Objects at Ends option in the drop-down list.

5. Select the Edges context option, check the Follow check box, and make all clones
Instances. Click Apply when the result looks right, and close the Spacing Tool dialog box.

Figure 7-10 shows the simple results. The Spacing Tool dialog box remains open until you
click the Close button.
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Creating Arrays of Objects

Now that you've probably figured out how to create arrays of objects by hand with the Shift-
clone method, the Array command multiplies the fun by making it easy to create many copies
instantaneously. The Array dialog box lets you specify the array dimensions, offsets, and
transformation values. These parameters enable you to create an array of objects easily.

o9 Access the Array dialog box by selecting an object and choosing Tools = Array or by

¥a®, clicking the Array button on the Extras toolbar. Figure 7-11 shows the Array dialog box.
The top of the Array dialog box displays the coordinate system and the center about which
the transformations are performed.

The Array dialog box is persistent, meaning that, after being applied, the settings remain until
they are changed. You can reset all the values at once by clicking the Reset All Parameters
button.
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Figure 7-11: The Array dialog box defines the number of
elements and transformation offsets in an array.

Linear arrays

Linear arrays are arrays where the objects form straight lines, such as rows and columns.
Using the Array dialog box, you can specify an offset along the X, Y, and Z axes at the top of
the dialog box and define this offset as an incremental amount or as a total amount. To
change between incremental values and total values, click the arrows to the left and right of
the Move, Rotate, and Scale labels. For example, an array with ten elements and an incremen-
tal value of 5 positions each successive object a distance of five units from the previous one.
An array with five elements and a total value of 100 positions each element a distance of 20
units from the previous one.

The Move row values represent units as specified in the Units Setup dialog box. The Rotate
row values represent degrees, and the Scale row values are a percentage of the selected
object. All values can be either positive or negative values.

Clicking the Re-Orient check box causes the coordinate system to be reoriented after each
rotation is made. If this check box isn’t enabled, then the objects in the array do not succes-
sively rotate. Clicking the Uniform check box to the right of the Scale row values disables the
Y and Z Scale value columns and forces the scaling transformations to be uniform. To per-
form non-uniform scaling, simply deselect the Uniform check box.
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The Type of Object section lets you define whether the new objects are copies, instances, or
references. If you plan on modeling all the objects in a similar manner, then you will want to
select the Instance or Reference options.

In the Array Dimensions section, you can specify the number of objects to copy along three
different dimensions. You can also define incremental offsets for each individual row.

n You can use the Array dialog box to create a large number of objects. If your array of objects
is too large, your system may crash.

Tutorial: Building a white picket fence

To start with a simple example, we create a white picket fence. Because a fence repeats,
we need only to create a single slat and then we use the Array command to duplicate it
consistently.

To create a picket fence, follow these steps:
1. Open the White picket fence.max file from the Chap 07 directory on the CD-ROM.

2. With the single fence board selected, choose Tools = Array or click on the Array button
on the Extras toolbar to open the Array dialog box.

3. In the Array dialog box, click the Reset All Parameters button to start with a clean slate.
Then enter a value of 50 in the X column’s Move row under the Incremental section.
(This is the incremental value for spacing each successive picket.) Next, enter 20 in the
Array Dimensions section next to the 1D radio button. (This is the number of objects to
include in the array.) Click OK to create the objects.

Don't worry if you don't get the values right the first time. The most recent values you

o entered into the Array dialog box stay around until you exit Max.

- Cross-
| Referen

4. Click the Zoom Extents All button (or press Shift+Ctrl+Z) in the lower-right corner of
the Max window to see the entire fence in the viewports.

Figure 7-12 shows the completed fence.

Circular arrays

_ You can use the Array dialog box for creating more than just linear arrays. All transfor-
iﬂ, mations are done relative to a center point. You can change the center point about
which transformations are performed using the Use Selection Center button on the main
toolbar. The three flyout options are Use Pivot Point Center, Use Selection Center, and Use
Transform Coordinate Center.

For more about how these settings affect transformations, see Chapter 10, “Transforming
ce Objects — Translate, Rotate, and Scale.”
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Figure 7-12: Tom Sawyer would be pleased to see this white picket fence, created
easily with the Array dialog box.

Tutorial: Building a Ferris wheel

Ferris wheels, like most of the rides at the fair, entertain by going around and around, with
the riders seated in chairs spaced around the Ferris wheel’s central point. The Array dialog
box can also create objects around a central point.

nm In this example, you use the Rotate transformation along with the Use Transform
', Coordinate Center button to create a circular array.

To create a circular array, follow these steps:
1. Open the Ferris wheel.max file from the Chap 07 directory on the CD-ROM.
This file has the Front viewport maximized to show the profile of the Ferris wheel.

2. Click the Use Selection Center button on the main toolbar, and drag down to the last
icon, which is the Use Transform Coordinate Center button.

The Use Transform Coordinate Center button becomes active. This button causes all
transformations to take place about the axes in the center of the screen.

3. Select the light blue chair object, and open the Array dialog box by choosing Tools =
Array or by clicking the Array button on the Extras toolbar. Before entering any values
into the Array dialog box, click the Reset All Parameters button.



Chapter 7 4 Cloning Objects and Creating Object Arrays 290

4. Between the Incremental and Totals sections are the labels Move, Rotate, and Scale.
Click the arrow button to the right of the Rotate label. Set the Z column value of the
Rotate row to 360 degrees, and make sure that the Re-Orient option is disabled.

A value of 360 degrees defines one complete revolution. Disabling the Re-Orient option
keeps each chair object from gradually turning upside down.

5. In the Array Dimensions section, set the 1D spinner Count value to 8 and click the OK
button to create the array.

6. Next select the green strut, and open the Array dialog box again with the Tools &> Array
command. Select the Re-Orient option, and leave the rest of the settings as they are.
Click the OK button to create the array.

Figure 7-13 shows the resulting Ferris wheel. You can click the Min/Max toggle in the lower-
right corner to view all four viewports again.

Spiral arrays

Before leaving arrays, we should examine one more special case: spiral arrays. A spiral array
results from moving and rotating objects along the same axis. Combinations of transforms in
the Array dialog box can produce many interesting modeling possibilities.
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New '\ 3ds max 6 includes a new primitive object type for creating spiral staircases. Check it out in
Feature the AEC Objects submenu in the Create menu.

s

Tutorial: Building a spiral staircase

To create a spiral staircase, we will first need to create a simple rectangular box that can be
used for the steps. Because a spiral staircase winds about a center pole, we will need our
transform’s center to be located at one end of the stair object.

To create a spiral staircase, follow these steps:
1. Open the Spiral staircase.max file from the Chap 07 directory on the CD-ROM.

This file has the Top viewport maximized, which is the easiest view in which to create
the spiral staircase.

2. Select the Use Transform Coordinate Center flyout from the Use Center button on the
main toolbar.

This setting transforms the selected object about the center of the active viewport. You
should notice that the axes are relocated to the center of the viewport.

3. Select the single stair, and open the Array dialog box by choosing Tools => Array or by
clicking the Array button on the Extras toolbar. Before entering any values into the
Array dialog box, click the Reset All Parameters button.

4. In the Incremental section, enter the value of 50 in the Z column of the Move row, and
45 in the Z column of the Rotate row.

5. Set the 1D Count spinner to 20, and click the OK button to create the array.

Figure 7-14 shows the results of the spiral array in the Perspective viewport.

Working with a ring array

You can find the Ring Array system by opening the Create panel and selecting the Systems
category. Clicking the Ring Array button opens a Parameters rollout, shown in Figure 7-15. In
this rollout are parameters for the ring’s Radius, Amplitude, Cycles, Phase, and the Number of
elements to include.

The Ring Array command is missing from the Create menu.
-',,.l-’

You create the actual array by clicking and dragging in one of the viewports. Initially, all ele-
ments are simple box objects surrounding a green dummy object.
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Figure 7-14: Getting fancy with the Array feature produced this spiral staircase.
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Figure 7-15: The Parameters rollout of the Ring Array system
can create an oscillating circular array of objects.
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You can change the boxes that appear as part of the ring array to another object using the
Track View. To do so, you need to locate the copy object’s track and paste it where the ring
array's boxes are. Chapter 33, “Working with the Track View,” shows how to do this.

The Amplitude, Cycles, and Phase values define the sinusoidal nature of the circle. The
Amplitude is the maximum distance that you can position the objects from the horizontal
plane. If the Amplitude is set to 0, then all objects lie in the same horizontal plane. The Cycles
value is the number of waves that occur around the entire circle. The Phase determines
which position along the circle starts in the up position.

For example, Figure 7-16 shows a ring array with 20 elements, a Radius of 80, an Amplitude of
20, a Cycles value of 3, and a Phase of 1.0. The Dummy object in the middle lets you control
the entire ring’s position and orientation. If you want to animate a wave-like motion, you can
animate the Phase value moving between 0 and 1.
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Figure 7-16: This ring array has only two cycles.

Tutorial: Using Ring Array to create a carousel

Continuing with the theme park attractions motif, this example creates a carousel. The horse
model comes from Poser, but was simplified using the MultiRes modifier.

To use a Ring Array system to create a carousel, follow these steps.
1. Open the Carousel.max file from the Chap 07 directory on the CD-ROM.

This file includes a carousel structure made from primitives along with a carousel
horse.
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2. Open the Create panel, select the Systems category, and click the Ring Array button. Drag
in the Top viewport from the center of the carousel to create a ring array. Then enter a
Radius value of 250, an Amplitude of 20, a Cycles value of 3, and a Number value of 6.

3. Select the Dummy object in the Left viewport, and drag it upward with the Select and
Move tool until all the box objects are positioned between the carousel base and the

top cone.

4. Select the horse object, and click on the Mini Curve Editor button to the left of the
Track Bar. This opens the Track View to the horse object. Scroll downward in the Track
View to the Object (Editable Mesh) track, and select it. Then right-click and select Copy
from the pop-up menu.

5. Click one of the Ring Array dummy objects, and the Track View locates the Box object
that is part of the Ring Array. Then right-click and select the Paste command from the
pop-up menu. This opens the Paste dialog, shown in Figure 7-17. Select Instance and
the Replace all Instances option, and click OK.

®&| Figure 7-17: This Paste dialog lets you replace all

instances.

‘Paste
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Figure 7-18 shows the finished carousel. Notice that each horse is at a different height.
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Figure 7-18: The horses in the carousel were created using a Ring Array system.
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Summary

Many ways to clone an object are available. You can use the Clone command under the Edit
menu or the Shift-clone feature for quickly creating numerous clones. Clones can be copies,
instances, or references. Each differs in how it retains links to the original object. You can
also clone using the Mirror, Snapshot, and Spacing tools.

Arrays are another means of cloning. You can use the Array dialog box to produce clones in
three different dimensions, and you can specify the offset transformations.

This chapter covered the following cloning topics:
4 Cloning objects and Shift-cloning
4+ Understanding copies, instances, and references
4 Using the Mirror, Snapshot, and Spacing tools
4 Building linear, circular, and spiral arrays of objects
4+ Using the Ring Array system

In the next chapter, you learn to group objects and link them into hierarchies. Then you’ll be
able to organize all the objects that you've learned to create.

+ o+«
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Linking Objects
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In This Chapter

N ow that you've learned how to select and clone objects, you'll Grouping objects

want to learn how to group objects together in an easily acces-

sible form, especially as a scene becomes more complex. Max’s Building assemblies
grouping features enable you to organize all the objects that you're
dealing with, thereby making your workflow more efficient. Understanding roof,

parent, and child

Another way of organizing objects is to build a linked hierarchy. A Haierdiizs

linked hierarchy attaches, or links, one object to another and makes
it possible to transform the attached object by moving the one to
which it is linked. For example, the arm is a classic example of a
linked hierarchy —when the shoulder rotates, so do the elbow, wrist,
and fingers. Establishing linked hierarchies can make moving, posi- * * * *
tioning, and animating many objects easy.

Linking and unlinking
objects

Working with Groups

Grouping objects organizes them and makes them easier to select
and transform. Groups are different from selection sets in that groups
exist like one object. Selecting any object in the group selects the
entire group, whereas selecting an object in a selection set selects
only that object and not the selection set. You can open groups to
add, delete, or reposition objects within the group. Groups can also
contain other groups. This is called nesting groups.

Creating groups

The Group command enables you to create a group. To do so, simply
select the desired objects and choose Group = Group. A simple Name
Group dialog box opens and enables you to give the group a name.
The newly created group displays a new bounding box that encom-
passes all the objects in the group.

Tip You can always identify groups in the Select by Name dialog box
.. because they are surrounded by square brackets, and groups
4 appear in bold in the Name and Color rollout of the Command

Panel.

Ungrouping objects

The Ungroup command enables you to break up a group (kind of like
a poor music album). To do so, simply select the desired group and
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choose Group = Ungroup. This menu command dissolves the group, and all the objects
within the group revert to separate objects. The Ungroup command breaks up only the cur-
rently selected group. All nested groups within a group stay intact.

The easiest way to dissolve an entire group, including any nested groups, is with the Explode
command. This command eliminates the group and the groups within the group and makes
each object separate.

Opening and closing groups

The Open command enables you to access the objects within a group. Grouped objects
move, scale, and rotate as a unit when transformed, but individual objects within a group can
be transformed independently after you open a group with the Open command.

To move an individual object in a group, select the group and choose Group > Open. The
white bounding box changes to pink. Then select an object within the group, and move it
with the Select and Move button (keyboard shortcut, W). Choose Group = Close to reinstate
the group.

Attaching and detaching objects

The Attach and Detach commands enable you to insert or remove objects from an opened
group without dissolving the group. To attach objects to an existing group, select an object,
select the Attach menu command, and then click on the group to which you want to add the
object. To detach an object from a group, you need to open the group and select the Detach
menu command. Remember to close the group when finished.

Tutorial: Grouping a plane’s parts together

Positioning objects relative to one another takes careful and precise work. After spending the
time to place the wings, tail, and prop on a plane exactly where they need to be, transforming
these objects can spell disaster. By grouping all the objects together, you can move all the
objects at once.

For this tutorial, you can get some practice grouping all the parts of an airplane together.
Follow these steps:

1. Open the T-28 Trojan plane.max file from the Chap 08 directory on the CD-ROM. This
file includes a model created by Viewpoint Datalabs.

2. Click the Select by Name button on the main toolbar (or press the H key) to open the
Select by Name dialog box. In this dialog box, notice all the different plane parts. Click
the All button to select all the separate objects, and click the Select button to close the
dialog box.

3. With all the objects selected, choose Group = Group to open the Group dialog box. Give
the group the name Plane, and click OK.

4. Click the Select and Move button (or press W), and click and drag the plane.
The entire group now moves together.

Figure 8-1 shows the plane grouped as one unit. Notice how only one set of brackets sur-
rounds the deer in the Perspective viewport. The group name is displayed in the Name field
of the Command Panel instead of saying Multiple Selected.
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Figure 8-1: The plane moves as one unit after its objects are grouped.
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Building Assemblies

At the bottom of the Group menu is a menu item called Assembly with a submenu that looks
frightfully similar to the Group menu. The difference between a group and an assembly is that
an assembly can include a light object and it has a Luminaire helper object as its head. This
enables you build light fixtures where the light is actually grouped (or assembled) with the light
stand objects. Once built, you can control the light by selecting and moving the light assembly.

New \ The Assembly menu is new to 3ds max 6.
Feature

After you've create the geometry for a light assembly, you can create an assembly with the
Group = Assembly > Assemble menu command. This opens the Create Assembly dialog box,
shown in Figure 8-2, where you can name the assembly and add a Luminaire object as the
head object.

/ Note Characters that are created with the Character=> Create Character command are structurally
.~ the same as assemblies. Both have head objects that control the position of all the objects
that make up the structure.
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/ Note

/ Note

Create Assembly  2Je3| Figure 8-2: The Create Assembly dialog box lets you choose a light

Mame: |Desk light head Object.

Chaose head object:

Lurninaire

(]S Cancel

Because the Luminaire object is the head object, you can see its parameters in the Modify
panel whenever the assembly is selected. Its parameters include a Dimmer value and a Filter
Color. These parameters are used only if they are wired to an actual light object that is
included in the assembly.

If you apply a modifier to an assembly, it affects only the Luminaire head object, so
o Parametric Deformation modifiers like Twist have no effect. If you open the assembly, you
can select and apply a modifier to an individual assembly object.

Adding lights to assemblies

If you know that your light characteristics aren’t going to change, then set up the parameters
for your light object before you build the assembly and the light object will provide constant
light. If you ever need to change a light setting, just open the assembly with the Group =
Assembly = Open menu command. Then select the light object, and its parameters appear in
the Modify panel. After you’'ve changed the light parameters, close the assembly again with
the Group => Assembly => Close menu command.

Adding a light object to an assembly without wiring it to the Luminaire object works the
o same as if you grouped the objects with the Group command. The real benefit of an assem-
bly comes from wiring the light parameters.

All other commands in the Assembly submenu work just like their counterparts in the
Group menu.

Wiring Luminaire helper objects to light objects

Luminaire objects can be confusing because they don’t actually add light to an assembly. If
you're curious about the Luminaire objects, you can find them in the Assembly Heads subcat-
egory of the Helper category.

The benefit of the Luminaire helper object is that it can add to an assembly some simple
parameters that are accessible whenever the assembly is selected. These parameters work
only if you wire them to the parameters of the light object included in the assembly.
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\ You can learn more about wiring parameters in Chapter 30, “Animation Basics.”
ce

To wire the Luminaire parameters to the light object’s parameters, select the assembly and
open the Parameter Wiring dialog box with the Animation => Wire Parameters > Parameter
Wiring Dialog menu command. In the left pane, locate and select the Dimmer parameter
under the Object (Luminaire) track. Locate and select the Multiplier parameter under the
Object (Light) track, which is under the Assembly01 track in the right pane. Click the one-way
connection button in the center of the dialog box that links the Dimmer to the Multiplier
parameters, and click the Connect button. Next wire the FilterColor parameter to the light’s
Color parameter. Figure 8-3 shows the Parameter Wiring dialog box for this simple assembly.
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Figure 8-3: The Parameter Wiring dialog can make the
light object’s parameter.

After the assembly light is wired to the Luminaire parameters, you can use the Dimmer and
Filter Color parameters in the Modify panel whenever the assembly is selected.

Tutorial: Creating a flashlight assembly

One of the most portable of lights is the ubiquitous flashlight. In this tutorial, we create an
assembly and wire the light parameters to the Luminaire head object’s parameters.

To create a flashlight assembly, follow these steps:

1. Open the Flashlight assembly.max file from the Chap 08 directory on the CD-ROM.

This file includes a flashlight model with a single free spotlight.

2. Select all objects within the scene with the Edit = Select All (Ctrl+A) menu command.
Then select the Group => Assembly => Assemble menu command. In the Create Assembly
dialog box, name the assembly Flashlight and click OK.
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3. To wire the Luminaire head object’s parameters to the light object, select Animation >

Wire Parameters = Parameter Wire Dialog. This opens the Parameter Wiring dialog box
with the Object (Luminaire) track selected in the left pane. Expand the Object
(Luminaire) track, and select the Dimmer parameter.

. In the right pane of the Parameter Wiring dialog box, expand the Flashlight track, locate

and expand the Fspot01 light object, and select the Multiplier track under the Object
(Free Spot) track. Then click the Control Direction arrow in the center of the dialog box
that points to the right, and click Connect.

. With the Parameter Wiring dialog box still open, select the FilterColor track in the left

pane and the Color track in the right pane, and connect these two parameters with the
Connect button. Click on the Close button in the upper-right corner of the dialog box.

. In the Luminaire Parameters rollout of the Command Panel, drag the Dimmer parame-

ter down to 1.0 and watch light in the flashlight dim.

Figure 8-4 shows the resulting flashlight assembly. This light fixture can now be positioned
and used in the scene.
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Understanding Parent, Child, and Root
Relationships
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Max uses several terms to describe the relationships between objects. A parent object is an
object that controls any secondary, or child, objects linked to it. A child object is an object
that is linked to and controlled by a parent. A parent object can have many children, but a
child can have only one parent. Additionally, an object can be both a parent and a child at
the same time.

A hierarchy is the complete set of linked objects that includes these types of relationships.
Ancestors are all the parents above a child object. Descendants are all the children below a
parent object. The root object is the top parent object that has no parent and controls the
entire hierarchy.

Each hierarchy can have several branches or subtrees. Any parent with two or more children
represents the start of a new branch.

\ The default hierarchies established using the Link tool are referred to as forward-kinematics

(B2 systems, in which control moves forward down the hierarchy from parent to child. In for-
ward-kinematics systems, the child has no control over the parent. An inverse kinematics sys-
tem (covered in Chapter 37, “Using Inverse Kinematics”) enables child objects to control
their parents.

All objects in a scene, whether linked or not, belong to a hierarchy. Objects that aren’t linked
to any other objects are, by default, children of the world object, which is an imaginary
object that holds all objects.

You can view the world object, labeled Objects, in the Track View. Individual objects are listed
o under the Objects track by their object name.

You have several ways to establish hierarchies using Max. The simplest method is to use the
Link and Unlink buttons found on the main toolbar. You can also find these buttons in the
Schematic View window. The Hierarchy panel in the Command Panel provides access to valu-
able controls and information about established hierarchies. When creating complex hierar-
chies, the bones system can help.

The Schematic View window is covered in Chapter 9, “Working with the Schematic View,”
ce and bone systems are covered in Chapter 35, “Rigging Characters.”

Building Links between Objects

The main toolbar includes two buttons that you can use to build a hierarchy: Link and Unlink.
The order of selection defines which object becomes the parent and which becomes the child.
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Tip

Linking objects
% The Link button always links children to the parents. To remind you of this order,
remember that a parent can have many children, but a child can have only one parent.

To link two objects, click the Link button. This places you in Link mode, which continues until
you turn it off by selecting another button, such as the Select button or one of the Transform
buttons. When you're in Link mode, the Link button is highlighted dark yellow.

With the Link button highlighted, click an object, which will be the child, and drag a line to
the target parent object. The cursor arrow changes to the link icon when it is over a potential
parent. When you release the mouse button, the parent object flashes once and the link is
established. If you drag the same child object to a different parent, the link to the previous
parent is replaced by the link to the new parent.

Once linked, all transformations applied to the parent are applied equally to its children
about the parent’s pivot point. A pivot point is the center about which the object rotates.

Unlinking objects

3. The Unlink button is used to destroy links, but only to the parent. For example, if a
“ [0 selected object has both children and a parent, clicking the Unlink button destroys
the link to the parent of the selected object, but not the links to its children.

To eliminate all links for an entire hierarchy, double-click an object to select its entire hierar-
chy and click the Unlink button.

Tutorial: Creating a solar system

Because the planets in the solar system all rotate about the sun, a solar system is a good
model to show the benefits of linking. After you link all the planets to the sun, you can reposi-
tion the entire system simply by moving the sun.

To create a solar system of spheres that are linked together, follow these steps:
1. Open the Linked solar system.max file from the Chap 08 directory on the CD-ROM.
This file includes spheres that represent all the planets in the solar system.
2. Click the Link button in the main toolbar, and drag a line from each planet to the sun

object.

You can link several objects at once by holding down the Ctrl key, clicking to select each
.. object to link, and dragging to the parent object. This procedure creates a link between the
# parent object and each selected object.

3. Click the Saturn rings object, and drag it to the Saturn object that it surrounds.

4. Click the Select and Rotate button (or press the E key), and rotate the sun. Notice how
all the planets rotate with the sun.

Figure 8-5 shows the planets as they orbit about the sun. The Link button made it possible to
rotate all the planets simply by rotating their parent.
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Figure 8-5: Linked child planets inherit transformations from their parent sun.

Displaying Links and Hierarchies

The Display panel includes a rollout that lets you display all the links in the viewports.

After links have been established, you can see linked objects listed as a hierarchy in several
places. The Select Objects dialog box, opened with the Select by Name button (or with the
H key), can display objects in this manner, as well as the Schematic and Track Views.

Displaying links in the viewport

You can select to see the links between the selected objects in the viewports by selecting the
Display Links option in the Link Display rollout of the Display panel. The Display Links option
shows links as lines that run between the pivot points of the objects with a diamond-shaped
marker at the end of each line; these lines and markers are the same color as the object.

/Note The Display Links option can be enabled or disabled for each object in the scene. To display
~~  the links for all objects, use the Edit=> Select All (Ctrl+A) command and then enable the
Display Links option.
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The Link Display rollout also offers the Link Replaces Object option, which removes the
objects and displays only the link structure. This feature removes the complexity of the
objects from the viewports and lets you work with the links directly. Although the objects
disappear, you can still transform the objects using the link markers.

Figure 8-6 shows the solar system that we created in the previous tutorial with the Display
Links option enabled for all links.

Viewing hierarchies

The Select Objects dialog box and the Schematic and Track Views can display the hierarchy
of objects in a scene as an ordered list, with child objects indented under parent objects.

Clicking the Select by Name button (H) on the main toolbar opens the Select Objects dialog
box; click the Display Subtree option to see all the children under the selected object. Figure
8-7 shows the Select Parent dialog box with the Display Subtree option selected.
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Figure 8-6: The solar system example with all links visible
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Figure 8-7: The Select Parent dialog box indents all
child objects under their parent.

The Schematic View (opened with the Graph Editors = New Schematic View menu command)
presents a graph in which objects are represented by rectangles with their hierarchical links
drawn as lines running between them. The Schematic View window is covered in the next
chapter.

The Track View (opened with the Graph Editors => New Track View menu command) displays
lots of scene details in addition to the object hierarchy. In the Track View, you can easily
expand and contract the hierarchy to focus on just the section you want to see or select.

|, gr?ss- \ For more information on using the Track View, see Chapter 33, “Working with the Track View.”
eference

Working with Linked Objects

If you link some objects together and set some animation keys, and the magical Play button
starts sending objects hurtling off into space, chances are good that you have a linked object
that you didn’t know about. Understanding object hierarchies and being able to transform
those hierarchies are the keys to efficient animation sequences.

All transformations are done about an object’s pivot point. You can move and reorient these
pivot points as needed by clicking the Pivot button under the Hierarchy panel.
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Several additional settings for controlling links are available under the Hierarchy panel of the
Command Panel (the Hierarchy panel tab looks like a mini-organizational chart). Just click the
Link Info button. This button opens two rollouts if a linked object is selected. You can use the
Locks and Inherit rollouts to limit an object’s transformations and specify the transforma-
tions that it inherits.

| present more information on object transformations in Chapter 10, “Transforming Objects —
ce Translate, Rotate, and Scale”

Selecting hierarchies

You need to select a hierarchy before you can transform it, and you have several ways to do
so. The easiest method is to simply double-click an object. Double-clicking the root object
selects the entire hierarchy, and double-clicking an object within the hierarchy selects it and
all of its children.

After you select an object in a hierarchy, pressing the Page Up or Page Down keyboard short-
cut selects its parent or child objects. For example, if you select the Sun object and press
Page Down, all planet objects are selected and the Sun object is deselected. Selecting any of
the planet objects and pressing Page Up selects the Sun object.

Linking to dummies

Dummy objects are useful as root objects for controlling the motion of hierarchies. By linking
the parent object of a hierarchy to a dummy object, you can control all the objects by moving
the dummy.

To create a dummy object, select Create > Helpers => Dummy, or open the Create panel and
click the Helpers category button (this button looks like a small tape measure) and select the
Standard category. Within the Object Type rollout is the Dummy button; click it, and then
click in the viewport where you want the dummy object to be positioned. Dummy objects
look like wireframe box objects in the viewports, but dummy objects are not rendered.

Tutorial: Circling the globe

When you work with complex models with lots of parts, you can control the object more eas-
ily if you link it to a Dummy object and then animate the dummy object instead of the entire
model. To practice doing this, we create a simple animation of an airplane flying around the
globe. To perform this feat, we create a dummy object in the center of a sphere, link the air-
plane model to it, and rotate the dummy object. This tutorial involves transforming and ani-
mating objects, which are covered in later chapters.

Rotating objects is covered in Chapter 10, “Transforming Objects —Translate, Rotate, and
(B2 Scale,” and the basics of animation are covered in Chapter 30, “Animation Basics.”

To link and rotate objects using a dummy object, follow these steps:
1. Open the Circling the globe.max file found in the Chap 08 directory on the CD-ROM.

This file includes a transparent wireframe sphere with an airplane model positioned
above it. The airplane model was created by Viewpoint Datalabs.
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. Select Create > Helpers = Dummy, and then drag in the center of the Sphere to create a

Dummy object.

. Because the dummy objects is inside the sphere, creating the link between the airplane

and the dummy object can be difficult. To simplify this process, select and right-click
the sphere object, and then select Hide Selection from the pop-up menu.

This hides the sphere so that you can create a link between the airplane and the
dummy object.

. Click the Link button on the main toolbar, and drag a line from the airplane to the

dummy object.

. Click the Auto Key button (or press N) to enable animation key mode, and drag the

Time Slider to frame 100. Then click the Select and Rotate button on the main toolbar
(or press E), and select the dummy object. Then rotate the dummy object, and notice
how the linked airplane also rotates over the surface of the sphere.

. Select the dummy object, and right click to access the pop-up quadmenu. Then select

the Unhide All menu command to make the sphere visible again.

By linking the airplane to a dummy object, you don’t have to worry about moving the air-
plane’s pivot point to get the correct motion. Figure 8-8 shows a frame from the final scene.
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Figure 8-8: With a link to a dummy object, making the airplane circle the globe is easy.
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Summary

As scenes become more complex, the name of the game is organization. You can organize
objects within the scene in several ways, including grouping, linking, and building hierarchies.

In this chapter, you’ve done the following:
4 Grouped objects using the Group menu and learned to work with groups
4 Learned about parent, child, and root relationships
4 Created a hierarchy of objects using the Link and Unlink features
4 Viewed links in the viewport
4 Learned how to create and use dummy objects

In the next chapter, you learn how to use an interface that helps as you organize scenes of
objects —the Schematic View window.

+ o+ ¢



CHAPTER

Working with the
Schematic View

+ o+ e

In This Chapter

Avaluable tool for selecting, linking, and organizing scene objects Working with the

is the Schematic View window. This window offers a 1,000-foot Selhemaie View

view of the objects in your scene. From this whole scene perspective, e

you can find the exact item you seek.

The Schematic View window shows all objects as simple nodes and ?]/?/orkinﬁ with
ierarchies

uses arrows to show relationships between objects. This structure
makes the Schematic View window the easiest place to establish links
and to wire parameters. You can also use this view to quickly see all
the instances of an object.

Setting Schematic View
preferences

Using List Views
Using the Schematic View Window o+ e e

A great way to organize and select objects is by using the Schematic
View window. Every object in the Schematic View is displayed as a
rectangular box. These boxes, or nodes, are connected to show the
relationships among them. You can rearrange them and save the cus-
tomized views for later access.

IF“thv \ The Schematic View window has been overhauled for 3ds max 6.
eature

You access the Schematic View window via the Graph Editors
menu command or by clicking its button on the main toolbar.
When the window opens, it floats on top of the Max interface and can
be moved by dragging its title bar. You can also resize the window by
dragging on its borders. The window is modeless and lets you access
the viewports and buttons in the interface beneath it.

The Graph Editors menu options

The Schematic View menu options enable you to manage several dif-
ferent views. The Graph Editors => New Schematic View command
opens the Schematic View window, shown in Figure 9-1. If you enter a
name in the View Name field at the top of the window, you can name
and save the current view. This name then appears in the Graph
Editors > Saved Schematic Views submenu and also in the title bar
when the saved view is open.
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Tip

/-

[

Every time the Graph Editors = New Schematic View menu command is used, a new view
name is created and another view is added to the Saved Schematic Views submenu. The

Schematic View = Delete Schematic View command opens a dialog box in which you can
select the view you want to delete.

You can open any saved Schematic View window (or a new Schematic View window) within

.. aviewport by right-clicking the viewport title, choosing Views = Schematic, and clicking the
4 view name in the pop-up menu.

View Name

My Saved View =]
Edit Select View Layout ListViews Options

Ok 24X [EAIE ==as |3 |7a 5B |Feeave e O @

T

) ) I [w
<] [ ——— | (]
@ [Seach [ Elick or dlick-and diag o select objects QAT T

Figure 9-1: The Schematic View window displays all objects
as nodes.

The Schematic View interface

The Schematic View window includes several common interface elements including menus,
toolbar buttons, and a right-click quadmenu. Just like the main interface, you can access the
commands in many ways.

Using the Schematic View menus
The Schematic View window includes menus at the top of its interface, including Edit, Select,
View, Layout, List Views, and Options.

The Edit menu includes commands to Connect (C) and Unlink Selected object nodes. It also
includes a Delete command, which deletes an object from the viewports as well as from the
object node. The Edit menu includes features to Assign Controllers, Wire Parameters, and
open the Object Properties dialog box.

Many of the keyboard shortcuts for the Schematic View window are the same as those in the
- main interface. If you enable the Keyboard Shortcut Override Toggle on the Extras toolbar,
then you can use the Schematic View keyboard shortcuts.
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The Select menu includes commands for accessing the Select tool (S); selecting All (Ctrl+A),
None (Ctrl+D), and Invert (Ctrl+]); selecting (Ctrl+C) and de-selecting children; and com-
mands to synch the selected nodes in the Schematic View with the scene (Select From Scene)
and vice versa (Select to Scene).

The View menu includes commands for selecting the Pan, Zoom, and Zoom Region tools.
You can also access the Zoom Extents, Zoom Extents Selected (Z), and Pan to Selected com-
mands. The View menu also includes options to Show/Hide Grid (G), Show/Hide Background,
and Refresh View.

The Layout menu includes various options for controlling how the nodes are arranged. The
Display Floater (D) command opens the Display floater, which can be used to select the types
of nodes to display. The Align submenu lets you align selected nodes to the Left, Right, Top,
Bottom, Center Horizontal, or Center Vertical. You can also Expand, Collapse, or Hide
Selected, Unhide All, Arrange Children, or Arrange Selected. The Free Selected (Alt+S) and
Free All (Alt+F) commands remove nodes from being auto arranged. With the Layout menu,
you can also Shrink Selected, Unshrink Selected, Unshrink All, and Toggle Shrink (Ctrl+S).

The List Views menu determines what is shown in the Schematic View. Options include All
Relationships, Selected Relationships, All Instances, Selected Instances, Show Occurrences,
and All Animated Controllers. Many of these options are also available in the Display Floater.

The Options menu lets you select the Always Arrange option and view mode (either
Hierarchy and Reference modes). You can also select the Move Children (Alt+C) option and
open the Schematic View Preferences dialog box.

Learning the toolbar buttons

You can also select most of these commands from the toolbar. Many of the toolbar buttons
are toggle switches that enable and disable certain viewing modes. The background of these
toggle buttons is highlighted yellow when selected. You'll also find some buttons along the
bottom of the window. All Schematic View icon buttons are shown in Table 9-1 and are
described in the following sections.

The Schematic View toolbar buttons are permanently docked to the interface and cannot be
-y removed.

Table 9-1: Schematic View Toolbar Buttons

Toolbar Button Name Description

@ Display Floater Opens the Display Floater, where you can toggle
which items are displayed or hidden.

E Select (S) Toggles selection mode on, where nodes can be
selected by clicking.

% Connect (C) Enables you to create links between objects in the
Schematic View window; also used to copy
modifiers and materials between objects.

-} Unlink Selected Destroys the link between the selected object

] - and its parent.

Continued
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Table 9-1 (continued)

Toolbar Button

Name

Description

o il X

G0 ol G% G 6F M 0 K

o ¥

| My 5 aved View

IM_I,I Bookmark:

&
®

[~

Delete Objects

Hierarchy Mode

References Mode

Always Arrange

Arrange Children

Arrange Selected

Free All

Free Selected

Move Children

Expand Selected

Collapse Selected

Preferences

View Name field

Bookmark Name

Go to Bookmark

Delete Bookmark

Deletes the selected object in both the
Schematic View and in the viewports.

Displays all child objects indented under their
parents.

Displays all object references and instances. This
mode displays all materials and modifiers
associated with the objects.

Causes all nodes to be automatically arranged in
a hierarchy or in references mode, and disables
moving of individual nodes.

Automatically rearranges the children of the
selected object nodes.

Automatically rearranges the selected object
nodes.

Allows all objects to be freely moved without
being automatically arranged.

Allows selected objects to be freely moved
without being automatically arranged.

Causes children to move along with their parent
node.

Reveals all nodes below the selected node.
Rolls up all nodes below the selected node.
Opens the Preferences dialog box.

Enter a name into this field to name the current
display. Named displays show up underneath the
Graph Editors { Saved Schematic View submenu.

Marks a selection of nodes to which you can
return later.

Zooms and pans to the selected bookmarked
objects.

Removes the bookmark from the Bookmark
selection list.
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Most of the menu and toolbar buttons commands are available in a pop-up menu that you
o can access by right-clicking in the Schematic View window.

Navigating the Schematic View window

As the number of nodes increases, it can become tricky to locate and see the correct node to
work with. Along the bottom edge of the Schematic View window are several navigation but-

tons that work similarly to the Viewport Navigation Control buttons. Using these buttons, you
can pan, zoom, and zoom to the extents of all nodes. These buttons are described in Table 9-2.

The Schematic View navigation buttons can also be accessed from within the View menu.
These menu commands include Pan Tool, Zoom Tool, Zoom Region Tool, Zoom Extents,

Zoom Extents Selected (Z), and Pan to Selected.

You can also navigate the Schematic View window using the mouse and its scroll wheel.
.. Scrubbing the mouse wheel zooms in and out of the window in steps. Holding down the Ctrl
# key and dragging with the scroll wheel button zooms smoothly in and out of the window.

Dragging the scroll wheel pans within the window.

Table 9-2: Schematic View Navigation Buttons

Toolbar Button Name Description
% Zoom Selected Zooms in on the nodes that correspond to
Viewport Object the selected viewport objects.
Search Name field Locates an object node when you type its
| Search name.
'Err? Pan Moves the node view when you drag in
the window.
I:l Zoom Zooms when you drag the mouse in the
window.

Region Zoom

I

Zoom Extents

T i |
H

Zoom Extents
Selected

[ i |
|

Pan to Selected

o

Zooms to an area selected when you drag
an outline.

Increases the window view until all nodes
are visible.

Increases the window view until all
selected nodes are visible.

Moves the node view at the current zoom
level to the selected objects.

As you navigate the Schematic View window, you can save specific views as bookmarks by

typing an identifying name in the Bookmark drop-down list. To recall these views later, select
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them from the drop-down list and click the Go to Bookmark icon in the Schematic View tool-
bar. Bookmarks can be deleted with the Delete Bookmark button.

Working with Schematic View nodes

Every object displayed in the scene has a node— a simple rectangular box that represents
the object or attribute. Each node contains a label, and the color of the node depends on the
node type.

Node colors
Nodes have a color scheme to help identify them. The colors of various nodes are listed in

Table 9-3.
Table 9-3: Schematic View Node Colors
Color Name
White Selected node
Blue Geometry Object node
Cyan Shape Object node
Yellow Light Object node
Dark Blue Camera Object node
Green Helper Object node
Purple Space Warp Object node
Goldenrod Modifier node
Dark Yellow Base Object node
Brown Material node
Dark Green Map node
Salmon Controller node
Magenta Parameter Wires
_./Note If you don't like any of these colors, you can set the colors used in the Schematic View using

—  the Colors panel of the Customize User Interface dialog box.

Selecting nodes

The Select (S) button enters select mode, which lets you select nodes within the Schematic
View window by clicking the object node. You can select multiple objects by dragging an out-
line over them. Holding down the Ctrl key while clicking an object node selects or deselects
it. Selected nodes are shown in white.
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The Select menu includes several selection commands that enable you to quickly select
(or deselect) many nodes, including Select All (Ctrl+A), Select None (Ctrl+D), Select Invert
(Ctlr+I), Select Children (Ctrl+C), and Deselect Children.

If the Select => Sync Selection option in the Select menu is enabled, then the node of any
object that is selected in the viewports is also selected in the Schematic View window and
vice versa. If you disable the Sync Selection option, then you can select different objects in
the viewports and in the Schematic View at the same time. The node of the object selected in
the viewports is outlined in white, and the interior of selected nodes is white. To select all the
objects in the viewports that match the selected nodes without the Sync Selection option
enabled, just use Select > Select to Scene. Select => Select From Scene selects the nodes for all
objects selected in the viewports.

All animated objects have their node border drawn in red.

e
g

y
Rearranging nodes

Schematic View includes several options for arranging nodes. In the Options menu, you can
toggle between Hierarchy and Reference modes. Hierarchy mode displays the nodes verti-
cally with child objects indented under their parent. Reference mode displays the nodes hori-
zontally allowing for plenty of room to display all the various reference nodes under each
parent node. Figure 9-2 shows both of these modes side by side.

Schematic View 1 =J0E3 Schematic View 1 e

Edit Select View Layout Edit Select View Layout ListViews Options

HEEIE R S O [% X AT sSas|2 v | [Femmwe [
T
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o

o e T e T— 2]
= ol (e ] [ Click o click-and-drag to select objects &mQ B 080

Figure 9-2: The Schematic View window can automatically arrange nodes in
two different modes: Hierarchy and Reference.

You can move nodes and rearrange them in any order. To move a node, simply click and drag
it to a new location. When a node is dragged, all selected nodes move together, and any links
follow the node movement. If a child node is moved, all remaining child nodes collapse
together to maintain the specified arrangement mode. The moved node then becomes free,
which is designated by an open rectangle on the left edge of the node. Figure 9-3 shows two
nodes that were moved and thereby became free. The other children automatically moved
closer together to close the gaps made by the moving nodes.
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Free nodes

Figure 9-3: Free nodes are moved independent of the arranging
mode.

Using the Layout => Free Selected (Alt+S) and Free All (Alt+F) menu commands, you can free
the selected nodes or all nodes. You can also designate that all the children of a node be auto
arranged with the Layout = Arrange Children menu command or that just the selected nodes
be arranged (Layout = Arrange Selected). The Options = Move Children (Alt+C) command
causes all children to be moved along with their parent when the parent is moved. This
causes free and non-free nodes to move with their parent.

If the Options = Always Arrange option is enabled, then Max automatically arranges all the
nodes using either the Hierarchy or Reference mode, but you cannot move any of the nodes
while this option is enabled. If you've moved any nodes when the Always Arrange option is
selected, a dialog box appears telling you that your custom layout will be lost. If the Always
Arrange option is enabled, the Arrange Children, Free All (Alt+F), Free Selected (Alt+S), Move
Children (Alt+C), and all the Align options are all disabled. If two or more nodes are selected,
you can align them using the Layout => Align menu. The options include Left, Right, Top,
Bottom, Center Horizontal, and Center Vertical.

Hiding, shrinking, and deleting nodes

If your Schematic View window starts to get cluttered, you can always hide nodes to simplify
the view. To hide a node, select the nodes to hide and use the Layout = Hide Selected menu
command. The Layout => Unhide All menu command can be used to make the hidden nodes
visible again.

If you hide a parent object, all its children nodes are also hidden.
-',,.rl’

Another useful way to reduce clutter in the Schematic View window is with the Layout =
Shrink Selected command. This command replaces the rectangular node with a simple dot,
but all hierarchical lines to the node are kept intact. Figure 9-4 shows a Schematic View with
several shrunk nodes. Shrunk nodes can be unshrunk with the Layout UnShrink Selected and
UnShrink All menu commands.

The Shrink commands work only when Layout > Toggle Shrink (Ctrl+S) is enabled. With this
o command, you can turn on and off the visibility of shrunken nodes.
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Shrunk nodes

Figure 9-4: Shrunk nodes appear as simple dots in the
Schematic View.

To delete a node, select the node and click the Delete Objects button on the Schematic View
toolbar or press the Delete key. If several nodes are selected, they are all deleted. This deletes
the object in the viewports also.

Renaming objects

In the Schematic View window, you can rename objects quickly and conveniently. To rename
an object, click a selected node and click again to highlight the text. When the text is high-
lighted, you can type the new name for the object. This works only for nodes that have a
name, which includes materials.

Tutorial: Rearranging the Solar System

To practice moving nodes around, we order the solar system model that was linked in the
preceding chapter. When Max places nodes in the Schematic View, it really doesn’t have any
specific order that it follows, but you can move them as needed by hand.

To rearrange the solar system nodes, follow these steps.
1. Open the Ordered solar system.max file from the Chap 09 directory on the CD-ROM.
This file includes several named spheres representing the solar system.
2. Select Graph Editors > New Schematic View to open the Schematic View window.
All planets are displayed as blue nodes under the Sun object.

3. Select Options => Reference Mode to position all the nodes horizontally. Click the Select
tool on the main toolbar (or press the S key).

4. Make sure that the Options => Always Arrange option is disabled. Then click and drag
the Mercury node to the left, and place it front of the Venus node.

5. Select the Options => Move Children (Alt+C) menu command, and drag and drop the
Saturn node between the Jupiter and Uranus nodes. With the Move Children option
enabled, the Saturn rings node moves with its parent.

6. Drag and drop the Pluto node beyond the Neptune node.
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7. Select all the planet nodes, and choose Layout &> Align = Top to align all the nodes
together.

Figure 9-5 shows the rearranged hierarchy with all the planets lined up in order.
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Figure 9-5: After rearranging nodes to the correct order, the
planets are easy to locate.

Working with Hierarchies

Another key benefit of the Schematic View is to see the relationships between different
objects. With the Schematic View open, you can quickly tell which objects are children and
which are parents. You can also see which objects have modifiers and which have materials
applied. You can get a wealth of knowledge from the Schematic View.

Using the Display floater

With all relationships enabled, the Schematic View becomes a mess. Luckily, you can control
which Relationships and which Entities are displayed using the Display floater, shown in
Figure 9-6.

Display [ Figure 9-6: The Display floater can turn nodes and lines on and off in the
[ Reletnships Schematic View.

J Constraints
[ controllers
ﬂ Param Wires
J Light Inclusion
|— Modifiers

r Entities
r Base Objects
J Modifier Stack.
J Materials

J Controllers

P| R| S|
Expand  Focus




Tip

Chapter 9 4 Working with the Schematic View

The top section of the Display floater shows or hides relationships between nodes, which are
displayed as lines. The relationships that you can control include Constraints, Controllers,
Param Wires, Light Inclusion, and Modifiers. If you hold the mouse over these relationship
lines, the details of the relationship are shown in the tooltip that appears.

For some relationships, you can double-click on the relationship line to open a dialog box
.. where you can edit the relationship. For example, double-clicking on a Parameter Wire rela-
4 tionship line opens the Parameter Wiring dialog box.

The lower section lets you show or hide entities that are displayed as nodes, including Base
Objects, Modifier Stack, Materials, and Controllers. The P, R, and S buttons let you turn on
Positional, Rotational, and Scale controllers. When a node has a relationship with another
node, the right end of the node displays an arrow. Clicking this arrow toggles the relationship
lines on and off.

The Expand button shows the actual nodes when enabled, but only an arrow that can be
clicked on to access the nodes if disabled. The Focus button shows all related objects as
colored nodes and all other nodes are unshaded.

Figure 9-7 shows a Schematic View with the Base Objects and Controllers Entities selected

in the Display floater. The Expand button is also disabled. This makes up and down arrows
appear above each node. Clicking the up arrow collapses the node, rolling it up into its parent.
Clicking the down arrow expands the node and displays the Base Object and Controller nodes
for the node that you clicked on, such as the Earth node in Figure 9-7. You can also expand and
collapse nodes with the Layout => Expand Selected and Collapse Selected menu commands.
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Collapse (up) arrow

Expand (down) arrow

Figure 9-7: Schematic View nodes can be collapsed or expanded
by clicking the up and down arrows.

Hierarchical relationships are shown as lines that connect the nodes. Even if the nodes are
moved, the lines follow as needed to show the relationship between the nodes.
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Connecting nodes

To create a hierarchy, use the Edit => Connect (C) menu command or click the Connect button
on the Schematic View toolbar. This enters Connect mode, which lets you link objects
together; copy modifiers, materials, or controllers between nodes; or even wire parameters.

For linking nodes, the Connect button works the same way here as it does on the main
toolbar — selecting the child node and dragging a line from the child node to its parent.
You can even select multiple nodes and link them all at once.

The Edit = Unlink Selected menu command (and toolbar button) destroys the link between
any object and its immediate parent. Remember that every child object can have only one
parent.

Copying modifiers and materials between nodes

Before you can copy materials or modifiers between nodes, you need to make sure that they are
visible. Materials and modifiers nodes show up only if they are enabled in the Display floater.
You can access this floater by clicking the Display floater button (or by pressing the D key).

To copy a material or modifier, select the material node for one object, click the Connect (C)
button, and drag the material to another object node.

In the Schematic View, materials can be copied only between objects —you cannot apply
o new materials from the Material Editor to Schematic View nodes.

When modifiers are copied between nodes, a dialog box appears giving you the chance to
Copy, Move, or Instance the modifier. You can also use the Schematic View window to reorder
the Modifier Stack. Using the Connect tool, just drag the modifier node to the modifier node
that you want to be beneath and the stack is reordered.

Assigning controllers and wiring parameters

If controller nodes are visible, you can copy them to another 